summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2019-08-02 21:59:53 +0100
committerJames Le Cuirot <chewi@gentoo.org>2019-08-02 21:59:53 +0100
commit7c9adb59daba6e9d352585b527022cb8698371d2 (patch)
tree990a747d4b282dde18acb911048a0dc24518ef32 /games-simulation
parentwww-client/chromium: security cleanup (diff)
downloadgentoo-7c9adb59daba6e9d352585b527022cb8698371d2.tar.gz
gentoo-7c9adb59daba6e9d352585b527022cb8698371d2.tar.bz2
gentoo-7c9adb59daba6e9d352585b527022cb8698371d2.zip
games-simulation/train-valley: New package
Package-Manager: Portage-2.3.70, Repoman-2.3.16 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'games-simulation')
-rw-r--r--games-simulation/train-valley/Manifest1
-rw-r--r--games-simulation/train-valley/metadata.xml11
-rw-r--r--games-simulation/train-valley/train-valley-1.3.31403.ebuild61
3 files changed, 73 insertions, 0 deletions
diff --git a/games-simulation/train-valley/Manifest b/games-simulation/train-valley/Manifest
new file mode 100644
index 000000000000..2e3e1fcf138f
--- /dev/null
+++ b/games-simulation/train-valley/Manifest
@@ -0,0 +1 @@
+DIST train_valley_1_3_31403.sh 196066169 BLAKE2B fe9e6ae5b0ef76794823dc86ed100fdac355d3929d85a9a12096f79cf9e6f946e2c85b5b737ebcab813ceef29094734f74546fff06124fe4bf07ef224d5842ff SHA512 16fd627f8ca6399579b17d7a4ce29caba554fbfb0dc72b40827f1c3a061d8c238a7faeb1b5171917362d381642e8cb066cdad5556fb71f4d27225bf227d735cd
diff --git a/games-simulation/train-valley/metadata.xml b/games-simulation/train-valley/metadata.xml
new file mode 100644
index 000000000000..1dbebd848c81
--- /dev/null
+++ b/games-simulation/train-valley/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <use>
+ <flag name="gui">Install the GUI for configuring screen resolution and input</flag>
+ </use>
+</pkgmetadata>
diff --git a/games-simulation/train-valley/train-valley-1.3.31403.ebuild b/games-simulation/train-valley/train-valley-1.3.31403.ebuild
new file mode 100644
index 000000000000..eeda5d017b72
--- /dev/null
+++ b/games-simulation/train-valley/train-valley-1.3.31403.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit eutils desktop unpacker xdg-utils
+
+DESCRIPTION="Build railroads in order to connect cities, tunnels, and bridges"
+HOMEPAGE="http://train-valley.com/tv1.html"
+SRC_URI="${P//[-.]/_}.sh"
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE="+gui"
+RESTRICT="bindist fetch splitdebug"
+
+RDEPEND="
+ virtual/opengl
+ x11-libs/libX11
+ x11-libs/libXrandr
+ gui? (
+ dev-libs/glib:2
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:2
+ )
+"
+
+S="${WORKDIR}/data/noarch/game"
+
+DIR="/opt/${PN}"
+QA_PREBUILT="${DIR}/*"
+
+pkg_nofetch() {
+ einfo "Please buy and download ${SRC_URI} from:"
+ einfo " https://www.gog.com/game/${PN//-/_}"
+ einfo "and move it to your distfiles directory."
+}
+
+src_unpack() {
+ unpack_zip ${A}
+}
+
+src_install() {
+ exeinto "${DIR}"
+ newexe ${PN}.$(usex amd64 x86_64 x86) ${PN}
+ make_wrapper ${PN} "${DIR}"/${PN}
+
+ insinto "${DIR}"
+ doins -r ${PN}_Data/
+ rm -r "${ED}/${DIR}"/${PN}_Data/*/$(usex amd64 x86 x86_64) || die
+
+ if ! use gui; then
+ rm "${ED}/${DIR}"/${PN}_Data/Plugins/*/ScreenSelector.so || die
+ fi
+
+ newicon -s 128 ${PN}_Data/Resources/UnityPlayer.png ${PN}.png
+ make_desktop_entry ${PN} "Train Valley"
+}
+
+pkg_postinst() { xdg_icon_cache_update; }
+pkg_postrm() { xdg_icon_cache_update; }