summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-09-22 13:31:47 -0500
committerAustin English <wizardedit@gentoo.org>2016-09-22 14:27:56 -0500
commit7ab9320b159a47dc4a580d033021dfe50dace049 (patch)
tree1dcc7bd584a89e03cff4f1b6f3217ee30ae2c598 /games-sports/bygfoot
parentgames-sports/dustrac: remove deprecated games eclass (diff)
downloadgentoo-7ab9320b159a47dc4a580d033021dfe50dace049.tar.gz
gentoo-7ab9320b159a47dc4a580d033021dfe50dace049.tar.bz2
gentoo-7ab9320b159a47dc4a580d033021dfe50dace049.zip
games-sports/bygfoot: remove deprecated games eclass
Also update to EAPI 6 Gentoo-Bug: https://bugs.gentoo.org/574082 Package-Manager: portage-2.3.0
Diffstat (limited to 'games-sports/bygfoot')
-rw-r--r--games-sports/bygfoot/bygfoot-2.3.2-r1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/games-sports/bygfoot/bygfoot-2.3.2-r1.ebuild b/games-sports/bygfoot/bygfoot-2.3.2-r1.ebuild
new file mode 100644
index 000000000000..c2b659108050
--- /dev/null
+++ b/games-sports/bygfoot/bygfoot-2.3.2-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit eutils
+
+DESCRIPTION="GTK+2 Soccer Management Game"
+HOMEPAGE="http://bygfoot.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="
+ app-arch/zip
+ media-libs/freetype:2
+ x11-libs/gtk+:2
+ virtual/libintl"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e 's:$(gnulocaledir):/usr/share/locale:' \
+ -e '/PACKAGE_LOCALE_DIR/s:\$(prefix)/\$(DATADIRNAME):/usr/share:' \
+ -e '/bygfoot_LDADD/s/$/ -lm/' \
+ po/Makefile.in.in src/Makefile.in || die
+}
+
+src_configure() {
+ econf --disable-gstreamer
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ esvn_clean "${D}"
+ dodoc AUTHORS ChangeLog README TODO UPDATE
+ newicon support_files/pixmaps/bygfoot_icon.png ${PN}.png
+ make_desktop_entry ${PN} Bygfoot
+}