summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-10-26 08:31:32 +0100
committerMichał Górny <mgorny@gentoo.org>2020-10-26 08:38:58 +0100
commit343943a7e3476ff60a4249954548509788cbfdd7 (patch)
tree66be01a96265cac7b7a9878381e7b39fd5d7fcf2 /games-sports
parentgames-strategy/endless-sky: Remove last-rited pkg (diff)
downloadgentoo-343943a7e3476ff60a4249954548509788cbfdd7.tar.gz
gentoo-343943a7e3476ff60a4249954548509788cbfdd7.tar.bz2
gentoo-343943a7e3476ff60a4249954548509788cbfdd7.zip
games-sports/vdrift: Remove last-rited pkg
Closes: https://bugs.gentoo.org/735540 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'games-sports')
-rw-r--r--games-sports/vdrift/Manifest2
-rw-r--r--games-sports/vdrift/files/vdrift-20120722-build.patch28
-rw-r--r--games-sports/vdrift/files/vdrift-20120722-bullet.patch100
-rw-r--r--games-sports/vdrift/metadata.xml11
-rw-r--r--games-sports/vdrift/vdrift-20120722.ebuild70
5 files changed, 0 insertions, 211 deletions
diff --git a/games-sports/vdrift/Manifest b/games-sports/vdrift/Manifest
deleted file mode 100644
index 7fc27d8f2fb8..000000000000
--- a/games-sports/vdrift/Manifest
+++ /dev/null
@@ -1,2 +0,0 @@
-DIST vdrift-2012-07-22.tar.bz2 589288618 BLAKE2B ccdd6358f7d753a87eb8d9d0603001ab3ca6f5c8572348c300a75961f58eb624f4cd7df18b6d892554e0f6e96982de5d5d8aca4f59d8db7e95926d772a6d963f SHA512 eb6f243fd28e5fe46e856c37cb528c8ec903bdec91b6aa86681add79a333077a3a8874f694255913ae8492b965884f02057a95a98e37027ff67c082a8ca5527e
-DIST vdrift-2012-07-22c_patch.diff 21689 BLAKE2B de7575df09d434f41a4dd02554dd39f7b6ae13d676ae33c692c7aabc49764c25805efdf5cb89e0b5fb016e02b5e33b93977d588df87ff0923421b57cf2796026 SHA512 7b82ba53f3c19ccd01de9ea64e0b7e15224219c0c614a6505b2a3f552ce78565fdedf7781a198c58606d3e9b94e594dee79097d46687e7d4fc763868204b761d
diff --git a/games-sports/vdrift/files/vdrift-20120722-build.patch b/games-sports/vdrift/files/vdrift-20120722-build.patch
deleted file mode 100644
index 16b6fe4c9ba1..000000000000
--- a/games-sports/vdrift/files/vdrift-20120722-build.patch
+++ /dev/null
@@ -1,28 +0,0 @@
---- VDrift.orig/SConstruct
-+++ VDrift/SConstruct
-@@ -44,6 +44,7 @@
- LIBPATH = ['.', '#lib', LOCALBASE + '/lib'],
- LINKFLAGS = ['-pthread','-lintl'],
- options = opts)
-+ env['LINKFLAGS'] += SCons.Util.CLVar(os.environ['LDFLAGS'])
- check_headers = ['GL/gl.h', 'GL/glu.h', 'SDL/SDL.h', 'SDL/SDL_image.h', 'SDL/SDL_rotozoom.h', 'vorbis/vorbisfile.h', 'GL/glew.h', 'bullet/btBulletCollisionCommon.h']
- check_libs = []
- if 'CC' in os.environ:
-@@ -380,7 +381,7 @@
- if env['release']:
- # release build, debugging off, optimizations on
- if (sys.platform != 'freebsd6') and (sys.platform != 'freebsd7') and (sys.platform != 'freebsd8') and (sys.platform != 'freebsd9') and (sys.platform != 'win32') and (sys.platform != 'cygwin'):
-- env.Append(CCFLAGS = ['-O1', '-pipe'])
-+ env.Append(CCFLAGS = ['-pipe'])
- else:
- # debug build, lots of debugging, no optimizations
- env.Append(CCFLAGS = ['-g3'])
-@@ -399,7 +400,6 @@
- env.Append(CCFLAGS = ['-pg'])
- env.Append(LINKFLAGS = ['-pg'])
- env.Append(CCFLAGS = ['-g3'])
-- env.Append(CCFLAGS = ['-O1'])
-
- #------------------------------------#
- # compile-time efficiency assessment #
-
diff --git a/games-sports/vdrift/files/vdrift-20120722-bullet.patch b/games-sports/vdrift/files/vdrift-20120722-bullet.patch
deleted file mode 100644
index 907433417ee6..000000000000
--- a/games-sports/vdrift/files/vdrift-20120722-bullet.patch
+++ /dev/null
@@ -1,100 +0,0 @@
---- src/cardynamics.cpp Mon Jan 19 23:26:36 1970
-+++ src/cardynamics.cpp Mon Jan 19 23:26:36 1970
-@@ -1791,23 +1791,29 @@
-
- bool CARDYNAMICS::WheelContactCallback(
- btManifoldPoint& cp,
-- const btCollisionObject* colObj0,
-- int partId0,
-+ const btCollisionObjectWrapper* col0,
-+ int part0,
- int index0,
-- const btCollisionObject* colObj1,
-- int partId1,
-+ const btCollisionObjectWrapper* col1,
-+ int part1,
- int index1)
- {
-- // cars are fracture bodies, wheel is a cylinder shape
-- const btCollisionShape* shape = colObj0->getCollisionShape();
-- if ((colObj0->getInternalType() & CO_FRACTURE_TYPE) &&
-+#if (BT_BULLET_VERSION < 281)
-+ const btCollisionObject* obj = col0;
-+ const btCollisionShape* shape = obj->getCollisionShape();
-+ const btCollisionShape* rootshape = obj->getRootCollisionShape();
-+#else
-+ const btCollisionObject* obj = col0->getCollisionObject();
-+ const btCollisionShape* shape = col0->getCollisionShape();
-+ const btCollisionShape* rootshape = obj->getCollisionShape();
-+#endif
-+ if ((obj->getInternalType() & CO_FRACTURE_TYPE) &&
- (shape->getShapeType() == CYLINDER_SHAPE_PROXYTYPE))
- {
-- // is contact within contact patch?
-- const btCompoundShape* car = static_cast<const btCompoundShape*>(colObj0->getRootCollisionShape());
-- const btCylinderShapeX* wheel = static_cast<const btCylinderShapeX*>(shape);
-- btVector3 contactPoint = cp.m_localPointA - car->getChildTransform(cp.m_index0).getOrigin();
-- if (-direction::up.dot(contactPoint) > 0.5 * wheel->getRadius())
-+ const btCompoundShape* carshape = static_cast<const btCompoundShape*>(rootshape);
-+ const btCylinderShapeX* wheelshape = static_cast<const btCylinderShapeX*>(shape);
-+ btVector3 contactPoint = cp.m_localPointA - carshape->getChildTransform(cp.m_index0).getOrigin();
-+ if (-direction::up.dot(contactPoint) > 0.5 * wheelshape->getRadius())
- {
- // break contact (hack)
- cp.m_normalWorldOnB = btVector3(0, 0, 0);
---- src/cardynamics.h Mon Jan 19 23:26:36 1970
-+++ src/cardynamics.h Mon Jan 19 23:26:36 1970
-@@ -25,6 +25,12 @@
- class FractureBody;
- class PTree;
-
-+#if (BT_BULLET_VERSION < 281)
-+#define btCollisionObjectWrapper btCollisionObject
-+#else
-+struct btCollisionObjectWrapper;
-+#endif
-+
- class CARDYNAMICS : public btActionInterface
- {
- friend class PERFORMANCE_TESTING;
-@@ -151,11 +157,11 @@
-
- static bool WheelContactCallback(
- btManifoldPoint& cp,
-- const btCollisionObject* colObj0,
-- int partId0,
-+ const btCollisionObjectWrapper* col0,
-+ int part0,
- int index0,
-- const btCollisionObject* colObj1,
-- int partId1,
-+ const btCollisionObjectWrapper* col1,
-+ int part1,
- int index1);
-
- protected:
---- src/dynamicsworld.cpp Mon Jan 19 23:26:36 1970
-+++ src/dynamicsworld.cpp Mon Jan 19 23:26:36 1970
-@@ -105,7 +105,7 @@
- int patch_id = -1;
- const BEZIER * b = 0;
- const TRACKSURFACE * s = TRACKSURFACE::None();
-- btCollisionObject * c = 0;
-+ const btCollisionObject * c = 0;
-
- MyRayResultCallback ray(origin, p, caster);
- rayTest(origin, p, ray);
-@@ -221,6 +221,7 @@
-
- void DynamicsWorld::fractureCallback()
- {
-+#if (BT_BULLET_VERSION < 281)
- m_activeConnections.resize(0);
-
- int numManifolds = getDispatcher()->getNumManifolds();
-@@ -268,4 +269,5 @@
- btRigidBody* child = body->updateConnection(con_id);
- if (child) addRigidBody(child);
- }
-+#endif
- } \ No newline at end of file
diff --git a/games-sports/vdrift/metadata.xml b/games-sports/vdrift/metadata.xml
deleted file mode 100644
index 873fcd84214e..000000000000
--- a/games-sports/vdrift/metadata.xml
+++ /dev/null
@@ -1,11 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>games@gentoo.org</email>
- <name>Gentoo Games Project</name>
- </maintainer>
- <upstream>
- <remote-id type="sourceforge">vdrift</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/games-sports/vdrift/vdrift-20120722.ebuild b/games-sports/vdrift/vdrift-20120722.ebuild
deleted file mode 100644
index c863bdfbb2ca..000000000000
--- a/games-sports/vdrift/vdrift-20120722.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-inherit eutils scons-utils games
-
-MY_P=${PN}-${PV:0:4}-${PV:4:2}-${PV:6:2}
-DESCRIPTION="A driving simulation made with drift racing in mind"
-HOMEPAGE="http://vdrift.net/"
-SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2
- mirror://sourceforge/${PN}/${MY_P}c_patch.diff"
-
-LICENSE="GPL-3 ZLIB LGPL-2.1+"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND="app-arch/libarchive
- media-libs/glew
- media-libs/libsdl[opengl,video]
- media-libs/sdl-gfx
- media-libs/sdl-image[png]
- media-libs/libvorbis
- net-misc/curl
- sci-physics/bullet[-double-precision]
- virtual/opengl
- virtual/glu"
-DEPEND="${RDEPEND}
- dev-cpp/asio
- dev-libs/boost
- virtual/pkgconfig"
-
-S=${WORKDIR}/VDrift
-
-src_unpack() {
- unpack ${MY_P}.tar.bz2
-}
-
-src_prepare() {
- epatch \
- "${DISTDIR}"/${MY_P}c_patch.diff \
- "${FILESDIR}"/${P}-build.patch \
- "${FILESDIR}"/${P}-bullet.patch
-}
-
-src_compile() {
- escons \
- force_feedback=1 \
- destdir="${D}" \
- bindir="${GAMES_BINDIR}" \
- datadir="${GAMES_DATADIR}"/${PN} \
- prefix= \
- use_binreloc=0 \
- release=1 \
- os_cc=1 \
- os_cxx=1 \
- os_cxxflags=1 \
- || die
-}
-
-src_install() {
- dogamesbin build/vdrift
- insinto "${GAMES_DATADIR}/${PN}"
- doins -r data/*
- newicon data/textures/icons/vdrift-64x64.png ${PN}.png
- make_desktop_entry ${PN} VDrift
- find "${D}" -name "SCon*" -exec rm \{\} +
- keepdir "${GAMES_DATADIR}"/${PN}/{music,settings/replays,settings/screenshots}
- prepgamesdirs
-}