summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-16 08:02:39 +0100
committerSam James <sam@gentoo.org>2021-04-16 12:17:46 +0100
commit589675f2a8ad4e58f125071d5156cb69456bf0d6 (patch)
tree65e4c1af7cd62c6ef00b721b7ecf1f1cfed443ad /games-sports
parentgames-sports/foobillard: port to EAPI 7, toolchain-funcs-- (diff)
downloadgentoo-589675f2a8ad4e58f125071d5156cb69456bf0d6.tar.gz
gentoo-589675f2a8ad4e58f125071d5156cb69456bf0d6.tar.bz2
gentoo-589675f2a8ad4e58f125071d5156cb69456bf0d6.zip
games-sports/foobillard: respect ${PKG_CONFIG}
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-sports')
-rw-r--r--games-sports/foobillard/files/foobillard-3.0a-as-needed.patch4
-rw-r--r--games-sports/foobillard/files/foobillard-3.0a-freetype_pkgconfig.patch6
-rw-r--r--games-sports/foobillard/foobillard-3.0a-r1.ebuild4
3 files changed, 8 insertions, 6 deletions
diff --git a/games-sports/foobillard/files/foobillard-3.0a-as-needed.patch b/games-sports/foobillard/files/foobillard-3.0a-as-needed.patch
index db37416a9900..cb3f4236b719 100644
--- a/games-sports/foobillard/files/foobillard-3.0a-as-needed.patch
+++ b/games-sports/foobillard/files/foobillard-3.0a-as-needed.patch
@@ -4,7 +4,7 @@
#LIBS = -L$(LIBDIR) -lglut -lGLU -lGL -lXext -lXaw -lm -lXi -lpng -lz
#LIBS = -L$(LIBDIR) -lglut -lGLU -lGL -lXext -lXaw -lm -lXi -lpng -lz
--AM_LDFLAGS = ${all_libraries} `pkg-config --libs freetype2` ${SDL_LIBS} ${GLUT_LIBS}
+-AM_LDFLAGS = ${all_libraries} `${PKG_CONFIG} --libs freetype2` ${SDL_LIBS} ${GLUT_LIBS}
#LDADD = ${X_PRE_LIBS} ${X_LIBS} ${X_EXTRA_LIBS} -lGL -lGLU -lXaw -lm -lXi -lpng -lz -L/home/floh/nvsdk/OpenGL/lib/ -lnvparse
-LDADD = ${X_PRE_LIBS} ${X_LIBS} ${X_EXTRA_LIBS} -lGL -lGLU -lXaw -lm -lXi -lpng -lz
-+LIBS = ${all_libraries} `pkg-config --libs freetype2` ${SDL_LIBS} ${GLUT_LIBS} ${X_PRE_LIBS} ${X_LIBS} ${X_EXTRA_LIBS} -lGL -lGLU -lXaw -lm -lXi -lpng -lz
++LIBS = ${all_libraries} `${PKG_CONFIG} --libs freetype2` ${SDL_LIBS} ${GLUT_LIBS} ${X_PRE_LIBS} ${X_LIBS} ${X_EXTRA_LIBS} -lGL -lGLU -lXaw -lm -lXi -lpng -lz
diff --git a/games-sports/foobillard/files/foobillard-3.0a-freetype_pkgconfig.patch b/games-sports/foobillard/files/foobillard-3.0a-freetype_pkgconfig.patch
index 57ce7ca94b1c..2fc284580aad 100644
--- a/games-sports/foobillard/files/foobillard-3.0a-freetype_pkgconfig.patch
+++ b/games-sports/foobillard/files/foobillard-3.0a-freetype_pkgconfig.patch
@@ -16,7 +16,7 @@
#CXXFLAGS = -O6 -s
#CFLAGS = -DXMESA -Wall -O3 -I$(INCDIR)
-#CFLAGS = -Wall -O3 -I$(INCDIR) `freetype-config --cflags`
-+#CFLAGS = -Wall -O3 -I$(INCDIR) `pkg-config --cflags freetype2`
++#CFLAGS = -Wall -O3 -I$(INCDIR) `${PKG_CONFIG} --cflags freetype2`
if USE_SDL
SDL_CFLAGS = `sdl-config --cflags` -DUSE_SDL
SDL_LIBS = `sdl-config --libs`
@@ -25,11 +25,11 @@
endif
-AM_CFLAGS = -Wall `freetype-config --cflags` ${SDL_CFLAGS} ${NVIDIA_CFLAGS} ${SOUND_CFLAGS} ${DEBUG_CFLAGS}
-+AM_CFLAGS = -Wall `pkg-config --cflags freetype2` ${SDL_CFLAGS} ${NVIDIA_CFLAGS} ${SOUND_CFLAGS} ${DEBUG_CFLAGS}
++AM_CFLAGS = -Wall `${PKG_CONFIG} --cflags freetype2` ${SDL_CFLAGS} ${NVIDIA_CFLAGS} ${SOUND_CFLAGS} ${DEBUG_CFLAGS}
#LIBS = -L$(LIBDIR) -lglut -lGLU -lGL -lXext -lXaw -lm -lXi -lpng -lz
#LIBS = -L$(LIBDIR) -lglut -lGLU -lGL -lXext -lXaw -lm -lXi -lpng -lz
-AM_LDFLAGS = ${all_libraries} `freetype-config --libs` ${SDL_LIBS} ${GLUT_LIBS}
-+AM_LDFLAGS = ${all_libraries} `pkg-config --libs freetype2` ${SDL_LIBS} ${GLUT_LIBS}
++AM_LDFLAGS = ${all_libraries} `${PKG_CONFIG} --libs freetype2` ${SDL_LIBS} ${GLUT_LIBS}
#LDADD = ${X_PRE_LIBS} ${X_LIBS} ${X_EXTRA_LIBS} -lGL -lGLU -lXaw -lm -lXi -lpng -lz -L/home/floh/nvsdk/OpenGL/lib/ -lnvparse
LDADD = ${X_PRE_LIBS} ${X_LIBS} ${X_EXTRA_LIBS} -lGL -lGLU -lXaw -lm -lXi -lpng -lz
diff --git a/games-sports/foobillard/foobillard-3.0a-r1.ebuild b/games-sports/foobillard/foobillard-3.0a-r1.ebuild
index c25b7f5ae4e4..365d327eec0c 100644
--- a/games-sports/foobillard/foobillard-3.0a-r1.ebuild
+++ b/games-sports/foobillard/foobillard-3.0a-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit autotools desktop flag-o-matic
+inherit autotools desktop flag-o-matic toolchain-funcs
DESCRIPTION="8ball, 9ball, snooker and carambol game"
HOMEPAGE="http://foobillard.sourceforge.net/"
@@ -40,6 +40,8 @@ src_prepare() {
mv configure.{in,ac} || die
rm aclocal.m4
+ tc-export PKG_CONFIG
+
eautoreconf
}