summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2015-08-15 00:49:30 +0200
committerJulian Ospald <hasufell@gentoo.org>2015-08-15 00:49:30 +0200
commita4a8287805a82348956f05406cda917c5927bf36 (patch)
tree17fdaa4e2069b3707b0582bd2169fb9f86d1190e /games-strategy/0ad/files
parentgames-strategy/0ad: version bump to 0.0.18_alpha (diff)
downloadgentoo-a4a8287805a82348956f05406cda917c5927bf36.tar.gz
gentoo-a4a8287805a82348956f05406cda917c5927bf36.tar.bz2
gentoo-a4a8287805a82348956f05406cda917c5927bf36.zip
games-strategy/0ad: rm old
Diffstat (limited to 'games-strategy/0ad/files')
-rw-r--r--games-strategy/0ad/files/0ad-0.0.16_alpha-gcc-4.9.patch42
-rw-r--r--games-strategy/0ad/files/0ad-0.0.16_alpha-gentoo.patch93
-rw-r--r--games-strategy/0ad/files/0ad-0.0.17_alpha-gentoo.patch100
3 files changed, 0 insertions, 235 deletions
diff --git a/games-strategy/0ad/files/0ad-0.0.16_alpha-gcc-4.9.patch b/games-strategy/0ad/files/0ad-0.0.16_alpha-gcc-4.9.patch
deleted file mode 100644
index 5b17120b4f7b..000000000000
--- a/games-strategy/0ad/files/0ad-0.0.16_alpha-gcc-4.9.patch
+++ /dev/null
@@ -1,42 +0,0 @@
-Index: /ps/trunk/source/lib/allocators/headerless.cpp
-===================================================================
---- /ps/trunk/source/lib/allocators/headerless.cpp (revision 15333)
-+++ /ps/trunk/source/lib/allocators/headerless.cpp (revision 15334)
-@@ -55,10 +55,12 @@
- }
-
-- FreedBlock(uintptr_t id, size_t size)
-- : m_magic(s_magic), m_size(size), m_id(id)
-- {
-- }
--
-- ~FreedBlock()
-+ void Setup(uintptr_t id, size_t size)
-+ {
-+ m_magic = s_magic;
-+ m_size = size;
-+ m_id = id;
-+ }
-+
-+ void Reset()
- {
- // clear all fields to prevent accidental reuse
-@@ -411,6 +413,7 @@
- FreedBlock* WriteTags(u8* p, size_t size)
- {
-- FreedBlock* freedBlock = new(p) FreedBlock(s_headerId, size);
-- (void)new(Footer(freedBlock)) FreedBlock(s_footerId, size);
-+ FreedBlock* freedBlock = (FreedBlock*)p;
-+ freedBlock->Setup(s_headerId, size);
-+ Footer(freedBlock)->Setup(s_footerId, size);
-
- m_freeBlocks++;
-@@ -431,6 +434,6 @@
-
- FreedBlock* footer = Footer(freedBlock);
-- freedBlock->~FreedBlock();
-- footer->~FreedBlock();
-+ freedBlock->Reset();
-+ footer->Reset();
- }
-
diff --git a/games-strategy/0ad/files/0ad-0.0.16_alpha-gentoo.patch b/games-strategy/0ad/files/0ad-0.0.16_alpha-gentoo.patch
deleted file mode 100644
index 30192fbccd56..000000000000
--- a/games-strategy/0ad/files/0ad-0.0.16_alpha-gentoo.patch
+++ /dev/null
@@ -1,93 +0,0 @@
-From: Julian Ospald <hasufell@gentoo.org>
-Date: Sun Jun 24 18:32:38 UTC 2012
-Subject: build system
-
-respect flags
-let stripping be handled by the system
-
-fix minimal-flags option:
- leave -fvisibility=hidden active
- leave conditional -fpc-preprocess active
-
---- build/premake/premake4.lua
-+++ build/premake/premake4.lua
-@@ -145,7 +145,7 @@
-
- function project_set_build_flags()
-
-- flags { "Symbols", "NoEditAndContinue" }
-+ flags { "NoEditAndContinue" }
- if not _OPTIONS["icc"] and (os.is("windows") or not _OPTIONS["minimal-flags"]) then
- -- adds the -Wall compiler flag
- flags { "ExtraWarnings" } -- this causes far too many warnings/remarks on ICC
-@@ -337,13 +337,11 @@
- end
- end
-
-- if not _OPTIONS["minimal-flags"] then
- buildoptions {
- -- Hide symbols in dynamic shared objects by default, for efficiency and for equivalence with
- -- Windows - they should be exported explicitly with __attribute__ ((visibility ("default")))
- "-fvisibility=hidden"
- }
-- end
-
- if _OPTIONS["bindir"] then
- defines { "INSTALLED_BINDIR=" .. _OPTIONS["bindir"] }
---- libraries/source/fcollada/src/Makefile
-+++ libraries/source/fcollada/src/Makefile
-@@ -9,8 +9,8 @@
-
- CXX ?= g++
- CXXFLAGS += -fvisibility=hidden -W -Wall -Wno-unused-parameter -Wno-unused-function $(OS_DEFINE) $(PIC_FLAGS) $(CPPFLAGS)
--CXXFLAGS_DEBUG := -O0 -g -D_DEBUG -DRETAIL
--CXXFLAGS_RELEASE := -O1 -DNDEBUG -DRETAIL
-+CXXFLAGS_DEBUG := -D_DEBUG -DRETAIL
-+CXXFLAGS_RELEASE := -DNDEBUG -DRETAIL
- # (-O2 with gcc 4.3 causes linker errors when using this library, for unknown reasons, so stick with -O1 until gcc >4.3 is typical.)
- CXXFLAGS_TEST := -O0 -g -D_DEBUG
- LIBS += `pkg-config libxml-2.0 --libs`
---- build/premake/premake4/src/tools/gcc.lua
-+++ build/premake/premake4/src/tools/gcc.lua
-@@ -136,8 +136,6 @@
- if not cfg.flags.Symbols then
- if cfg.system == "macosx" then
- table.insert(result, "-Wl,-x")
-- else
-- table.insert(result, "-s")
- end
- end
-
---- build/premake/premake4/build/gmake.unix/Premake4.make
-+++ build/premake/premake4/build/gmake.unix/Premake4.make
-@@ -26,9 +26,9 @@
- DEFINES += -DNDEBUG -DLUA_USE_POSIX -DLUA_USE_DLOPEN
- INCLUDES += -I../../src/host/lua-5.1.4/src
- CPPFLAGS += -MMD -MP $(DEFINES) $(INCLUDES)
-- CFLAGS += $(CPPFLAGS) -Wall -Os
-- CXXFLAGS += $(CPPFLAGS) -Wall -Os
-- LDFLAGS += -s -rdynamic
-+ CFLAGS += $(CPPFLAGS) -Wall
-+ CXXFLAGS += $(CPPFLAGS) -Wall
-+ LDFLAGS += -rdynamic
- LIBS += -lm -ldl
- RESFLAGS += $(DEFINES) $(INCLUDES)
- LDDEPS +=
-@@ -48,8 +48,8 @@
- DEFINES += -D_DEBUG -DLUA_USE_POSIX -DLUA_USE_DLOPEN
- INCLUDES += -I../../src/host/lua-5.1.4/src
- CPPFLAGS += -MMD -MP $(DEFINES) $(INCLUDES)
-- CFLAGS += $(CPPFLAGS) -Wall -g
-- CXXFLAGS += $(CPPFLAGS) -Wall -g
-+ CFLAGS += $(CPPFLAGS) -Wall
-+ CXXFLAGS += $(CPPFLAGS) -Wall
- LDFLAGS += -rdynamic
- LIBS += -lm -ldl
- RESFLAGS += $(DEFINES) $(INCLUDES)
-@@ -302,4 +302,4 @@
- $(SILENT) $(CC) $(PCHINCLUDES) $(CFLAGS) -MF $(OBJDIR)/lauxlib.d -MT "$@" -o "$@" -c "$<"
-
- -include $(OBJECTS:%.o=%.d)
---include $(GCH:%.h.gch=%.h.d)
-\ No newline at end of file
-+-include $(GCH:%.h.gch=%.h.d)
diff --git a/games-strategy/0ad/files/0ad-0.0.17_alpha-gentoo.patch b/games-strategy/0ad/files/0ad-0.0.17_alpha-gentoo.patch
deleted file mode 100644
index 45233ab16066..000000000000
--- a/games-strategy/0ad/files/0ad-0.0.17_alpha-gentoo.patch
+++ /dev/null
@@ -1,100 +0,0 @@
-From: Julian Ospald <hasufell@gentoo.org>
-Date: Sun Jun 24 18:32:38 UTC 2012
-Subject: build system
-
-respect flags
-let stripping be handled by the system
-
-fix minimal-flags option:
- leave -fvisibility=hidden active
- leave conditional -fpc-preprocess active
-
---- build/premake/premake4.lua
-+++ build/premake/premake4.lua
-@@ -177,7 +177,7 @@
-
- function project_set_build_flags()
-
-- flags { "Symbols", "NoEditAndContinue" }
-+ flags { "NoEditAndContinue" }
- if cc ~= "icc" and (os.is("windows") or not _OPTIONS["minimal-flags"]) then
- -- adds the -Wall compiler flag
- flags { "ExtraWarnings" } -- this causes far too many warnings/remarks on ICC
-@@ -366,13 +366,11 @@
- end
- end
-
-- if not _OPTIONS["minimal-flags"] then
-- buildoptions {
-- -- Hide symbols in dynamic shared objects by default, for efficiency and for equivalence with
-- -- Windows - they should be exported explicitly with __attribute__ ((visibility ("default")))
-- "-fvisibility=hidden"
-- }
-- end
-+ buildoptions {
-+ -- Hide symbols in dynamic shared objects by default, for efficiency and for equivalence with
-+ -- Windows - they should be exported explicitly with __attribute__ ((visibility ("default")))
-+ "-fvisibility=hidden"
-+ }
-
- if _OPTIONS["bindir"] then
- defines { "INSTALLED_BINDIR=" .. _OPTIONS["bindir"] }
---- libraries/source/fcollada/src/Makefile
-+++ libraries/source/fcollada/src/Makefile
-@@ -9,9 +9,9 @@
-
- CXX ?= g++
- CXXFLAGS += -fvisibility=hidden -W -Wall -Wno-unused-parameter -Wno-unused-function $(OS_DEFINE) $(PIC_FLAGS) $(CPPFLAGS)
--CXXFLAGS_DEBUG := -O0 -g -D_DEBUG -DRETAIL
--CXXFLAGS_RELEASE := -O2 -DNDEBUG -DRETAIL
--CXXFLAGS_TEST := -O0 -g -D_DEBUG
-+CXXFLAGS_DEBUG := -D_DEBUG -DRETAIL
-+CXXFLAGS_RELEASE := -DNDEBUG -DRETAIL
-+CXXFLAGS_TEST := -D_DEBUG
- LIBS += `pkg-config libxml-2.0 --libs`
- INCLUDES += -IFCollada `pkg-config libxml-2.0 --cflags`
- INCLUDES_TEST := -IFCollada/FColladaTest $(INCLUDES)
---- build/premake/premake4/src/tools/gcc.lua
-+++ build/premake/premake4/src/tools/gcc.lua
-@@ -136,8 +136,6 @@
- if not cfg.flags.Symbols then
- if cfg.system == "macosx" then
- table.insert(result, "-Wl,-x")
-- else
-- table.insert(result, "-s")
- end
- end
-
---- build/premake/premake4/build/gmake.unix/Premake4.make
-+++ build/premake/premake4/build/gmake.unix/Premake4.make
-@@ -26,9 +26,9 @@
- DEFINES += -DNDEBUG -DLUA_USE_POSIX -DLUA_USE_DLOPEN
- INCLUDES += -I../../src/host/lua-5.1.4/src
- CPPFLAGS += -MMD -MP $(DEFINES) $(INCLUDES)
-- CFLAGS += $(CPPFLAGS) -Wall -Os
-- CXXFLAGS += $(CPPFLAGS) -Wall -Os
-- LDFLAGS += -s -rdynamic
-+ CFLAGS += $(CPPFLAGS) -Wall
-+ CXXFLAGS += $(CPPFLAGS) -Wall
-+ LDFLAGS += -rdynamic
- LIBS += -lm -ldl
- RESFLAGS += $(DEFINES) $(INCLUDES)
- LDDEPS +=
-@@ -48,8 +48,8 @@
- DEFINES += -D_DEBUG -DLUA_USE_POSIX -DLUA_USE_DLOPEN
- INCLUDES += -I../../src/host/lua-5.1.4/src
- CPPFLAGS += -MMD -MP $(DEFINES) $(INCLUDES)
-- CFLAGS += $(CPPFLAGS) -Wall -g
-- CXXFLAGS += $(CPPFLAGS) -Wall -g
-+ CFLAGS += $(CPPFLAGS) -Wall
-+ CXXFLAGS += $(CPPFLAGS) -Wall
- LDFLAGS += -rdynamic
- LIBS += -lm -ldl
- RESFLAGS += $(DEFINES) $(INCLUDES)
-@@ -302,4 +302,4 @@
- $(SILENT) $(CC) $(PCHINCLUDES) $(CFLAGS) -MF $(OBJDIR)/lauxlib.d -MT "$@" -o "$@" -c "$<"
-
- -include $(OBJECTS:%.o=%.d)
---include $(GCH:%.h.gch=%.h.d)
-\ No newline at end of file
-+-include $(GCH:%.h.gch=%.h.d)