summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorsoredake <fdsfgs@krutt.org>2018-01-05 15:29:09 +0200
committerDavid Seifert <soap@gentoo.org>2018-01-13 23:35:35 +0100
commit48fa4bea6756dd5dc06592d09dc8ebbd1d6d3964 (patch)
tree575aa88bcaa1574517b703b682210ccd9310d604 /games-strategy/colobot/colobot-9999.ebuild
parentgames-emulation/ppsspp: remove unneded deps (diff)
downloadgentoo-48fa4bea6756dd5dc06592d09dc8ebbd1d6d3964.tar.gz
gentoo-48fa4bea6756dd5dc06592d09dc8ebbd1d6d3964.tar.bz2
gentoo-48fa4bea6756dd5dc06592d09dc8ebbd1d6d3964.zip
games-strategy/colobot: new package
Closes: https://github.com/gentoo/gentoo/pull/6756
Diffstat (limited to 'games-strategy/colobot/colobot-9999.ebuild')
-rw-r--r--games-strategy/colobot/colobot-9999.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/games-strategy/colobot/colobot-9999.ebuild b/games-strategy/colobot/colobot-9999.ebuild
new file mode 100644
index 000000000000..02e4757ef02e
--- /dev/null
+++ b/games-strategy/colobot/colobot-9999.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils desktop
+
+DESCRIPTION="Colobot is an educational real-time strategy video game featuring 3D graphics"
+HOMEPAGE="https://colobot.info/"
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/colobot/colobot"
+ EGIT_SUBMODULES=()
+ inherit git-r3
+else
+ SRC_URI="https://github.com/colobot/colobot/archive/${PN}-gold-${PV}-alpha.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+ S="${WORKDIR}/${PN}-${PN}-gold-${PV}-alpha"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="devbuild test tools doc +openal"
+
+DEPEND="
+ dev-games/physfs
+ dev-libs/boost:=
+ media-libs/glew:0
+ media-libs/libogg
+ media-libs/libpng:0=
+ media-libs/libsdl2:=
+ media-libs/libsndfile:=
+ media-libs/libvorbis:=
+ media-libs/sdl2-image
+ media-libs/sdl2-ttf
+ media-sound/vorbis-tools
+ sys-devel/gettext
+ openal? ( media-libs/openal )"
+RDEPEND="${DEPEND}
+ games-strategy/colobot-data"
+
+src_configure() {
+ local mycmakeargs=(
+ -DDEV_BUILD=$(usex devbuild)
+ -DTESTS=$(usex test)
+ -DTOOLS=$(usex tools)
+ -DINSTALL_DOCS=$(usex doc)
+ -DOPENAL_SOUND=$(usex openal)
+ -DCOLOBOT_INSTALL_BIN_DIR="${EPREFIX}"/usr/bin
+ -DCOLOBOT_INSTALL_LIB_DIR="${EPREFIX}"/usr/$(get_libdir)
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ doicon -s 256 desktop/colobot.ico
+}