summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2016-05-18 01:06:47 -0400
committerMichael Sterrett <mr_bones_@gentoo.org>2016-05-18 01:17:09 -0400
commitfb94b102bd5af7cb4117e764e7a45b1bcfef4eb0 (patch)
treefe0494b56f1381dfa95cc8519671c0eacbd65692 /games-strategy/freecol
parentgames-fps/quake2-demodata: stable for amd64 (diff)
downloadgentoo-fb94b102bd5af7cb4117e764e7a45b1bcfef4eb0.tar.gz
gentoo-fb94b102bd5af7cb4117e764e7a45b1bcfef4eb0.tar.bz2
gentoo-fb94b102bd5af7cb4117e764e7a45b1bcfef4eb0.zip
games-strategy/freecol: version bump (bug #571392)
Package-Manager: portage-2.2.28
Diffstat (limited to 'games-strategy/freecol')
-rw-r--r--games-strategy/freecol/Manifest1
-rw-r--r--games-strategy/freecol/files/freecol-0.11.6-gentoo.patch27
-rw-r--r--games-strategy/freecol/freecol-0.11.6.ebuild80
3 files changed, 108 insertions, 0 deletions
diff --git a/games-strategy/freecol/Manifest b/games-strategy/freecol/Manifest
index 2ca3a17fcbb3..c94a3deda83e 100644
--- a/games-strategy/freecol/Manifest
+++ b/games-strategy/freecol/Manifest
@@ -1 +1,2 @@
DIST freecol-0.11.5-src.zip 45280324 SHA256 99b31077fb3d7bfab44fcb900e0ea828a1dedf44fa814e05e166f240a68a5078 SHA512 1059c3b5c87c0f5ae07a99aaab1af2f73c7767a536aa2cff1b6c518b53d9ef6cb75713b4aeb601ab02bf946dcf451d01775b27cf82c457c0b9869e4cfeb55965 WHIRLPOOL 859c5097db4db88642fdfe0189bb731f47e7fe5118e943958698c351b21b6e0762a106b9541a8554633f770c7c2a0d4b57a8b7b26584e96be1277ec887721d67
+DIST freecol-0.11.6-src.zip 45002451 SHA256 52bbc35a8101cbfa770a004750c88969d6caf3f182733671a1e04dd97b86021a SHA512 fbfec95ad7128477d631be92b750d639d42bde3e052c94265590933e841adf66e670d5e1b2f6e8ef05629afeafded60cbb495ef93272ebc14ce7fd2f2eaa53de WHIRLPOOL 355c046419c4fe62a1564460145d13938ae7435a8cb518e1de156a5f575627249c5bccd79d56e8a2b3f156d8f0d291d2cd9c24e4c1d9b27efb9427a8a33acb07
diff --git a/games-strategy/freecol/files/freecol-0.11.6-gentoo.patch b/games-strategy/freecol/files/freecol-0.11.6-gentoo.patch
new file mode 100644
index 000000000000..c087193eb8c5
--- /dev/null
+++ b/games-strategy/freecol/files/freecol-0.11.6-gentoo.patch
@@ -0,0 +1,27 @@
+--- build.xml.orig 2015-12-09 21:10:08.272361404 -0500
++++ build.xml 2015-12-09 21:11:26.189663216 -0500
+@@ -36,12 +36,11 @@
+
+ <path id="libraries.classpath">
+ <!-- MigLayout manager -->
+- <pathelement location="${basedir}/${miglayout-swing.jar}"/>
+- <pathelement location="${basedir}/${miglayout-core.jar}"/>
++ <pathelement location="${miglayout.jar}"/>
+ <!-- Command line processor -->
+- <pathelement location="${basedir}/${cli.jar}"/>
++ <pathelement location="${cli.jar}"/>
+ <!-- Cortado Video Applet -->
+- <pathelement location="${basedir}/${cortado.jar}"/>
++ <pathelement location="${cortado.jar}"/>
+ <!-- JOgg/JOrbis libraries -->
+ <pathelement location="${basedir}/jars/jogg-0.0.17.jar"/>
+ <pathelement location="${basedir}/jars/jorbis-0.0.17.jar"/>
+@@ -162,7 +161,7 @@
+
+ <target name="manifest" depends="git-revision"
+ description="Creates the Manifest file.">
+- <manifestclasspath property="jar.classpath"
++ <manifestclasspath maxParentLevels="50" property="jar.classpath"
+ jarfile="Freecol.jar">
+ <classpath refid="libraries.classpath" />
+ </manifestclasspath>
diff --git a/games-strategy/freecol/freecol-0.11.6.ebuild b/games-strategy/freecol/freecol-0.11.6.ebuild
new file mode 100644
index 000000000000..86e3be069ef6
--- /dev/null
+++ b/games-strategy/freecol/freecol-0.11.6.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils java-pkg-2 java-ant-2 games
+
+DESCRIPTION="An open source clone of the game Colonization"
+HOMEPAGE="http://www.freecol.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}-src.zip"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+COMMON_DEP="dev-java/jsr173
+ dev-java/wstx:3.2
+ dev-java/commons-cli:1
+ dev-java/cortado
+ dev-java/miglayout"
+DEPEND=">=virtual/jdk-1.8
+ app-arch/unzip
+ ${COMMON_DEP}"
+RDEPEND=">=virtual/jre-1.8
+ ${COMMON_DEP}"
+
+S=${WORKDIR}/${PN}
+
+java_prepare() {
+ # jorbis isn't in portage yet
+ rm jars/{commons-cli-1.1,cortado-0.6.0,miglayout-core-4.2,miglayout-swing-4.2}.jar || die
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+}
+
+src_prepare() {
+ java-pkg-2_src_prepare
+}
+
+src_configure() {
+ java-ant-2_src_configure
+}
+
+src_compile() {
+ EANT_BUILD_TARGET=package
+ EANT_EXTRA_ARGS="
+ -Dstax.jar=$(java-pkg_getjars jsr173)
+ -Dwoodstox.jar=$(java-pkg_getjars wstx-3.2)
+ -Dcli.jar=$(java-pkg_getjars commons-cli-1)
+ -Dmiglayout.jar=$(java-pkg_getjars miglayout)
+ -Dcortado.jar=$(java-pkg_getjars cortado)
+ "
+ java-pkg-2_src_compile
+}
+
+src_install() {
+ java-pkg_jarinto "${GAMES_DATADIR}"/${PN}
+ java-pkg_dojar FreeCol.jar
+ java-pkg_dolauncher ${PN} \
+ -into "${GAMES_PREFIX}" \
+ --pwd "${GAMES_DATADIR}"/${PN} \
+ --jar FreeCol.jar \
+ --java_args -Xmx512M
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r data schema
+ doicon data/${PN}.png
+ make_desktop_entry ${PN} FreeCol
+ dodoc README
+ prepgamesdirs
+}
+
+pkg_setup() {
+ games_pkg_setup
+ java-pkg-2_pkg_setup
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ java-pkg-2_pkg_preinst
+}