summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-05-02 19:54:00 +0200
committerPacho Ramos <pacho@gentoo.org>2018-05-02 21:27:44 +0200
commitddbb4e5b4011bd489929cb631af98827df6764d8 (patch)
tree22f76b326106f664e8a7598e2fd709062583c4e4 /games-strategy/knights-demo
parentRevert "games-strategy/heroes3-demo: Stop using games.eclass" (diff)
downloadgentoo-ddbb4e5b4011bd489929cb631af98827df6764d8.tar.gz
gentoo-ddbb4e5b4011bd489929cb631af98827df6764d8.tar.bz2
gentoo-ddbb4e5b4011bd489929cb631af98827df6764d8.zip
games-strategy/knights-demo: Stop using games.eclass
Package-Manager: Portage-2.3.31, Repoman-2.3.9
Diffstat (limited to 'games-strategy/knights-demo')
-rw-r--r--games-strategy/knights-demo/knights-demo-1.32-r2.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/games-strategy/knights-demo/knights-demo-1.32-r2.ebuild b/games-strategy/knights-demo/knights-demo-1.32-r2.ebuild
new file mode 100644
index 000000000000..d314a019ee7c
--- /dev/null
+++ b/games-strategy/knights-demo/knights-demo-1.32-r2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils unpacker
+
+DESCRIPTION="Anglo-Saxon medieval army battles and resource management"
+HOMEPAGE="http://www.linuxgamepublishing.com/info.php?id=knights"
+# Unversioned upstream filename
+SRC_URI="mirror://gentoo/${P}.run"
+
+LICENSE="knights-demo"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="strip"
+
+RDEPEND="
+ sys-libs/glibc
+ >=x11-libs/libX11-1.6.2[abi_x86_32(-)]
+ >=x11-libs/libXau-1.0.7-r1[abi_x86_32(-)]
+ >=x11-libs/libXdmcp-1.1.1-r1[abi_x86_32(-)]
+ >=x11-libs/libXext-1.3.2[abi_x86_32(-)]
+ >=x11-libs/libXi-1.7.2[abi_x86_32(-)]
+"
+S="${WORKDIR}"
+
+src_unpack() {
+ unpack_makeself ${P}.run
+ mv -f data{,-temp}
+ unpack ./data-temp/data.tar.gz
+ rm -rf data-temp lgp_* setup*
+}
+
+src_install() {
+ local dir=/opt/${PN}
+
+ exeinto "${dir}"
+ doexe bin/Linux/x86/${PN}{,.dynamic}
+
+ insinto "${dir}"
+ doins -r data
+ doins EULA icon.xpm README{,.licenses}
+
+ # We don't support the dynamic version, even though we install it.
+ make_wrapper ${PN} ./${PN} "${dir}" "${dir}"
+ newicon icon.xpm ${PN}.xpm
+ make_desktop_entry ${PN} "Knights and Merchants (Demo)" ${PN}
+}