summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-strategy/lgeneral/lgeneral-1.2.4.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-strategy/lgeneral/lgeneral-1.2.4.ebuild')
-rw-r--r--games-strategy/lgeneral/lgeneral-1.2.4.ebuild100
1 files changed, 100 insertions, 0 deletions
diff --git a/games-strategy/lgeneral/lgeneral-1.2.4.ebuild b/games-strategy/lgeneral/lgeneral-1.2.4.ebuild
new file mode 100644
index 000000000000..16d1598c3353
--- /dev/null
+++ b/games-strategy/lgeneral/lgeneral-1.2.4.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils autotools gnome2-utils games
+
+MY_P="${P/_/}"
+MY_P="${MY_P/beta/beta-}"
+DESCRIPTION="A Panzer General clone written in SDL"
+HOMEPAGE="http://lgames.sourceforge.net/index.php?project=LGeneral"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz
+ mirror://sourceforge/${PN}/pg-data.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="nls"
+
+RDEPEND="media-libs/libsdl[sound,video]
+ media-libs/sdl-mixer
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ sys-devel/gettext"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ sed -i \
+ -e '/desktop_DATA/d' \
+ -e '/icon_DATA/d' \
+ Makefile.am || die
+
+ cp /usr/share/gettext/config.rpath .
+ rm -f missing
+ mv configure.in configure.ac
+ eautoreconf
+
+ # Build a temporary lgc-pg that knows about ${WORKDIR}:
+ cp -pPR "${S}" "${WORKDIR}"/tmp-build || die
+ sed -i \
+ -e "s:@GENTOO_DATADIR@:${GAMES_DATADIR}:" \
+ -e "s:@D@::" \
+ {lgc-pg,src}/misc.c || die
+
+ cd "${WORKDIR}"/tmp-build || die
+ sed -i \
+ -e "s:@GENTOO_DATADIR@:${GAMES_DATADIR}:" \
+ -e "s:@D@:${D}:" \
+ {lgc-pg,src}/misc.c || die
+}
+
+src_configure() {
+ egamesconf \
+ $(use_enable nls)
+
+ # Build the temporary lgc-pg:
+ cd "${WORKDIR}"/tmp-build || die
+ egamesconf \
+ --disable-nls \
+ --datadir="${D}/${GAMES_DATADIR}"
+}
+
+src_compile() {
+ emake
+
+ # Build the temporary lgc-pg:
+ cd "${WORKDIR}"/tmp-build || die
+ emake
+}
+
+src_install() {
+ default
+ keepdir "${GAMES_DATADIR}"/${PN}/{ai_modules,music,terrain}
+
+ # Generate scenario data:
+ dodir "${GAMES_DATADIR}"/${PN}/gfx/{flags,units,terrain} #413901
+ SDL_VIDEODRIVER=dummy "${WORKDIR}"/tmp-build/lgc-pg/lgc-pg \
+ -s "${WORKDIR}"/pg-data \
+ -d "${D}/${GAMES_DATADIR}"/${PN} \
+ || die
+
+ newicon -s 48 lgeneral48.png ${PN}.png
+ make_desktop_entry ${PN} LGeneral
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}