summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-05-02 20:47:24 +0200
committerPacho Ramos <pacho@gentoo.org>2018-05-02 21:28:06 +0200
commit6fc56d0836ec8f7ba43b83cd8fb8ac51d1af8394 (patch)
tree65b5a55ac9ba2eae42045616633d28a8e05d2b20 /games-strategy/netherearth
parentgames-strategy/naev: Drop old (diff)
downloadgentoo-6fc56d0836ec8f7ba43b83cd8fb8ac51d1af8394.tar.gz
gentoo-6fc56d0836ec8f7ba43b83cd8fb8ac51d1af8394.tar.bz2
gentoo-6fc56d0836ec8f7ba43b83cd8fb8ac51d1af8394.zip
games-strategy/netherearth: Stop using games.eclass
Package-Manager: Portage-2.3.31, Repoman-2.3.9
Diffstat (limited to 'games-strategy/netherearth')
-rw-r--r--games-strategy/netherearth/files/netherearth-0.52-freeglut.patch4
-rw-r--r--games-strategy/netherearth/files/netherearth-0.52-ldflags.patch4
-rw-r--r--games-strategy/netherearth/netherearth-0.52-r1.ebuild86
3 files changed, 90 insertions, 4 deletions
diff --git a/games-strategy/netherearth/files/netherearth-0.52-freeglut.patch b/games-strategy/netherearth/files/netherearth-0.52-freeglut.patch
index 0fc147f0b7aa..b61e1f139b04 100644
--- a/games-strategy/netherearth/files/netherearth-0.52-freeglut.patch
+++ b/games-strategy/netherearth/files/netherearth-0.52-freeglut.patch
@@ -1,5 +1,5 @@
---- main.cpp
-+++ main.cpp
+--- a/main.cpp
++++ b/main.cpp
@@ -8,6 +8,7 @@
#include <stdio.h>
diff --git a/games-strategy/netherearth/files/netherearth-0.52-ldflags.patch b/games-strategy/netherearth/files/netherearth-0.52-ldflags.patch
index 6b7ed3a8989c..7d81f912764f 100644
--- a/games-strategy/netherearth/files/netherearth-0.52-ldflags.patch
+++ b/games-strategy/netherearth/files/netherearth-0.52-ldflags.patch
@@ -1,5 +1,5 @@
---- Makefile.old 2010-10-12 09:30:19.000000000 +0200
-+++ Makefile 2010-10-12 09:30:38.000000000 +0200
+--- a/Makefile.old 2010-10-12 09:30:19.000000000 +0200
++++ b/Makefile 2010-10-12 09:30:38.000000000 +0200
@@ -17,4 +17,4 @@
all: $(TARGET)
diff --git a/games-strategy/netherearth/netherearth-0.52-r1.ebuild b/games-strategy/netherearth/netherearth-0.52-r1.ebuild
new file mode 100644
index 000000000000..e1aa7cabaaac
--- /dev/null
+++ b/games-strategy/netherearth/netherearth-0.52-r1.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit desktop
+
+MY_PV="${PV/./}"
+DESCRIPTION="A remake of the SPECTRUM game Nether Earth"
+HOMEPAGE="http://www.braingames.getput.com/nether/"
+SRC_URI="http://www.braingames.getput.com/nether/sources.zip
+ http://www.braingames.getput.com/nether/${PN}${MY_PV}.zip"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="mirror bindist"
+
+RDEPEND="
+ >=media-libs/libsdl-1.2.6-r3
+ >=media-libs/sdl-mixer-1.2.5-r1
+ media-libs/freeglut
+"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+"
+
+S="${WORKDIR}/sources"
+
+data="../nether earth v${PV}"
+
+src_unpack() {
+ unzip -LL "${DISTDIR}/${PN}${MY_PV}.zip" >/dev/null || die
+ unzip -LL "${DISTDIR}/sources.zip" >/dev/null || die
+}
+
+src_prepare() {
+ default
+
+ DATA_DIR=/usr/share/${PN}
+
+ cp "${FILESDIR}/Makefile" . || die
+
+ # Fix compilation errors/warnings
+ eapply "${FILESDIR}"/${P}-linux.patch
+
+ eapply "${FILESDIR}"/${P}-freeglut.patch \
+ "${FILESDIR}"/${P}-glibc-212.patch \
+ "${FILESDIR}"/${P}-ldflags.patch
+
+ # Modify dirs and some fopen() permissions
+ eapply "${FILESDIR}/${P}-gentoo-paths.patch"
+ sed -i \
+ -e "s:models:${DATA_DIR}/models:" \
+ -e "s:textures:${DATA_DIR}/textures:" \
+ -e "s:maps/\*:${DATA_DIR}/maps/\*:" \
+ -e "s:\./maps:${DATA_DIR}/maps:" \
+ mainmenu.cpp || die
+ sed -i \
+ -e "s:models:${DATA_DIR}/models:g" \
+ -e "s:textures:${DATA_DIR}/textures:" \
+ -e "s:sound/:${DATA_DIR}/sound/:" \
+ nether.cpp || die
+ sed -i -e "s:maps:${DATA_DIR}/maps:" \
+ main.cpp || die
+ sed -i -e "s:textures/:${DATA_DIR}/textures/:" \
+ myglutaux.cpp || die
+
+ cd "${data}"
+ rm textures/thumbs.db
+}
+
+src_install() {
+ dobin nether_earth
+
+ cd "${data}"
+
+ # Install all game data
+ insinto "${DATA_DIR}"
+ doins -r maps models sound textures
+
+ dodoc readme.txt
+
+ newicon textures/nuclear.bmp ${PN}.bmp
+ make_desktop_entry nether_earth "Nether Earth" /usr/share/pixmaps/${PN}.bmp
+}