summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-strategy/revenge-of-the-titans
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-strategy/revenge-of-the-titans')
-rw-r--r--games-strategy/revenge-of-the-titans/Manifest2
-rw-r--r--games-strategy/revenge-of-the-titans/metadata.xml5
-rw-r--r--games-strategy/revenge-of-the-titans/revenge-of-the-titans-1.80.12.ebuild54
3 files changed, 61 insertions, 0 deletions
diff --git a/games-strategy/revenge-of-the-titans/Manifest b/games-strategy/revenge-of-the-titans/Manifest
new file mode 100644
index 000000000000..c341f5cab7b4
--- /dev/null
+++ b/games-strategy/revenge-of-the-titans/Manifest
@@ -0,0 +1,2 @@
+DIST revenge-of-the-titans-1.80.12-amd64.tar.gz 60169813 SHA256 ff0c210b39fe8b6c26c42aef822bfb5e8d8646ad875a39727b543d97e516cd0e
+DIST revenge-of-the-titans-1.80.12-i386.tar.gz 60125162 SHA256 c0c8a29bf874285e89811d38d20a163732823373570bf4d7450ac11cd4244c53
diff --git a/games-strategy/revenge-of-the-titans/metadata.xml b/games-strategy/revenge-of-the-titans/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-strategy/revenge-of-the-titans/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>
diff --git a/games-strategy/revenge-of-the-titans/revenge-of-the-titans-1.80.12.ebuild b/games-strategy/revenge-of-the-titans/revenge-of-the-titans-1.80.12.ebuild
new file mode 100644
index 000000000000..fa8a9754f2a6
--- /dev/null
+++ b/games-strategy/revenge-of-the-titans/revenge-of-the-titans-1.80.12.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils games java-pkg-2
+
+DESCRIPTION="defeat the returning Titan horde in a series of epic ground battles"
+HOMEPAGE="http://www.puppygames.net/revenge-of-the-titans/"
+SRC_URI="amd64? ( http://downloads.puppygames.net/RevengeOfTheTitans-amd64.tar.gz -> ${P}-amd64.tar.gz )
+ x86? ( http://downloads.puppygames.net/RevengeOfTheTitans-i386.tar.gz -> ${P}-i386.tar.gz )"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=virtual/jre-1.6
+ virtual/opengl"
+DEPEND=""
+
+RESTRICT="mirror bindist strip"
+
+S=${WORKDIR}/${PN//-}
+
+pkg_setup() {
+ java-pkg-2_pkg_setup
+ games_pkg_setup
+}
+
+# nothing to do ... stubs for eclasses
+src_configure() { :; }
+src_compile() { :; }
+
+src_install() {
+ local dir="${GAMES_PREFIX_OPT}/${PN}"
+
+ insinto "${dir}"
+ doins *.jar
+
+ exeinto "${dir}"
+ doexe *.so revenge.sh
+
+ games_make_wrapper ${PN} ./revenge.sh "${dir}" "${dir}"
+ doicon revenge.png
+ make_desktop_entry ${PN} "Revenge of the Titans" revenge
+
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ java-pkg-2_pkg_preinst
+ games_pkg_preinst
+}