summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2020-11-15 19:31:16 +0300
committerSergey Popov <pinkbyte@gentoo.org>2020-11-15 19:33:26 +0300
commitea9bacef363430021e94a8b760bdb950ed8fd1b9 (patch)
tree008ff49861328be2fed87bd6ce2e64d95e6be03e /games-strategy/seven-kingdoms/seven-kingdoms-2.15.4_p1.ebuild
parentgames-strategy/seven-kingdoms: respect AR variable (diff)
downloadgentoo-ea9bacef363430021e94a8b760bdb950ed8fd1b9.tar.gz
gentoo-ea9bacef363430021e94a8b760bdb950ed8fd1b9.tar.bz2
gentoo-ea9bacef363430021e94a8b760bdb950ed8fd1b9.zip
games-strategy/seven-kingdoms: version bump, drop old
Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Sergey Popov <pinkbyte@gentoo.org>
Diffstat (limited to 'games-strategy/seven-kingdoms/seven-kingdoms-2.15.4_p1.ebuild')
-rw-r--r--games-strategy/seven-kingdoms/seven-kingdoms-2.15.4_p1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/games-strategy/seven-kingdoms/seven-kingdoms-2.15.4_p1.ebuild b/games-strategy/seven-kingdoms/seven-kingdoms-2.15.4_p1.ebuild
new file mode 100644
index 000000000000..a23677ae1b8b
--- /dev/null
+++ b/games-strategy/seven-kingdoms/seven-kingdoms-2.15.4_p1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop toolchain-funcs
+
+MY_PN="7kaa"
+MY_PV="$(ver_rs 3- '')"
+MY_P="${MY_PN}-${MY_PV}"
+
+DESCRIPTION="Seven Kingdoms: Ancient Adversaries"
+HOMEPAGE="https://7kfans.com/"
+SRC_URI="https://github.com/the3dfxdude/${MY_PN}/releases/download/v${MY_PV}/${MY_P}.tar.xz
+ https://dev.gentoo.org/~pinkbyte/distfiles/${MY_PN}.png"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+DEPEND="net-libs/enet:1.3=
+ media-libs/libsdl2[X,video]
+ media-libs/openal
+ net-misc/curl"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${MY_P}.tar.xz
+}
+
+src_compile() {
+ emake AR="$(tc-getAR)"
+}
+
+src_install() {
+ default
+
+ doicon "${DISTDIR}/${MY_PN}.png"
+ make_desktop_entry "${MY_PN}" "Seven Kingdoms: Ancient Adversaries" "${MY_PN}" "Game;StrategyGame"
+}