summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-strategy/ufo-ai/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-strategy/ufo-ai/files')
-rw-r--r--games-strategy/ufo-ai/files/ufo-ai-2.4-anon.patch17
-rw-r--r--games-strategy/ufo-ai/files/ufo-ai-2.4-locale.patch15
-rw-r--r--games-strategy/ufo-ai/files/ufo-ai-2.4-mathlib.patch29
3 files changed, 61 insertions, 0 deletions
diff --git a/games-strategy/ufo-ai/files/ufo-ai-2.4-anon.patch b/games-strategy/ufo-ai/files/ufo-ai-2.4-anon.patch
new file mode 100644
index 000000000000..53f07261bb7e
--- /dev/null
+++ b/games-strategy/ufo-ai/files/ufo-ai-2.4-anon.patch
@@ -0,0 +1,17 @@
+--- src/tools/radiant/radiant/camera/CameraSettings.h.old 2014-10-22 08:30:35.690248415 +0200
++++ src/tools/radiant/radiant/camera/CameraSettings.h 2014-10-22 08:31:12.329900302 +0200
+@@ -16,13 +16,13 @@
+ const std::string RKEY_ENABLE_FARCLIP = "user/ui/camera/enableCubicClipping";
+ const std::string RKEY_DRAWMODE = "user/ui/camera/drawMode";
+ const std::string RKEY_SOLID_SELECTION_BOXES = "user/ui/xyview/solidSelectionBoxes";
++}
+
+ enum CameraDrawMode
+ {
+ drawWire, drawSolid, drawTexture
+ };
+
+-}
+ /* greebo: This is the home of all the camera settings. As this class derives
+ * from a RegistryKeyObserver, it can be connected to the according registry keys
+ * and gets notified if any of the observed keys are changed.*/
diff --git a/games-strategy/ufo-ai/files/ufo-ai-2.4-locale.patch b/games-strategy/ufo-ai/files/ufo-ai-2.4-locale.patch
new file mode 100644
index 000000000000..632e0d4fdc0d
--- /dev/null
+++ b/games-strategy/ufo-ai/files/ufo-ai-2.4-locale.patch
@@ -0,0 +1,15 @@
+diff -urN ufoai-2.4-source.old//src/client/cl_main.c ufoai-2.4-source/src/client/cl_main.c
+--- ufoai-2.4-source.old//src/client/cl_main.c 2012-05-01 10:59:51.720868619 +0200
++++ ufoai-2.4-source/src/client/cl_main.c 2012-05-01 11:00:57.235869759 +0200
+@@ -1180,7 +1180,11 @@
+ if (fs_i18ndir->string[0] != '\0')
+ Q_strncpyz(languagePath, fs_i18ndir->string, sizeof(languagePath));
+ else
++#ifdef LOCALEDIR
++ Q_strncpyz(languagePath, LOCALEDIR, sizeof(languagePath));
++#else
+ Com_sprintf(languagePath, sizeof(languagePath), "%s/"BASEDIRNAME"/i18n/", FS_GetCwd());
++#endif
+ Com_DPrintf(DEBUG_CLIENT, "...using mo files from %s\n", languagePath);
+ bindtextdomain(TEXT_DOMAIN, languagePath);
+ bind_textdomain_codeset(TEXT_DOMAIN, "UTF-8");
diff --git a/games-strategy/ufo-ai/files/ufo-ai-2.4-mathlib.patch b/games-strategy/ufo-ai/files/ufo-ai-2.4-mathlib.patch
new file mode 100644
index 000000000000..72fd81038fb6
--- /dev/null
+++ b/games-strategy/ufo-ai/files/ufo-ai-2.4-mathlib.patch
@@ -0,0 +1,29 @@
+http://bugs.gentoo.org/509928
+
+src/common/common.c:261: error: undefined reference to 'sincos'
+src/shared/mathlib.c:476: error: undefined reference to '__acosf_finite'
+[ ... snip ... ]
+collect2: error: ld returned 1 exit status
+
+--- build/modules/ufo.mk
++++ build/modules/ufo.mk
+@@ -9,7 +9,7 @@
+ $(TARGET)_LINKER := $(CC)
+ $(TARGET)_FILE := $(TARGET)$(EXE_EXT)
+ $(TARGET)_CFLAGS += -DCOMPILE_UFO $(BFD_CFLAGS) $(SDL_CFLAGS) $(SDL_TTF_CFLAGS) $(SDL_MIXER_CFLAGS) $(CURL_CFLAGS) $(THEORA_CFLAGS) $(XVID_CFLAGS) $(VORBIS_CFLAGS) $(OGG_CFLAGS) $(MXML_CFLAGS)
+-$(TARGET)_LDFLAGS += -lpng -ljpeg $(BFD_LIBS) $(INTL_LIBS) $(SDL_TTF_LIBS) $(SDL_MIXER_LIBS) $(OPENGL_LIBS) $(SDL_LIBS) $(CURL_LIBS) $(THEORA_LIBS) $(XVID_LIBS) $(VORBIS_LIBS) $(OGG_LIBS) $(MXML_LIBS) $(SO_LIBS) -lz
++$(TARGET)_LDFLAGS += -lpng -ljpeg $(BFD_LIBS) $(INTL_LIBS) $(SDL_TTF_LIBS) $(SDL_MIXER_LIBS) $(OPENGL_LIBS) $(SDL_LIBS) $(CURL_LIBS) $(THEORA_LIBS) $(XVID_LIBS) $(VORBIS_LIBS) $(OGG_LIBS) $(MXML_LIBS) $(SO_LIBS) -lz -lm
+
+ $(TARGET)_SRCS = \
+ client/cl_console.c \
+--- build/modules/testall.mk
++++ build/modules/testall.mk
+@@ -9,7 +9,7 @@
+ $(TARGET)_LINKER := $(CC)
+ $(TARGET)_FILE := $(TARGET)$(EXE_EXT)
+ $(TARGET)_CFLAGS += -DCOMPILE_UFO -DHARD_LINKED_GAME -DCOMPILE_UNITTESTS $(BFD_CFLAGS) $(SDL_CFLAGS) $(CURL_CFLAGS) $(OGG_CFLAGS) $(MXML_CFLAGS)
+-$(TARGET)_LDFLAGS += -lcunit -lpng -ljpeg $(BFD_LIBS) $(INTL_LIBS) $(SDL_TTF_LIBS) $(SDL_MIXER_LIBS) $(OPENGL_LIBS) $(SDL_LIBS) $(CURL_LIBS) $(THEORA_LIBS) $(XVID_LIBS) $(VORBIS_LIBS) $(OGG_LIBS) $(MXML_LIBS) $(SO_LIBS) -lz
++$(TARGET)_LDFLAGS += -lcunit -lpng -ljpeg $(BFD_LIBS) $(INTL_LIBS) $(SDL_TTF_LIBS) $(SDL_MIXER_LIBS) $(OPENGL_LIBS) $(SDL_LIBS) $(CURL_LIBS) $(THEORA_LIBS) $(XVID_LIBS) $(VORBIS_LIBS) $(OGG_LIBS) $(MXML_LIBS) $(SO_LIBS) -lz -lm
+
+ $(TARGET)_SRCS = \
+ tests/test_all.c \