summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-strategy/xbattle
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-strategy/xbattle')
-rw-r--r--games-strategy/xbattle/Manifest1
-rw-r--r--games-strategy/xbattle/metadata.xml27
-rw-r--r--games-strategy/xbattle/xbattle-5.4.1.ebuild56
3 files changed, 84 insertions, 0 deletions
diff --git a/games-strategy/xbattle/Manifest b/games-strategy/xbattle/Manifest
new file mode 100644
index 000000000000..92a1689b2a98
--- /dev/null
+++ b/games-strategy/xbattle/Manifest
@@ -0,0 +1 @@
+DIST xbattle-5.4.1.tar.gz 128982 SHA256 9de38df361c87d0fdc65e13cf2fa3bb28dc22a8d04cc94f2f08e6cd9457ee180
diff --git a/games-strategy/xbattle/metadata.xml b/games-strategy/xbattle/metadata.xml
new file mode 100644
index 000000000000..e46af3a374bc
--- /dev/null
+++ b/games-strategy/xbattle/metadata.xml
@@ -0,0 +1,27 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+<maintainer>
+<email>mr_bones_@gentoo.org</email>
+<name>Michael Sterrett</name>
+</maintainer>
+<longdescription>
+From the HOMEPAGE:
+XBattle is a concurrent multi-player arcade/strategy game that captures
+the dynamics of a wide range of military situations through numerous
+options. The game board is a matrix of game cells which can be occupied
+by troops of various colors, with troop strength indicated by the size of
+colored markers within a cell. Troops are commanded by clicking the mouse
+near the edge of an occupied cell in the direction that movement is to take
+place. XBattle is concurrent, so that commands are given continuously by
+all players without waiting for turns. A command will be acknowledged by
+the appearance of a command vector, and thereafter, in each update cycle,
+a certain proportion of the troops will move from the source cell to the
+destination cell. In this way, troops can be slowly redistributed via
+supply lines which steadily deliver troops to their endpoints. Troops
+of different colors engage in battle whenever they come to occupy the
+same cell. A wide variety of options are available for configuring troop
+movement, distribution, and production.
+</longdescription>
+</pkgmetadata>
diff --git a/games-strategy/xbattle/xbattle-5.4.1.ebuild b/games-strategy/xbattle/xbattle-5.4.1.ebuild
new file mode 100644
index 000000000000..25b405599bfd
--- /dev/null
+++ b/games-strategy/xbattle/xbattle-5.4.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit games
+
+DESCRIPTION="A multi-player game of strategy and coordination"
+HOMEPAGE="http://www.cgl.uwaterloo.ca/~jdsteele/xbattle.html"
+SRC_URI="ftp://cns-ftp.bu.edu/pub/xbattle/${P}.tar.gz"
+
+LICENSE="xbattle"
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ia64 ~mips ppc sparc x86"
+IUSE=""
+
+RDEPEND="x11-libs/libXext
+ x11-libs/libX11
+ !games-strategy/xbattleai"
+DEPEND="${RDEPEND}
+ x11-proto/xproto
+ app-text/rman
+ x11-misc/imake"
+
+src_prepare() {
+ sed -i \
+ -e "s:/export/home/lesher/:${GAMES_DATADIR}/${PN}/:" Imakefile || die
+}
+
+src_configure() {
+ xmkmf || die
+}
+
+src_compile() {
+ emake \
+ CDEBUGFLAGS="${CFLAGS}" \
+ LOCAL_LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ dogamesbin xbattle
+ newgamesbin tutorial1 xbattle-tutorial1
+ newgamesbin tutorial2 xbattle-tutorial2
+ dodir "${GAMES_DATADIR}/${PN}"
+ cp -r xbas/ xbos/ xbts/ "${D}${GAMES_DATADIR}/${PN}/" || die
+ newman xbattle.man xbattle.6
+ dodoc README xbattle.dot
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ elog 'You may be interested by these tutorials:'
+ elog ' xbattle-tutorial1'
+ elog ' xbattle-tutorial2'
+}