summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-08-02 16:43:09 -0500
committerAustin English <wizardedit@gentoo.org>2016-08-03 15:59:15 -0500
commit46956ffca6909f456da8a29be20e5185f5e04de0 (patch)
treeaa1a161f8c84c4e657af3f79d418a29f2c425af3 /games-strategy
parentkde-apps/kdepim-meta: Don't block self (diff)
downloadgentoo-46956ffca6909f456da8a29be20e5185f5e04de0.tar.gz
gentoo-46956ffca6909f456da8a29be20e5185f5e04de0.tar.bz2
gentoo-46956ffca6909f456da8a29be20e5185f5e04de0.zip
games-strategy/xbattleai: remove deprecated games eclass
Also update to EAPI 6 Gentoo-Bug: https://bugs.gentoo.org/574082 Package-Manager: portage-2.3.0
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/xbattleai/files/xbattleai-1.2.2-sandbox.patch4
-rw-r--r--games-strategy/xbattleai/xbattleai-1.2.2-r2.ebuild43
2 files changed, 45 insertions, 2 deletions
diff --git a/games-strategy/xbattleai/files/xbattleai-1.2.2-sandbox.patch b/games-strategy/xbattleai/files/xbattleai-1.2.2-sandbox.patch
index 566d4eec0565..56d63ac694e4 100644
--- a/games-strategy/xbattleai/files/xbattleai-1.2.2-sandbox.patch
+++ b/games-strategy/xbattleai/files/xbattleai-1.2.2-sandbox.patch
@@ -1,5 +1,5 @@
---- Makefile.in
-+++ Makefile.in
+--- a/Makefile.in
++++ b/Makefile.in
@@ -200,87 +200,87 @@
.PHONY: install-bin
diff --git a/games-strategy/xbattleai/xbattleai-1.2.2-r2.ebuild b/games-strategy/xbattleai/xbattleai-1.2.2-r2.ebuild
new file mode 100644
index 000000000000..3cace4da5155
--- /dev/null
+++ b/games-strategy/xbattleai/xbattleai-1.2.2-r2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit eutils
+
+DESCRIPTION="A multi-player game of strategy and coordination"
+HOMEPAGE="https://inf.ug.edu.pl/~piotao/xbattle/mirror/www.lysator.liu.se/XBattleAI/"
+SRC_URI="https://inf.ug.edu.pl/~piotao/xbattle/mirror/www.lysator.liu.se/XBattleAI/${P}.tgz"
+
+LICENSE="xbattle"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# Since this uses similar code and the same binary name as the original XBattle,
+# we want to make sure you can't install both at the same time
+RDEPEND="
+ dev-lang/tcl:0
+ dev-lang/tk:0
+ x11-libs/libX11
+ x11-libs/libXext
+ !games-strategy/xbattle"
+DEPEND="${RDEPEND}
+ app-text/rman
+ x11-misc/imake
+ x11-proto/xproto"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-sandbox.patch
+)
+
+src_prepare() {
+ default
+ rm -f xbcs/foo.xbc~ || die
+}
+
+src_install() {
+ DOCS="CONTRIBUTORS README README.AI TODO xbattle.dot" \
+ default
+ mv "${D}/usr/bin/"{,xb_}gauntletCampaign || die
+}