summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-08-25 17:21:48 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-08-25 17:21:48 +0200
commit0f917374bcbafc1e0ec7ecad84ada6331a67b8fa (patch)
tree4e50eee6c78d722324be4a30ebc9c402588fabc0 /games-util/antimicro/files
parentdev-db/cppdb: Drop old (diff)
downloadgentoo-0f917374bcbafc1e0ec7ecad84ada6331a67b8fa.tar.gz
gentoo-0f917374bcbafc1e0ec7ecad84ada6331a67b8fa.tar.bz2
gentoo-0f917374bcbafc1e0ec7ecad84ada6331a67b8fa.zip
games-util/antimicro: 2.23 version bump, EAPI-6
Thanks-to: Niranjan <niranjan.public@gmail.com> Thanks-to: Small_Penguin <dark.shadow@gmx.at> Closes: https://bugs.gentoo.org/603712 Package-Manager: Portage-2.3.48, Repoman-2.3.10
Diffstat (limited to 'games-util/antimicro/files')
-rw-r--r--games-util/antimicro/files/antimicro-2.23-linking-errors.patch40
1 files changed, 40 insertions, 0 deletions
diff --git a/games-util/antimicro/files/antimicro-2.23-linking-errors.patch b/games-util/antimicro/files/antimicro-2.23-linking-errors.patch
new file mode 100644
index 000000000000..88d03e876704
--- /dev/null
+++ b/games-util/antimicro/files/antimicro-2.23-linking-errors.patch
@@ -0,0 +1,40 @@
+From d5cfe429edb8c5f6f039153a0f646f2198c06b16 Mon Sep 17 00:00:00 2001
+From: Raphael Kubo da Costa <rakuco@FreeBSD.org>
+Date: Mon, 29 Jan 2018 12:19:55 +0100
+Subject: [PATCH] cmake: Stop calling QT5_WRAP_CPP().
+
+The USE_QT5 code path already unconditionally sets CMAKE_AUTOMOC to on.
+
+Calling QT5_WRAP_CPP() used to be just redundant, as antimicro_HEADERS_MOC
+was never actually added as a source dependency of the antimicro target. In
+other words, CMake's own automoc infrastructure was actually being used and
+the moc invocations from QT5_WRAP_CPP() were not being made at all.
+
+Starting with Qt 5.9.4, calling QT5_WRAP_CPP() disables the AUTOMOC property
+on the macro's input files, which means neither CMake's automoc
+infrastructure not QT5_WRAP_CPP()'s code were being used and we ended up
+with several 'undefined reference to vtable' errors when linking.
+---
+ CMakeLists.txt | 2 --
+ 1 file changed, 2 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 63ef851..0e47889 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -499,7 +499,6 @@ if (UNIX)
+ find_package(Qt5Network REQUIRED)
+ find_package(Qt5LinguistTools REQUIRED)
+
+- QT5_WRAP_CPP(antimicro_HEADERS_MOC ${antimicro_HEADERS})
+ QT5_WRAP_UI(antimicro_FORMS_HEADERS ${antimicro_FORMS})
+ QT5_ADD_RESOURCES(antimicro_RESOURCES_RCC ${antimicro_RESOURCES})
+ add_subdirectory("share/antimicro/translations")
+@@ -550,7 +549,6 @@ elseif(WIN32)
+ find_package(Qt5Network REQUIRED)
+ find_package(Qt5LinguistTools REQUIRED)
+
+- QT5_WRAP_CPP(antimicro_HEADERS_MOC ${antimicro_HEADERS})
+ QT5_WRAP_UI(antimicro_FORMS_HEADERS ${antimicro_FORMS})
+ QT5_ADD_RESOURCES(antimicro_RESOURCES_RCC ${antimicro_RESOURCES})
+ add_subdirectory("share/antimicro/translations")