summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-util/datutil
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-util/datutil')
-rw-r--r--games-util/datutil/Manifest2
-rw-r--r--games-util/datutil/datutil-2.46.ebuild44
-rw-r--r--games-util/datutil/metadata.xml11
3 files changed, 57 insertions, 0 deletions
diff --git a/games-util/datutil/Manifest b/games-util/datutil/Manifest
new file mode 100644
index 000000000000..be9263e6e220
--- /dev/null
+++ b/games-util/datutil/Manifest
@@ -0,0 +1,2 @@
+DIST datlib236.zip 109484 SHA256 9ff474ed30047f2bbb2a0942077a63dd2b0825c08b061cb4b36dd168d9014bb3 SHA512 0c601fe243c8ea4186abb6181cf70e749226a5eed871d7391b3686e7eb58195d1aab40305d498d1419c6fa49bf56c59fb74d032642822045cc7e36f8a5fe96b4 WHIRLPOOL a8a3c41900b4d4ef1837dcc5e5df65949bedf5209e47b604ec29b0134b800888166642607ac8e47a70db936d150267c9e0d6611003a5be495d0b042e84b3a59a
+DIST dutil246.zip 209577 SHA256 171fd5f30a31973e1a49f484fbd475c518a3234aa41e97d45904dc8ccbf67f56 SHA512 f9e55eac41894681caaee7d6e3247d4e4d053ac6985d42708623fad415afeb8ece588dd728edc31cbd31bf6df1d9a06ec80f1b45979b0f77763c12e6627434b2 WHIRLPOOL 33095f026f05fee1d8b6f3b3ba5fec4e75ceb51c864889b7670c7461a67a9dcaf265fcaf271fe37e593bc6908cd44dd3ce2ce22b97f4848c21ff29b12de8a3c2
diff --git a/games-util/datutil/datutil-2.46.ebuild b/games-util/datutil/datutil-2.46.ebuild
new file mode 100644
index 000000000000..28a92759b5ab
--- /dev/null
+++ b/games-util/datutil/datutil-2.46.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit toolchain-funcs
+
+DL_PV=2.36
+DESCRIPTION="Converter for dat files for Rom Managers"
+HOMEPAGE="http://www.logiqx.com/Tools/DatUtil/"
+SRC_URI="http://www.logiqx.com/Tools/DatUtil/dutil${PV//.}.zip
+ http://www.logiqx.com/Tools/DatLib/datlib${DL_PV//.}.zip"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="amd64 x86 ~x86-fbsd"
+IUSE=""
+RESTRICT="mirror bindist"
+
+DEPEND="app-arch/unzip"
+RDEPEND=""
+
+S=${WORKDIR}
+
+src_unpack() {
+ unpack dutil${PV//.}.zip
+ cd "${S}"
+ mkdir -p dev/datlib
+ cd dev/datlib
+ unpack datlib${DL_PV//.}.zip
+}
+
+src_compile() {
+ # Parallel make issue, see bug #244879 (so make the dirs first)
+ emake -j1 CC="$(tc-getCC)" LD="$(tc-getCC) ${CFLAGS} ${LDFLAGS}" \
+ CFLAGS="${CFLAGS} -Idev" LOGIQX=. EXT= UPX=@# dlmaketree maketree || die "emake failed"
+ emake CC="$(tc-getCC)" LD="$(tc-getCC) ${CFLAGS} ${LDFLAGS}" \
+ CFLAGS="${CFLAGS} -Idev" LOGIQX=. EXT= UPX=@# || die "emake failed"
+}
+
+src_install() {
+ dobin datutil
+ dodoc readme.txt whatsnew.txt
+}
diff --git a/games-util/datutil/metadata.xml b/games-util/datutil/metadata.xml
new file mode 100644
index 000000000000..7a192d8ada41
--- /dev/null
+++ b/games-util/datutil/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+<longdescription lang="en">
+DatUtil was created to aid in the creation of dat files for Rom Managers such as
+ClrMamePro and RomCenter (Roman Scherzer / Eric Bole-Feysot). It can convert
+between formats, extract individual games (and optionally their clones) and
+cleanse dats. It supports a variety of formats
+</longdescription>
+</pkgmetadata>