summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Breathitt Gray <vilhelm.gray@gmail.com>2019-06-16 15:20:20 +0900
committerJames Le Cuirot <chewi@gentoo.org>2019-06-23 22:12:11 +0100
commit1b8cebf4ee3ea5ebfd34a521e7d967cd10040225 (patch)
treede2d33f0e5d5dc196c3f8c9481e7fa35223d52c9 /games-util/deutex/deutex-5.2.0.ebuild
parentmedia-gfx/exiv2: Drop 0.27.1 (r0) (diff)
downloadgentoo-1b8cebf4ee3ea5ebfd34a521e7d967cd10040225.tar.gz
gentoo-1b8cebf4ee3ea5ebfd34a521e7d967cd10040225.tar.bz2
gentoo-1b8cebf4ee3ea5ebfd34a521e7d967cd10040225.zip
games-util/deutex: version bump to deutex-5.2.0
Closes: https://bugs.gentoo.org/680460 Closes: https://bugs.gentoo.org/687678 Package-Manager: Portage-2.3.67, Repoman-2.3.14 Signed-off-by: William Breathitt Gray <vilhelm.gray@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/12262 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'games-util/deutex/deutex-5.2.0.ebuild')
-rw-r--r--games-util/deutex/deutex-5.2.0.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/games-util/deutex/deutex-5.2.0.ebuild b/games-util/deutex/deutex-5.2.0.ebuild
new file mode 100644
index 000000000000..f4802fcadd48
--- /dev/null
+++ b/games-util/deutex/deutex-5.2.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="WAD composer for Doom, Heretic, Hexen, and Strife"
+HOMEPAGE="https://github.com/Doom-Utils/deutex"
+SRC_URI="https://github.com/Doom-Utils/${PN}/releases/download/v${PV}/${P}.tar.xz"
+
+LICENSE="GPL-2+ LGPL-2+ HPND"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="man png"
+
+DEPEND="png? ( media-libs/libpng:0= )"
+RDEPEND="${DEPEND}"
+BDEPEND="man? ( app-text/asciidoc )"
+
+src_configure() {
+ econf \
+ $(use_enable man) \
+ $(use_with png libpng)
+}