summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Breathitt Gray <vilhelm.gray@gmail.com>2020-12-30 08:39:06 -0500
committerJoonas Niilola <juippis@gentoo.org>2021-01-20 16:13:39 +0200
commitb7d4b2d7cb6b2956e46cfb4654b8b5442e1b1b09 (patch)
treed0d1eec49c51c60ee6fc572bf59dc6b603f82982 /games-util/deutex/deutex-5.2.2.ebuild
parentnet-im/telegram-desktop-bin: cleanup old (diff)
downloadgentoo-b7d4b2d7cb6b2956e46cfb4654b8b5442e1b1b09.tar.gz
gentoo-b7d4b2d7cb6b2956e46cfb4654b8b5442e1b1b09.tar.bz2
gentoo-b7d4b2d7cb6b2956e46cfb4654b8b5442e1b1b09.zip
games-util/deutex: Version bump to 5.2.2
Closes: https://bugs.gentoo.org/762652 Signed-off-by: William Breathitt Gray <vilhelm.gray@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/18882 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'games-util/deutex/deutex-5.2.2.ebuild')
-rw-r--r--games-util/deutex/deutex-5.2.2.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/games-util/deutex/deutex-5.2.2.ebuild b/games-util/deutex/deutex-5.2.2.ebuild
new file mode 100644
index 000000000000..dcead660a3ae
--- /dev/null
+++ b/games-util/deutex/deutex-5.2.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit unpacker
+
+DESCRIPTION="WAD composer for Doom, Heretic, Hexen, and Strife"
+HOMEPAGE="https://github.com/Doom-Utils/deutex"
+SRC_URI="https://github.com/Doom-Utils/${PN}/releases/download/v${PV}/${P}.tar.zst"
+
+LICENSE="GPL-2+ LGPL-2+ HPND"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="man png"
+
+DEPEND="png? ( media-libs/libpng:0= )"
+RDEPEND="${DEPEND}"
+BDEPEND="man? ( app-text/asciidoc )"
+
+src_configure() {
+ econf \
+ $(use_enable man) \
+ $(use_with png libpng)
+}