summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-02-22 01:56:56 +0100
committerLars Wendler <polynomial-c@gentoo.org>2019-02-22 01:57:09 +0100
commitd676574b43da7591fd7bd181b8347692e28262d9 (patch)
treeed7257df8646b28e89ae10a59af24b5d790fb222 /games-util/joystick/joystick-1.6.1.ebuild
parentsys-apps/dbus: Add bug reference (diff)
downloadgentoo-d676574b43da7591fd7bd181b8347692e28262d9.tar.gz
gentoo-d676574b43da7591fd7bd181b8347692e28262d9.tar.bz2
gentoo-d676574b43da7591fd7bd181b8347692e28262d9.zip
games-util/joystick: Bump to version 1.6.1
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'games-util/joystick/joystick-1.6.1.ebuild')
-rw-r--r--games-util/joystick/joystick-1.6.1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/games-util/joystick/joystick-1.6.1.ebuild b/games-util/joystick/joystick-1.6.1.ebuild
new file mode 100644
index 000000000000..389255caf332
--- /dev/null
+++ b/games-util/joystick/joystick-1.6.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs
+
+MY_P="linuxconsoletools-${PV}"
+DESCRIPTION="joystick testing utilities"
+HOMEPAGE="https://sourceforge.net/projects/linuxconsole/ http://atrey.karlin.mff.cuni.cz/~vojtech/input/"
+SRC_URI="mirror://sourceforge/linuxconsole/files/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="sdl udev"
+
+DEPEND="sdl? ( media-libs/libsdl:0[video] )
+ !<x11-libs/tslib-1.0-r2"
+RDEPEND="${DEPEND}
+ udev? ( virtual/udev )"
+
+S=${WORKDIR}/${MY_P}
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.6.0-build.patch
+)
+
+src_prepare() {
+ default
+
+ export PREFIX=/usr
+ tc-export CC PKG_CONFIG
+ export USE_SDL=$(usex sdl)
+}
+
+src_install() {
+ default
+ if ! use udev ; then
+ rm "${ED}"/usr/bin/jscal-{re,}store || die
+ fi
+}