summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2017-03-08 21:38:05 +0000
committerJames Le Cuirot <chewi@gentoo.org>2017-03-08 21:38:37 +0000
commitc1227c2ba06c8bf2ca8933810c12bbdde7730f6f (patch)
treeeb7d6208900f6ae1b905f0781e389e1df5e1fa11 /games-util/lgogdownloader/lgogdownloader-3.2.ebuild
parentmedia-libs/x264: disable asm for armv5 (diff)
downloadgentoo-c1227c2ba06c8bf2ca8933810c12bbdde7730f6f.tar.gz
gentoo-c1227c2ba06c8bf2ca8933810c12bbdde7730f6f.tar.bz2
gentoo-c1227c2ba06c8bf2ca8933810c12bbdde7730f6f.zip
games-util/lgogdownloader: Version bump to 3.2
Package-Manager: Portage-2.3.4, Repoman-2.3.2
Diffstat (limited to 'games-util/lgogdownloader/lgogdownloader-3.2.ebuild')
-rw-r--r--games-util/lgogdownloader/lgogdownloader-3.2.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/games-util/lgogdownloader/lgogdownloader-3.2.ebuild b/games-util/lgogdownloader/lgogdownloader-3.2.ebuild
new file mode 100644
index 000000000000..0ac33eae5786
--- /dev/null
+++ b/games-util/lgogdownloader/lgogdownloader-3.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="Unofficial GOG.com downloader for Linux"
+HOMEPAGE="https://sites.google.com/site/gogdownloader/"
+SRC_URI="https://sites.google.com/site/gogdownloader/${P}.tar.gz"
+LICENSE="WTFPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+debug"
+
+RDEPEND=">=app-crypt/rhash-1.3.3-r2:0=
+ dev-cpp/htmlcxx:0=
+ dev-libs/boost:0=
+ >=dev-libs/jsoncpp-1.7:0=
+ dev-libs/tinyxml2:0=
+ net-libs/liboauth:0=
+ >=net-misc/curl-7.32:0=[ssl]"
+
+DEPEND="${RDEPEND}
+ sys-apps/help2man
+ virtual/pkgconfig"