summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorsoredake <fdsfgs@krutt.org>2017-11-08 15:54:48 +0200
committerJames Le Cuirot <chewi@gentoo.org>2017-11-09 20:16:26 +0000
commit82209ff919971efa2d7b8176a6888d42d878d2c6 (patch)
tree6803b7d67d5f2d710a4e88537d5a1ce1a6e477fd /games-util/lgogdownloader
parentgames-util/lgogdownloader: version bump to 3.3 (diff)
downloadgentoo-82209ff919971efa2d7b8176a6888d42d878d2c6.tar.gz
gentoo-82209ff919971efa2d7b8176a6888d42d878d2c6.tar.bz2
gentoo-82209ff919971efa2d7b8176a6888d42d878d2c6.zip
games-util/lgogdownloader: add live version
Closes: https://github.com/gentoo/gentoo/pull/6149
Diffstat (limited to 'games-util/lgogdownloader')
-rw-r--r--games-util/lgogdownloader/lgogdownloader-9999.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/games-util/lgogdownloader/lgogdownloader-9999.ebuild b/games-util/lgogdownloader/lgogdownloader-9999.ebuild
new file mode 100644
index 000000000000..478ab0eee166
--- /dev/null
+++ b/games-util/lgogdownloader/lgogdownloader-9999.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils git-r3
+
+DESCRIPTION="Unofficial GOG.com downloader for Linux"
+HOMEPAGE="https://sites.google.com/site/gogdownloader/"
+EGIT_REPO_URI="https://github.com/Sude-/lgogdownloader.git"
+LICENSE="WTFPL-2"
+SLOT="0"
+IUSE="+debug"
+
+RDEPEND=">=app-crypt/rhash-1.3.3-r2:0=
+ dev-cpp/htmlcxx:0=
+ dev-libs/boost:0=
+ >=dev-libs/jsoncpp-1.7:0=
+ dev-libs/tinyxml2:0=
+ net-libs/liboauth:0=
+ >=net-misc/curl-7.32:0=[ssl]"
+
+DEPEND="${RDEPEND}
+ sys-apps/help2man
+ virtual/pkgconfig"