summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2021-09-04 08:21:11 +0100
committerJames Le Cuirot <chewi@gentoo.org>2021-09-04 08:21:11 +0100
commitaa0a9598963c38e1cd3875c0d71cd23db8287310 (patch)
tree4ea059ba95935a4445cf59db47ea92d4bf858487 /games-util/lgogdownloader
parentapp-admin/hcloud: version bump to 1.28.1 - remove old (diff)
downloadgentoo-aa0a9598963c38e1cd3875c0d71cd23db8287310.tar.gz
gentoo-aa0a9598963c38e1cd3875c0d71cd23db8287310.tar.bz2
gentoo-aa0a9598963c38e1cd3875c0d71cd23db8287310.zip
games-util/lgogdownloader: Version bump to 3.8
Package-Manager: Portage-3.0.22, Repoman-3.0.3 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'games-util/lgogdownloader')
-rw-r--r--games-util/lgogdownloader/Manifest1
-rw-r--r--games-util/lgogdownloader/lgogdownloader-3.8.ebuild39
-rw-r--r--games-util/lgogdownloader/lgogdownloader-9999.ebuild4
3 files changed, 42 insertions, 2 deletions
diff --git a/games-util/lgogdownloader/Manifest b/games-util/lgogdownloader/Manifest
index e11639e41e64..f330c2b186e4 100644
--- a/games-util/lgogdownloader/Manifest
+++ b/games-util/lgogdownloader/Manifest
@@ -1 +1,2 @@
DIST lgogdownloader-3.7.tar.gz 85653 BLAKE2B bb6fe56be291ca726b97cfb7ce83e87e855584da911839a9bc6a923c027e7ea67e83e62a5e8bb1a0c62dd053a7d6728c1e82896d19ba48a310574dc8c6a647f5 SHA512 2085b9c64008d790a28dcb9d22009340acac164db316523919dcf797255fd57a36160950fb222e82b9ee6262ef8c0e86193e2d9a4488ea2105f9f4bbe7db727b
+DIST lgogdownloader-3.8.tar.gz 85271 BLAKE2B ff8e9f80dbec849649b4074ab5890f833a5bfaf120246e7ca5eae83f414af469da29302323dc22632eb0a7259e49e9cf3660ea8953adda75fc7a5308204767bd SHA512 ccc6116f22a5c0bff5e4ef650f6386d5bfc507cc667b7154b021ecdbd45e7553ac33ae6b81531e2cea52a5022ee9c810033518a07374d4e9f7c672344e7ccad3
diff --git a/games-util/lgogdownloader/lgogdownloader-3.8.ebuild b/games-util/lgogdownloader/lgogdownloader-3.8.ebuild
new file mode 100644
index 000000000000..805b3a49d3c0
--- /dev/null
+++ b/games-util/lgogdownloader/lgogdownloader-3.8.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Unofficial GOG.com downloader for Linux"
+HOMEPAGE="https://sites.google.com/site/gogdownloader/"
+SRC_URI="https://sites.google.com/site/gogdownloader/${P}.tar.gz"
+LICENSE="WTFPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gui"
+
+RDEPEND=">=app-crypt/rhash-1.3.3-r2:0=
+ dev-cpp/htmlcxx:0=
+ dev-libs/boost:0=[zlib]
+ >=dev-libs/jsoncpp-1.7:0=
+ dev-libs/tinyxml2:0=
+ >=net-misc/curl-7.32:0=[ssl]
+ gui? ( dev-qt/qtwebengine:5=[widgets] )"
+
+DEPEND="${RDEPEND}"
+
+BDEPEND="sys-apps/help2man
+ virtual/pkgconfig"
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_QT_GUI=$(usex gui)
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+ gunzip "${ED}"/usr/share/man/man1/${PN}.1.gz || die
+}
diff --git a/games-util/lgogdownloader/lgogdownloader-9999.ebuild b/games-util/lgogdownloader/lgogdownloader-9999.ebuild
index e1817aeca2ae..39a33d8fe4fd 100644
--- a/games-util/lgogdownloader/lgogdownloader-9999.ebuild
+++ b/games-util/lgogdownloader/lgogdownloader-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit cmake git-r3