summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gmail.com>2019-03-14 19:01:32 +0200
committerLars Wendler <polynomial-c@gentoo.org>2019-03-18 17:47:19 +0100
commitc7bc03d8fb8626cfeebc41358486e46330d486a4 (patch)
treee1efc9e3874f2fe7a6720963032cbe1d6b8c947b /games-util/lutris
parentgames-util/lutris: add dev-python/requests to RDEPEND (diff)
downloadgentoo-c7bc03d8fb8626cfeebc41358486e46330d486a4.tar.gz
gentoo-c7bc03d8fb8626cfeebc41358486e46330d486a4.tar.bz2
gentoo-c7bc03d8fb8626cfeebc41358486e46330d486a4.zip
games-util/lutris: drop old 0.5.0.1
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Joonas Niilola <juippis@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/11363 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'games-util/lutris')
-rw-r--r--games-util/lutris/lutris-0.5.0.1.ebuild74
1 files changed, 0 insertions, 74 deletions
diff --git a/games-util/lutris/lutris-0.5.0.1.ebuild b/games-util/lutris/lutris-0.5.0.1.ebuild
deleted file mode 100644
index fca79a193ebf..000000000000
--- a/games-util/lutris/lutris-0.5.0.1.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{4,5,6,7} )
-PYTHON_REQ_USE="sqlite,threads(+)"
-
-inherit distutils-r1 virtualx xdg
-
-DESCRIPTION="An open source gaming platform for GNU/Linux"
-HOMEPAGE="https://lutris.net/"
-
-if [[ ${PV} == *9999* ]] ; then
- EGIT_REPO_URI="https://github.com/lutris/lutris.git"
- inherit git-r3
-else
- SRC_URI="https://lutris.net/releases/${P/-/_}.tar.xz"
- KEYWORDS="~amd64 ~x86"
-fi
-
-LICENSE="GPL-3"
-SLOT="0"
-
-BDEPEND="
- test? ( dev-python/nose[${PYTHON_USEDEP}] )
-"
-RDEPEND="
- app-arch/cabextract
- app-arch/p7zip
- app-arch/unrar
- app-arch/unzip
- dev-python/pillow[${PYTHON_USEDEP}]
- dev-python/pygobject:3[${PYTHON_USEDEP}]
- dev-python/python-evdev[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- gnome-base/gnome-desktop[introspection]
- media-sound/fluid-soundfont
- net-libs/libsoup
- net-libs/webkit-gtk:4[introspection]
- x11-apps/xgamma
- x11-apps/xrandr
- x11-libs/gtk+:3[introspection]
- x11-libs/libnotify
-"
-
-S="${WORKDIR}/${PN}"
-
-python_install_all() {
- local DOCS=( AUTHORS README.rst docs/installers.rst )
- distutils-r1_python_install_all
-}
-
-python_test() {
- virtx nosetests -v || die
-}
-
-pkg_preinst() {
- xdg_pkg_preinst
-}
-
-pkg_postinst() {
- xdg_pkg_postinst
-
- # Quote README.rst
- elog "Lutris installations are fully automated through scripts, which can"
- elog "be written in either JSON or YAML. The scripting syntax is described"
- elog "in ${EROOT}/usr/share/doc/${PF}/installers.rst.bz2, and is also"
- elog "available online at lutris.net."
-}
-
-pkg_postrm() {
- xdg_pkg_postrm
-}