summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-util/mcrcon
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-util/mcrcon')
-rw-r--r--games-util/mcrcon/Manifest1
-rw-r--r--games-util/mcrcon/mcrcon-0.0.5.ebuild27
-rw-r--r--games-util/mcrcon/metadata.xml12
3 files changed, 40 insertions, 0 deletions
diff --git a/games-util/mcrcon/Manifest b/games-util/mcrcon/Manifest
new file mode 100644
index 000000000000..a03de6d7e7d7
--- /dev/null
+++ b/games-util/mcrcon/Manifest
@@ -0,0 +1 @@
+DIST mcrcon-0.0.5-src.zip 9748 SHA256 14cdbc00d5e2c4e877ea82fef3aeb94c2e258b3539c47a7f2b015cab12f98a74 SHA512 590da8007d630a9ff5332b5fda9e2498e949b4085e16fd00a4b1f693251980bc2d91736ea8ca7c649ee34b28484d165c8b5f45b1830e9fb661bec3a10af080d2 WHIRLPOOL 5cfb116cdf7c4a600f7cc3475e868081ea4674807edc360e87c27af7777a3423be1763a743d0d655039b4a8b1f0206fa829ecb1adbc9504a68976204b01091f7
diff --git a/games-util/mcrcon/mcrcon-0.0.5.ebuild b/games-util/mcrcon/mcrcon-0.0.5.ebuild
new file mode 100644
index 000000000000..928377663bd9
--- /dev/null
+++ b/games-util/mcrcon/mcrcon-0.0.5.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit toolchain-funcs games
+
+DESCRIPTION="Remote connection client for Minecraft servers"
+HOMEPAGE="http://sourceforge.net/projects/mcrcon/"
+SRC_URI="mirror://sourceforge/${PN}/${P}-src.zip"
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+S="${WORKDIR}"
+
+src_compile() {
+ # Flags taken from COMPILING.txt.
+ $(tc-getCC) ${CFLAGS} ${LDFLAGS} -std=gnu11 -pedantic -Wall -Wextra -o "${PN}" "${PN}.c" || die
+}
+
+src_install() {
+ dogamesbin "${PN}"
+ dodoc README.txt
+}
diff --git a/games-util/mcrcon/metadata.xml b/games-util/mcrcon/metadata.xml
new file mode 100644
index 000000000000..248f1ffbb028
--- /dev/null
+++ b/games-util/mcrcon/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>chewi@gentoo.org</email>
+ <name>James Le Cuirot</name>
+ </maintainer>
+ <longdescription>mcrcon is an IPv6 compliant Minecraft rcon client with Bukkit coloring support. It is well suited for remote administration and to be used as part of automated server maintenance scripts. Does not trigger the "IO: Broken pipe" or "IO: Connection reset" spam bug on the server side.</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">mcrcon</remote-id>
+ </upstream>
+</pkgmetadata>