summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2017-02-23 17:23:44 -0600
committerAustin English <wizardedit@gentoo.org>2017-02-23 17:24:35 -0600
commite2e777b0e933325c71736a55d8630fc08c0716cf (patch)
treeaf1682723d72ec3b61a3ddb23261c4767b18c402 /games-util/pogo-manager-bin
parentmedia-libs/mesa: Update HOMEPAGE. (diff)
downloadgentoo-e2e777b0e933325c71736a55d8630fc08c0716cf.tar.gz
gentoo-e2e777b0e933325c71736a55d8630fc08c0716cf.tar.bz2
gentoo-e2e777b0e933325c71736a55d8630fc08c0716cf.zip
games-util/pogo-manager-bin: version bump
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'games-util/pogo-manager-bin')
-rw-r--r--games-util/pogo-manager-bin/Manifest1
-rw-r--r--games-util/pogo-manager-bin/pogo-manager-bin-0.1.7.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/games-util/pogo-manager-bin/Manifest b/games-util/pogo-manager-bin/Manifest
index 432c0d3a65b2..31045e589697 100644
--- a/games-util/pogo-manager-bin/Manifest
+++ b/games-util/pogo-manager-bin/Manifest
@@ -1 +1,2 @@
DIST pogo-manager-bin-0.1.6.zip 7703380 SHA256 57c019ba56b038c4ee87adcd60d80611b1633a39c5dc15de3c4f7d4bbee63ea9 SHA512 d09e5f905fad659b5f380c25e8ccb7f9423430a1210ebb15e233f7f9436dff0307897ce372fdedf1b44ff48bd682b1f991a5fa3ac28a98af18d2a2bec72b08b0 WHIRLPOOL 94e7ca564f833e4cb23c1542fa2fd6100cfed9d8cbab53b53622db4d8121bca5aacef9dc86f2bfbba11407d345d1a368492e28e6b3aeb66554feebe783205d36
+DIST pogo-manager-bin-0.1.7.zip 7978366 SHA256 607e7b74723c21d03cad4b2d70786c1b7abacb3c2facfe6b018ab0f7c7f23fc6 SHA512 6d43626d0b7edb756d0a36b8114782ea78bd87fe1f4bdcd78c8d724961ad1635042ab8e0e7f489c5c5cf8b09fa14788c701a14eb5bdce1cf21ed95c3e97fa90a WHIRLPOOL 78fa621414446510ad3cce721b91edbbf317a3101012fb5a9d884f243ef041f7dac1801d82606b059a9d7237d575964b51c4ea959a90a01e85b8330c0877951d
diff --git a/games-util/pogo-manager-bin/pogo-manager-bin-0.1.7.ebuild b/games-util/pogo-manager-bin/pogo-manager-bin-0.1.7.ebuild
new file mode 100644
index 000000000000..65a46ee7e20b
--- /dev/null
+++ b/games-util/pogo-manager-bin/pogo-manager-bin-0.1.7.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+MY_PN="${PN/-bin}"
+
+DESCRIPTION="Pokemon Go manager"
+HOMEPAGE="https://github.com/Wolfsblvt/BlossomsPokemonGoManager"
+SRC_URI="https://github.com/Wolfsblvt/BlossomsPokemonGoManager/releases/download/v${PV}/BPGM_v${PV}.zip -> ${P}.zip"
+
+LICENSE="CC-BY-NC-SA-4.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="|| ( dev-java/oracle-jdk-bin:1.8[javafx] dev-java/oracle-jre-bin:1.8[javafx] )"
+DEPEND="app-arch/unzip"
+
+S="${WORKDIR}/BPGM_v${PV}"
+
+src_install()
+{
+ insinto /opt/${MY_PN}
+ newins BlossomsPogoManager.jar ${MY_PN}.jar
+
+ dobin "${FILESDIR}/pogo-manager"
+}
+
+pkg_postinst()
+{
+ ewarn "Use of this tool is not sanctioned by Niantic and could get you banned."
+ ewarn "You have been warned!"
+}