summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-util/pyfa
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-util/pyfa')
-rw-r--r--games-util/pyfa/Manifest1
-rw-r--r--games-util/pyfa/files/configforced.py4
-rw-r--r--games-util/pyfa/files/pyfa-1.1.11-import-pyfa.patch28
-rw-r--r--games-util/pyfa/files/pyfa-1.1.20-staticPath.patch27
-rw-r--r--games-util/pyfa/files/pyfa-1.1.8-html-export-path.patch33
-rw-r--r--games-util/pyfa/files/pyfa.desktop8
-rw-r--r--games-util/pyfa/metadata.xml20
-rw-r--r--games-util/pyfa/pyfa-1.12.0.ebuild94
-rw-r--r--games-util/pyfa/pyfa-9999.ebuild94
9 files changed, 309 insertions, 0 deletions
diff --git a/games-util/pyfa/Manifest b/games-util/pyfa/Manifest
new file mode 100644
index 000000000000..37684441c58c
--- /dev/null
+++ b/games-util/pyfa/Manifest
@@ -0,0 +1 @@
+DIST pyfa-1.12.0.tar.gz 5898063 SHA256 d22f725efee6cd48a30ccc16a04e913afa1a7e9e89a2004ef8ca12263663ae87 SHA512 c7cda257c0ebffee113df713b8e4a2578fc46ec4493a13341c3907cd8de99c19f4cb1dbae4fe4365134c9ebced618efee2614cb57889a50330d37cf5996ec602 WHIRLPOOL eaf0bc3907b0f32feb601319ca8630e18e8eababb8d3623e56ee3fdc45dfc30946c817e2040e10f0f0e13093672b4faf0e5893088a125bb056d14dd006d623f6
diff --git a/games-util/pyfa/files/configforced.py b/games-util/pyfa/files/configforced.py
new file mode 100644
index 000000000000..a8008c217eda
--- /dev/null
+++ b/games-util/pyfa/files/configforced.py
@@ -0,0 +1,4 @@
+# Gentoo-specific settings
+pyfaPath = u'%%SITEDIR%%/pyfa'
+staticPath = u'%%EPREFIX%%/usr/share/pyfa/staticdata'
+gameDB = staticPath + "/eve.db"
diff --git a/games-util/pyfa/files/pyfa-1.1.11-import-pyfa.patch b/games-util/pyfa/files/pyfa-1.1.11-import-pyfa.patch
new file mode 100644
index 000000000000..8269080038f9
--- /dev/null
+++ b/games-util/pyfa/files/pyfa-1.1.11-import-pyfa.patch
@@ -0,0 +1,28 @@
+From f301dcd0df741514e889fc234811cd4770dca6c7 Mon Sep 17 00:00:00 2001
+From: Alexandre Rostovtsev <tetromino@gentoo.org>
+Date: Wed, 5 Dec 2012 00:48:12 -0500
+Subject: [PATCH] Append $(python_get_sitedir)/pyfa to import path
+
+Ensures that pyfa's import statements continue to work for systemwide
+installation.
+---
+ pyfa.py | 3 +++
+ 1 file changed, 3 insertions(+)
+
+diff --git a/pyfa.py b/pyfa.py
+index 6992aaf..d66cb70 100755
+--- a/pyfa.py
++++ b/pyfa.py
+@@ -63,6 +63,9 @@ if __name__ == "__main__":
+ parser.add_option("-r", "--root", action="store_true", dest="rootsavedata", help="if you want pyfa to store its data in root folder, use this option", default=False)
+ (options, args) = parser.parse_args()
+
++ import os
++ sys.path.append(os.path.join("%%SITEDIR%%", "pyfa"))
++
+ import config
+ # Configure paths
+ if options.rootsavedata is True:
+--
+1.8.0
+
diff --git a/games-util/pyfa/files/pyfa-1.1.20-staticPath.patch b/games-util/pyfa/files/pyfa-1.1.20-staticPath.patch
new file mode 100644
index 000000000000..cdcc9f90d3e5
--- /dev/null
+++ b/games-util/pyfa/files/pyfa-1.1.20-staticPath.patch
@@ -0,0 +1,27 @@
+From 69660180a59d0d100097dedbc507d4af73267e8d Mon Sep 17 00:00:00 2001
+From: Alexandre Rostovtsev <tetromino@gentoo.org>
+Date: Wed, 30 Nov 2011 12:50:53 -0500
+Subject: [PATCH] Make staticPath settable from configforced
+
+---
+ config.py | 4 +++-
+ 1 file changed, 3 insertions(+), 1 deletion(-)
+
+diff --git a/config.py b/config.py
+index e39e0d3..e028c36 100644
+--- a/config.py
++++ b/config.py
+@@ -66,7 +66,9 @@ def defPaths():
+
+ # Static EVE Data from the staticdata repository, should be in the staticdata
+ # directory in our pyfa directory
+- staticPath = os.path.join(pyfaPath, "staticdata")
++ staticPath = getattr(configforced, "staticPath", None)
++ if staticPath is None:
++ staticPath = os.path.join(pyfaPath, "staticdata")
+
+ # The database where we store all the fits etc
+ saveDB = os.path.join(savePath, "saveddata.db")
+--
+1.8.5.3
+
diff --git a/games-util/pyfa/files/pyfa-1.1.8-html-export-path.patch b/games-util/pyfa/files/pyfa-1.1.8-html-export-path.patch
new file mode 100644
index 000000000000..e7614d21aa4d
--- /dev/null
+++ b/games-util/pyfa/files/pyfa-1.1.8-html-export-path.patch
@@ -0,0 +1,33 @@
+From 017938391c5b67327c489a5c3a6fc720d4204609 Mon Sep 17 00:00:00 2001
+From: Alexandre Rostovtsev <tetromino@gentoo.org>
+Date: Mon, 16 Jul 2012 05:43:38 -0400
+Subject: [PATCH] Export fits to home directory, not python sitedir
+
+---
+ service/settings.py | 3 ++-
+ 1 files changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/service/settings.py b/service/settings.py
+index 8f6e3a8..5ac386d 100644
+--- a/service/settings.py
++++ b/service/settings.py
+@@ -21,6 +21,7 @@ import cPickle
+ import os.path
+ import config
+ import urllib2
++import sys
+
+ class SettingsProvider():
+ BASE_PATH = os.path.join(config.savePath, "settings")
+@@ -199,7 +200,7 @@ class HTMLExportSettings():
+ return cls._instance
+
+ def __init__(self):
+- serviceHTMLExportDefaultSettings = {"enabled": False, "path": config.pyfaPath + os.sep + 'pyfaFits.html' }
++ serviceHTMLExportDefaultSettings = {"enabled": False, "path": unicode(os.path.expanduser(os.path.join('~', 'pyfaFits.html')), sys.getfilesystemencoding()) }
+ self.serviceHTMLExportSettings = SettingsProvider.getInstance().getSettings("pyfaServiceHTMLExportSettings", serviceHTMLExportDefaultSettings)
+
+ def getEnabled(self):
+--
+1.7.8.6
+
diff --git a/games-util/pyfa/files/pyfa.desktop b/games-util/pyfa/files/pyfa.desktop
new file mode 100644
index 000000000000..07f3f0ee22a7
--- /dev/null
+++ b/games-util/pyfa/files/pyfa.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Name=Pyfa
+Comment=Ship fitting application for EVE Online
+Icon=pyfa
+Terminal=false
+Type=Application
+Categories=Game;RolePlaying;
+Exec=pyfa
diff --git a/games-util/pyfa/metadata.xml b/games-util/pyfa/metadata.xml
new file mode 100644
index 000000000000..39be7ad301d4
--- /dev/null
+++ b/games-util/pyfa/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>tetromino@gentoo.org</email>
+ <name>Alexandre Rostovtsev</name>
+ </maintainer>
+ <longdescription lang="en">
+Pyfa is the Python Fitting Assistant, a standalone application for creating
+fittings for the EVE Online SciFi MMORPG. It provides many advanced features
+such as graphs and full calculations of any possible combination of modules,
+fits, etc.
+</longdescription>
+ <use>
+ <flag name="graph">Enable support for graphs</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">DarkFenX/Pyfa</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/games-util/pyfa/pyfa-1.12.0.ebuild b/games-util/pyfa/pyfa-1.12.0.ebuild
new file mode 100644
index 000000000000..8f2241416ab5
--- /dev/null
+++ b/games-util/pyfa/pyfa-1.12.0.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="sqlite,threads"
+
+inherit eutils gnome2-utils python-r1
+
+DESCRIPTION="Python Fitting Assistant - a ship fitting application for EVE Online"
+HOMEPAGE="https://github.com/DarkFenX/Pyfa"
+
+LICENSE="GPL-3+ LGPL-2.1+ CC-BY-2.5 free-noncomm"
+SLOT="0"
+if [[ ${PV} = 9999 ]]; then
+ EGIT_REPO_URI="https://github.com/DarkFenX/Pyfa.git"
+ inherit git-2
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/DarkFenX/Pyfa/archive/v${PV}.tar.gz -> pyfa-${PV}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+IUSE="+graph"
+
+RDEPEND="dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/sqlalchemy[${PYTHON_USEDEP}]
+ dev-python/wxpython:2.8[${PYTHON_USEDEP}]
+ graph? (
+ dev-python/matplotlib[wxwidgets,${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}] )
+ ${PYTHON_DEPS}"
+DEPEND="app-arch/unzip"
+
+S=${WORKDIR}/Pyfa-${PV}
+
+src_prepare() {
+ # get rid of CRLF line endings introduced in 1.1.10 so patches work
+ edos2unix config.py pyfa.py service/settings.py
+
+ # make staticPath settable from configforced again
+ epatch "${FILESDIR}/${PN}-1.1.20-staticPath.patch"
+
+ # do not try to save exported html to python sitedir
+ epatch "${FILESDIR}/${PN}-1.1.8-html-export-path.patch"
+
+ # fix import path in the main script for systemwide installation
+ epatch "${FILESDIR}/${PN}-1.1.11-import-pyfa.patch"
+ touch __init__.py
+
+ pyfa_make_configforced() {
+ mkdir -p "${BUILD_DIR}" || die
+ sed -e "s:%%SITEDIR%%:$(python_get_sitedir):" \
+ -e "s:%%EPREFIX%%:${EPREFIX}:" \
+ "${FILESDIR}/configforced.py" > "${BUILD_DIR}/configforced.py"
+ sed -e "s:%%SITEDIR%%:$(python_get_sitedir):" \
+ pyfa.py > "${BUILD_DIR}/pyfa"
+ }
+ python_foreach_impl pyfa_make_configforced
+}
+
+src_install() {
+ pyfa_py_install() {
+ local packagedir=$(python_get_sitedir)/${PN}
+ insinto "${packagedir}"
+ doins -r eos gui icons service config*.py __init__.py gpl.txt
+ [[ -e info.py ]] && doins info.py # only in zip releases
+ doins "${BUILD_DIR}/configforced.py"
+ python_doscript "${BUILD_DIR}/pyfa"
+ python_optimize
+ }
+ python_foreach_impl pyfa_py_install
+
+ insinto /usr/share/${PN}
+ doins -r staticdata
+ dodoc README.md
+ insinto /usr/share/icons/hicolor/32x32/apps
+ doins icons/pyfa.png
+ insinto /usr/share/icons/hicolor/64x64/apps
+ newins icons/pyfa64.png pyfa.png
+ domenu "${FILESDIR}/${PN}.desktop"
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/games-util/pyfa/pyfa-9999.ebuild b/games-util/pyfa/pyfa-9999.ebuild
new file mode 100644
index 000000000000..8f2241416ab5
--- /dev/null
+++ b/games-util/pyfa/pyfa-9999.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="sqlite,threads"
+
+inherit eutils gnome2-utils python-r1
+
+DESCRIPTION="Python Fitting Assistant - a ship fitting application for EVE Online"
+HOMEPAGE="https://github.com/DarkFenX/Pyfa"
+
+LICENSE="GPL-3+ LGPL-2.1+ CC-BY-2.5 free-noncomm"
+SLOT="0"
+if [[ ${PV} = 9999 ]]; then
+ EGIT_REPO_URI="https://github.com/DarkFenX/Pyfa.git"
+ inherit git-2
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/DarkFenX/Pyfa/archive/v${PV}.tar.gz -> pyfa-${PV}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+IUSE="+graph"
+
+RDEPEND="dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/sqlalchemy[${PYTHON_USEDEP}]
+ dev-python/wxpython:2.8[${PYTHON_USEDEP}]
+ graph? (
+ dev-python/matplotlib[wxwidgets,${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}] )
+ ${PYTHON_DEPS}"
+DEPEND="app-arch/unzip"
+
+S=${WORKDIR}/Pyfa-${PV}
+
+src_prepare() {
+ # get rid of CRLF line endings introduced in 1.1.10 so patches work
+ edos2unix config.py pyfa.py service/settings.py
+
+ # make staticPath settable from configforced again
+ epatch "${FILESDIR}/${PN}-1.1.20-staticPath.patch"
+
+ # do not try to save exported html to python sitedir
+ epatch "${FILESDIR}/${PN}-1.1.8-html-export-path.patch"
+
+ # fix import path in the main script for systemwide installation
+ epatch "${FILESDIR}/${PN}-1.1.11-import-pyfa.patch"
+ touch __init__.py
+
+ pyfa_make_configforced() {
+ mkdir -p "${BUILD_DIR}" || die
+ sed -e "s:%%SITEDIR%%:$(python_get_sitedir):" \
+ -e "s:%%EPREFIX%%:${EPREFIX}:" \
+ "${FILESDIR}/configforced.py" > "${BUILD_DIR}/configforced.py"
+ sed -e "s:%%SITEDIR%%:$(python_get_sitedir):" \
+ pyfa.py > "${BUILD_DIR}/pyfa"
+ }
+ python_foreach_impl pyfa_make_configforced
+}
+
+src_install() {
+ pyfa_py_install() {
+ local packagedir=$(python_get_sitedir)/${PN}
+ insinto "${packagedir}"
+ doins -r eos gui icons service config*.py __init__.py gpl.txt
+ [[ -e info.py ]] && doins info.py # only in zip releases
+ doins "${BUILD_DIR}/configforced.py"
+ python_doscript "${BUILD_DIR}/pyfa"
+ python_optimize
+ }
+ python_foreach_impl pyfa_py_install
+
+ insinto /usr/share/${PN}
+ doins -r staticdata
+ dodoc README.md
+ insinto /usr/share/icons/hicolor/32x32/apps
+ doins icons/pyfa.png
+ insinto /usr/share/icons/hicolor/64x64/apps
+ newins icons/pyfa64.png pyfa.png
+ domenu "${FILESDIR}/${PN}.desktop"
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}