summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Zuber <a.zuber@gmx.ch>2018-05-30 14:29:30 +0200
committerMichał Górny <mgorny@gentoo.org>2018-05-30 15:35:37 +0200
commit7ad57335d01b572de6c6b180f1b5e8d8f86203b3 (patch)
treef216b5070a1a977ba48ec7a4eb21e5c3e3953183 /games-util/pyfa
parentgames-util/pyfa: version bump to 1.37.0 (diff)
downloadgentoo-7ad57335d01b572de6c6b180f1b5e8d8f86203b3.tar.gz
gentoo-7ad57335d01b572de6c6b180f1b5e8d8f86203b3.tar.bz2
gentoo-7ad57335d01b572de6c6b180f1b5e8d8f86203b3.zip
games-util/pyfa: update live ebuild
Closes: https://github.com/gentoo/gentoo/pull/7367 Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'games-util/pyfa')
-rw-r--r--games-util/pyfa/pyfa-9999.ebuild36
1 files changed, 16 insertions, 20 deletions
diff --git a/games-util/pyfa/pyfa-9999.ebuild b/games-util/pyfa/pyfa-9999.ebuild
index dbd5180ef370..32200ccbee19 100644
--- a/games-util/pyfa/pyfa-9999.ebuild
+++ b/games-util/pyfa/pyfa-9999.ebuild
@@ -1,33 +1,35 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
PYTHON_COMPAT=( python2_7 )
PYTHON_REQ_USE="sqlite,threads"
-inherit eutils gnome2-utils python-r1
+inherit desktop eutils gnome2-utils python-r1
DESCRIPTION="Python Fitting Assistant - a ship fitting application for EVE Online"
HOMEPAGE="https://github.com/pyfa-org/Pyfa"
-LICENSE="GPL-3+ LGPL-2.1+ CC-BY-2.5 free-noncomm"
+RESTRICT="mirror bindist"
+LICENSE="GPL-3+ all-rights-reserved"
SLOT="0"
if [[ ${PV} = 9999 ]]; then
EGIT_REPO_URI="https://github.com/pyfa-org/Pyfa.git"
inherit git-r3
KEYWORDS=""
else
- SRC_URI="https://github.com/pyfa-org/Pyfa/archive/v${PV}.tar.gz -> pyfa-${PV}.tar.gz"
+ SRC_URI="https://github.com/pyfa-org/Pyfa/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
fi
IUSE="+graph"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-RDEPEND="dev-python/python-dateutil[${PYTHON_USEDEP}]
- >=dev-python/sqlalchemy-1.0.5[${PYTHON_USEDEP}]
- dev-python/wxpython:3.0[${PYTHON_USEDEP}]
+RDEPEND="
>=dev-python/logbook-1.0.0[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
dev-python/requests[${PYTHON_USEDEP}]
+ >=dev-python/sqlalchemy-1.0.5[${PYTHON_USEDEP}]
+ dev-python/wxpython:3.0[${PYTHON_USEDEP}]
graph? (
dev-python/matplotlib[wxwidgets,${PYTHON_USEDEP}]
dev-python/numpy[${PYTHON_USEDEP}] )
@@ -48,28 +50,26 @@ src_prepare() {
eapply_user
- touch __init__.py
+ # make python recognize pyfa as a package
+ touch __init__.py || die
pyfa_make_configforced() {
mkdir -p "${BUILD_DIR}" || die
sed -e "s:%%SITEDIR%%:$(python_get_sitedir):" \
-e "s:%%EPREFIX%%:${EPREFIX}:" \
- "${FILESDIR}/configforced-1.15.1.py" > "${BUILD_DIR}/configforced.py"
+ "${FILESDIR}/configforced-1.15.1.py" > "${BUILD_DIR}/configforced.py" || die
sed -e "s:%%SITEDIR%%:$(python_get_sitedir):" \
- pyfa.py > "${BUILD_DIR}/pyfa"
+ pyfa.py > "${BUILD_DIR}/pyfa" || die
}
python_foreach_impl pyfa_make_configforced
}
src_install() {
pyfa_py_install() {
- local packagedir=$(python_get_sitedir)/${PN}
- insinto "${packagedir}"
- doins -r eos gui service utils config*.py __init__.py
- [[ -e info.py ]] && doins info.py # only in zip releases
- doins "${BUILD_DIR}/configforced.py"
+ python_moduleinto ${PN}
+ python_domodule eos gui service utils config*.py __init__.py
+ python_domodule "${BUILD_DIR}/configforced.py"
python_doscript "${BUILD_DIR}/pyfa"
- python_optimize
}
python_foreach_impl pyfa_py_install
@@ -88,10 +88,6 @@ src_install() {
domenu "${FILESDIR}/${PN}.desktop"
}
-pkg_preinst() {
- gnome2_icon_savelist
-}
-
pkg_postinst() {
gnome2_icon_cache_update
}