summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2021-06-14 18:07:00 -0400
committerIonen Wolkens <ionen@gentoo.org>2021-06-14 18:55:16 -0400
commit449d7802c1c41097291ff82f28518ae7afffec3e (patch)
treeeee8d647985572f08ec6a48260ad26b991813a62 /games-util/ucon64/files
parentnet-misc/lksctp-tools: bump to v1.0.19 (diff)
downloadgentoo-449d7802c1c41097291ff82f28518ae7afffec3e.tar.gz
gentoo-449d7802c1c41097291ff82f28518ae7afffec3e.tar.bz2
gentoo-449d7802c1c41097291ff82f28518ae7afffec3e.zip
games-util/ucon64: add 2.2.1
- add IUSE debug, usb, zlib - set default discmage.so path not to need user intervention - shorter elog given ucon64's output already mentions .ucon64/dat - use fixes suggested by upstream in bug #753950 Closes: https://bugs.gentoo.org/753950 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-util/ucon64/files')
-rw-r--r--games-util/ucon64/files/ucon64-2.2.1-change-mem2-64bit.patch23
-rw-r--r--games-util/ucon64/files/ucon64-2.2.1-respect-flags.patch35
-rw-r--r--games-util/ucon64/files/ucon64-2.2.1-zlib.patch26
3 files changed, 84 insertions, 0 deletions
diff --git a/games-util/ucon64/files/ucon64-2.2.1-change-mem2-64bit.patch b/games-util/ucon64/files/ucon64-2.2.1-change-mem2-64bit.patch
new file mode 100644
index 000000000000..d07a18fdd8f0
--- /dev/null
+++ b/games-util/ucon64/files/ucon64-2.2.1-change-mem2-64bit.patch
@@ -0,0 +1,23 @@
+Fix crash on 64bit platforms in change_mem2()
+https://bugs.gentoo.org/753950
+
+From upstream:
+https://sourceforge.net/p/ucon64/svn/2821/
+--- a/libdiscmage/misc.c
++++ b/libdiscmage/misc.c
+@@ -1875,5 +1875,5 @@
+ if (strpos == pos_1st_esc)
+ setindex = 0; // reset argument pointer
+- if (pos_1st_esc == (unsigned int) -1)
++ if (pos_1st_esc == (size_t) -1)
+ pos_1st_esc = strpos;
+
+--- a/misc/misc.c
++++ b/misc/misc.c
+@@ -502,5 +502,5 @@
+ if (strpos == pos_1st_esc)
+ setindex = 0; // reset argument pointer
+- if (pos_1st_esc == (unsigned int) -1)
++ if (pos_1st_esc == (size_t) -1)
+ pos_1st_esc = strpos;
+
diff --git a/games-util/ucon64/files/ucon64-2.2.1-respect-flags.patch b/games-util/ucon64/files/ucon64-2.2.1-respect-flags.patch
new file mode 100644
index 000000000000..c1c9ed6f78da
--- /dev/null
+++ b/games-util/ucon64/files/ucon64-2.2.1-respect-flags.patch
@@ -0,0 +1,35 @@
+Respect *FLAGS and toolchain variables in Makefiles where missing.
+--- a/Makefile
++++ b/Makefile
+@@ -12,3 +12,3 @@
+ CFLAGS+=-I. -Wall -W -Wno-implicit-fallthrough -Wno-format-truncation \
+--Wno-stringop-overflow -O3 -fsigned-char
++-Wno-stringop-overflow -fsigned-char
+ # Enable -Wstringop-overflow[=type] when it is no longer a broken, partial
+@@ -19,3 +19,2 @@
+ # ld: warning: option -s is obsolete and being ignored
+-LDFLAGS+=-s
+ endif
+--- a/backup/libcd64/Makefile
++++ b/backup/libcd64/Makefile
+@@ -1,2 +1 @@
+-CC=gcc
+
+@@ -7,3 +6,2 @@
+ else
+-CFLAGS+=-O6 -funroll-loops -fexpensive-optimizations
+ endif
+@@ -181,4 +179,4 @@
+ else
+- ld -r $^ $(LIBS) -o $*.o
+- ar crs $@ $*.o
++ $(LD) -r $^ $(LIBS) -o $*.o
++ $(AR) crs $@ $*.o
+ endif
+--- a/libdiscmage/Makefile.in
++++ b/libdiscmage/Makefile.in
+@@ -33,3 +33,2 @@
+ # /usr/bin/libtool: -static not specified, -s invalid
+-LDFLAGS+=-s
+ endif
+
diff --git a/games-util/ucon64/files/ucon64-2.2.1-zlib.patch b/games-util/ucon64/files/ucon64-2.2.1-zlib.patch
new file mode 100644
index 000000000000..a618c3bce75a
--- /dev/null
+++ b/games-util/ucon64/files/ucon64-2.2.1-zlib.patch
@@ -0,0 +1,26 @@
+Fix undefined macro issue when compiling with zlib.
+https://bugs.gentoo.org/753950
+
+From upstream:
+https://sourceforge.net/p/ucon64/svn/2817/
+https://sourceforge.net/p/ucon64/svn/2819/
+--- a/libdiscmage/ioapi.h
++++ b/libdiscmage/ioapi.h
+@@ -35,4 +35,7 @@
+ extern "C" {
+ #endif
++#ifndef OF
++#define OF(x) x
++#endif
+
+ typedef voidpf (ZCALLBACK *open_file_func) OF((voidpf opaque, const char* filename, int mode));
+--- a/misc/ioapi.h
++++ b/misc/ioapi.h
+@@ -35,4 +35,7 @@
+ extern "C" {
+ #endif
++#ifndef OF
++#define OF(x) x
++#endif
+
+ typedef voidpf (ZCALLBACK *open_file_func) OF((voidpf opaque, const char* filename, int mode));