summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2016-12-16 11:31:25 +0100
committerDavid Seifert <soap@gentoo.org>2016-12-16 11:56:49 +0100
commit946021f3cbce9688b84fa96a59a11b78a9594b9e (patch)
treeb901ef063fe984a0a701bdf0f8ee14bbf78a999f /games-util/xboxdrv
parentx11-libs/libXpm: x86 stable wrt bug #602782 (diff)
downloadgentoo-946021f3cbce9688b84fa96a59a11b78a9594b9e.tar.gz
gentoo-946021f3cbce9688b84fa96a59a11b78a9594b9e.tar.bz2
gentoo-946021f3cbce9688b84fa96a59a11b78a9594b9e.zip
games-util/xboxdrv: Fix building with GCC 6
Gentoo-bug: 594674 Package-Manager: portage-2.3.3
Diffstat (limited to 'games-util/xboxdrv')
-rw-r--r--games-util/xboxdrv/files/xboxdrv-0.8.8-fix-c++14.patch16
-rw-r--r--games-util/xboxdrv/xboxdrv-0.8.8.ebuild1
2 files changed, 17 insertions, 0 deletions
diff --git a/games-util/xboxdrv/files/xboxdrv-0.8.8-fix-c++14.patch b/games-util/xboxdrv/files/xboxdrv-0.8.8-fix-c++14.patch
new file mode 100644
index 000000000000..80a8d8f550e1
--- /dev/null
+++ b/games-util/xboxdrv/files/xboxdrv-0.8.8-fix-c++14.patch
@@ -0,0 +1,16 @@
+Cast boost::shared_ptr explicitly for C++14.
+See also: https://bugs.gentoo.org/show_bug.cgi?id=594674
+
+--- a/src/controller_slot.cpp
++++ b/src/controller_slot.cpp
+@@ -67,9 +67,9 @@ ControllerSlot::disconnect()
+ }
+
+ bool
+ ControllerSlot::is_connected() const
+ {
+- return m_thread;
++ return static_cast<bool>(m_thread);
+ }
+
+ /* EOF */
diff --git a/games-util/xboxdrv/xboxdrv-0.8.8.ebuild b/games-util/xboxdrv/xboxdrv-0.8.8.ebuild
index 04d3c7d0782b..804d3facbd79 100644
--- a/games-util/xboxdrv/xboxdrv-0.8.8.ebuild
+++ b/games-util/xboxdrv/xboxdrv-0.8.8.ebuild
@@ -29,6 +29,7 @@ S=${WORKDIR}/${MY_P}
PATCHES=(
"${FILESDIR}"/${P}-scons.patch
"${FILESDIR}"/github-144.patch
+ "${FILESDIR}"/${P}-fix-c++14.patch
)
CONFIG_CHECK="~INPUT_EVDEV ~INPUT_JOYDEV ~INPUT_UINPUT ~!JOYSTICK_XPAD"