summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-11-21 21:37:52 +0100
committerDavid Seifert <soap@gentoo.org>2020-11-21 21:37:52 +0100
commit279a598fceda81830fd5a42feb7f53581dbabeca (patch)
tree09b3addd3bc662d701eb07097df40b0b87a04936 /games-util
parentdev-ruby/execjs-2.7.0: drop ppc keyword (diff)
downloadgentoo-279a598fceda81830fd5a42feb7f53581dbabeca.tar.gz
gentoo-279a598fceda81830fd5a42feb7f53581dbabeca.tar.bz2
gentoo-279a598fceda81830fd5a42feb7f53581dbabeca.zip
games-util/xqf: Port to EAPI 7
Closes: https://bugs.gentoo.org/633562 Closes: https://bugs.gentoo.org/708754 Closes: https://bugs.gentoo.org/739402 Closes: https://bugs.gentoo.org/741774 Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'games-util')
-rw-r--r--games-util/xqf/files/xqf-1.0.6.2-fno-common.patch21
-rw-r--r--games-util/xqf/files/xqf-1.0.6.2-underlink.patch14
-rw-r--r--games-util/xqf/xqf-1.0.6.2.ebuild31
3 files changed, 50 insertions, 16 deletions
diff --git a/games-util/xqf/files/xqf-1.0.6.2-fno-common.patch b/games-util/xqf/files/xqf-1.0.6.2-fno-common.patch
new file mode 100644
index 000000000000..15147ac6d917
--- /dev/null
+++ b/games-util/xqf/files/xqf-1.0.6.2-fno-common.patch
@@ -0,0 +1,21 @@
+--- a/src/filter.c
++++ b/src/filter.c
+@@ -88,6 +88,8 @@
+ const char* filter_quick_get(void);
+ void filter_quick_unset (void);
+
++unsigned int current_server_filter;
++
+ /* /QUICK FILTER */
+
+ struct filter filters[FILTERS_TOTAL] = {
+--- a/src/filter.h
++++ b/src/filter.h
+@@ -89,7 +89,6 @@
+
+ extern GArray* server_filters;
+
+-unsigned int current_server_filter;
+ extern unsigned int current_server_filter;
+
+
diff --git a/games-util/xqf/files/xqf-1.0.6.2-underlink.patch b/games-util/xqf/files/xqf-1.0.6.2-underlink.patch
index fe93c7624675..a40961eb25ff 100644
--- a/games-util/xqf/files/xqf-1.0.6.2-underlink.patch
+++ b/games-util/xqf/files/xqf-1.0.6.2-underlink.patch
@@ -1,5 +1,5 @@
---- xqf-xqf-1.0.6.2/src/Makefile.am
-+++ xqf-xqf-1.0.6.2/src/Makefile.am
+--- a/src/Makefile.am
++++ b/src/Makefile.am
@@ -41,6 +41,7 @@
$(GEOIP_LIB) \
$(PACKAGE_LIBS) \
@@ -8,3 +8,13 @@
-lz -ldl
xqf_LDFLAGS = -Wl,-rpath,$(pkglibdir) -Wl,--export-dynamic -Wl,--version-script=$(top_srcdir)/src/xqf.map
+--- a/po/POTFILES.in
++++ b/po/POTFILES.in
+@@ -21,6 +21,7 @@
+ #src/rc.c
+ src/rcon.c
+ src/redial.c
++src/scripts.c
+ #src/server.c
+ #src/skin.c
+ #src/skin_pcx.c
diff --git a/games-util/xqf/xqf-1.0.6.2.ebuild b/games-util/xqf/xqf-1.0.6.2.ebuild
index 5ea89476375a..9c9510182f86 100644
--- a/games-util/xqf/xqf-1.0.6.2.ebuild
+++ b/games-util/xqf/xqf-1.0.6.2.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit autotools eutils
+EAPI=7
+
+inherit autotools
DESCRIPTION="A server browser for many FPS games (frontend for qstat)"
HOMEPAGE="http://xqf.github.io/en/"
@@ -13,26 +14,28 @@ SLOT="0"
KEYWORDS="~amd64 ~hppa ~x86"
IUSE="bzip2 geoip nls"
-RDEPEND="x11-libs/gtk+:2
+RDEPEND="
+ x11-libs/gdk-pixbuf-xlib
+ x11-libs/gtk+:2
>=games-util/qstat-2.11
nls? ( virtual/libintl )
geoip? ( dev-libs/geoip )
bzip2? ( app-arch/bzip2 )"
-DEPEND="${RDEPEND}
+DEPEND="${RDEPEND}"
+BDEPEND="
virtual/pkgconfig
nls? ( sys-devel/gettext )"
-S=${WORKDIR}/${PN}-${P}
+S="${WORKDIR}/${PN}-${P}"
-# bug #288853
-src_prepare() {
- epatch \
- "${FILESDIR}"/${P}-underlink.patch \
- "${FILESDIR}"/${P}-zlib-1.2.5.1-compile-fix.patch
- sed -i \
- -e '/Icon/s/.png//' \
- xqf.desktop.in || die
+PATCHES=(
+ "${FILESDIR}"/${P}-underlink.patch
+ "${FILESDIR}"/${P}-zlib-1.2.5.1-compile-fix.patch
+ "${FILESDIR}"/${P}-fno-common.patch
+)
+src_prepare() {
+ default
mv configure.{in,ac} || die
eautoreconf
}