summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2020-09-11 10:04:55 +0200
committerLars Wendler <polynomial-c@gentoo.org>2020-09-11 10:08:59 +0200
commit29b588944a03fb6f123226952666c5b0a3f99d86 (patch)
tree837e6c4d3c9ff4a310542f1e474f4ef0c3ffdffa /games-util
parentgames-emulation/dolphin: allow new rangeset depend (diff)
downloadgentoo-29b588944a03fb6f123226952666c5b0a3f99d86.tar.gz
gentoo-29b588944a03fb6f123226952666c5b0a3f99d86.tar.bz2
gentoo-29b588944a03fb6f123226952666c5b0a3f99d86.zip
games-util/lutris: Bump to version 0.5.7.1
Converted to only use a single python implementation in order to avoid bug #740048 Thanks-to: Arfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org> Closes: https://bugs.gentoo.org/733828 Closes: https://bugs.gentoo.org/740048 Package-Manager: Portage-3.0.6, Repoman-3.0.1 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'games-util')
-rw-r--r--games-util/lutris/Manifest1
-rw-r--r--games-util/lutris/files/lutris-0.5.7-copy_paste_fix.patch38
-rw-r--r--games-util/lutris/lutris-0.5.7.1.ebuild82
3 files changed, 121 insertions, 0 deletions
diff --git a/games-util/lutris/Manifest b/games-util/lutris/Manifest
index 0e52c75c49c3..678e040bedaf 100644
--- a/games-util/lutris/Manifest
+++ b/games-util/lutris/Manifest
@@ -1,3 +1,4 @@
DIST lutris_0.5.4.tar.xz 1843880 BLAKE2B f286d62df3bf5a5eadd634d2d177a5b69b5fa5d897e70f58a19be4148609e56ba33c29ce4218ae833dbdf9dded1e9be869f9ed4d84ba2b435a09981219d74438 SHA512 81669f2021063229bad78ebc49b54075058266716279695c53c43a5a06a8c1d4e5a9dcbcb20a1becfe0d243aa6e812f5a30b4d90f418d4cffcff18daefb09c50
DIST lutris_0.5.6.tar.xz 1747440 BLAKE2B e39206d8245d99a0424537cd9d9ed860c4e0d9fd373afe61d7e19eb2672bee621d541060af74f1197242e49a846e70fe16eb28e0c57370d2e11634d7035ab1fe SHA512 3ac9f7095c30044990e42f671d6e1e5cac6cd921cdf93e175400335cb6e9ae5b1bf8101dc0805838f3c5bf9713b891c62960c80a1a20aef1e4f896a74af97a01
+DIST lutris_0.5.7.1.tar.xz 2145584 BLAKE2B eb766d5e36aca63af7af8f2e85f51b4e3e37b8372b13a59702c545a0c697fa5feb1403cd9589d22c2bdff6593f69ed39e1bcb7ecb28ecc24b7a77b09ed1b2f89 SHA512 9efff4d92ae4d9051a7253324047dfa57f463188ebdbcede5feba2c0268494e8fa7929d2ef30bfe85e52824bbb9c05b1f1688b6658376597cc4cc35c26a19da3
DIST lutris_0.5.7.tar.xz 2133524 BLAKE2B d27191668f582a5cd50941ca227d6121f1bfdb4824c490dd54cc513fda523712af9480451b0e5503404aba8d083c94ce91b928ed3faf4e94ea9f0bbf28b764c1 SHA512 f751be82dd5550dc882932980a3a04a62f183e5f0dddc9939154025408da081392917834324875a80ae8b354906e04835c2df56c23f1d6d29cd9fbdc514e1c57
diff --git a/games-util/lutris/files/lutris-0.5.7-copy_paste_fix.patch b/games-util/lutris/files/lutris-0.5.7-copy_paste_fix.patch
new file mode 100644
index 000000000000..3e278561aa3b
--- /dev/null
+++ b/games-util/lutris/files/lutris-0.5.7-copy_paste_fix.patch
@@ -0,0 +1,38 @@
+From 9603da9d4eda1656219a4c79e1f9d1a958165151 Mon Sep 17 00:00:00 2001
+From: Austin Pua <pua.austin.anderson@gmail.com>
+Date: Wed, 1 Jul 2020 21:48:09 +0800
+Subject: [PATCH] Fix copy paste issue in auth webviews
+
+---
+ lutris/services/gog.py | 3 ++-
+ lutris/services/humblebundle.py | 3 ++-
+ 2 files changed, 4 insertions(+), 2 deletions(-)
+
+diff --git a/lutris/services/gog.py b/lutris/services/gog.py
+index 0eed7778c..099f9083d 100644
+--- a/lutris/services/gog.py
++++ b/lutris/services/gog.py
+@@ -279,7 +279,8 @@ def connect(parent=None):
+ """Connect to GOG"""
+ logger.debug("Connecting to GOG")
+ dialog = WebConnectDialog(SERVICE, parent)
+- dialog.run()
++ dialog.set_modal(True)
++ dialog.show()
+
+
+ def disconnect():
+diff --git a/lutris/services/humblebundle.py b/lutris/services/humblebundle.py
+index 6dcfe6911..056ef9460 100644
+--- a/lutris/services/humblebundle.py
++++ b/lutris/services/humblebundle.py
+@@ -152,7 +152,8 @@ def is_connected():
+ def connect(parent=None):
+ """Connect to Humble Bundle"""
+ dialog = WebConnectDialog(SERVICE, parent)
+- dialog.run()
++ dialog.set_modal(True)
++ dialog.show()
+
+
+ def disconnect():
diff --git a/games-util/lutris/lutris-0.5.7.1.ebuild b/games-util/lutris/lutris-0.5.7.1.ebuild
new file mode 100644
index 000000000000..fb54a72d2b4d
--- /dev/null
+++ b/games-util/lutris/lutris-0.5.7.1.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_REQ_USE="sqlite,threads(+)"
+DISTUTILS_SINGLE_IMPL="1"
+
+inherit distutils-r1 virtualx xdg
+
+DESCRIPTION="An open source gaming platform for GNU/Linux"
+HOMEPAGE="https://lutris.net/"
+
+if [[ ${PV} == *9999* ]] ; then
+ EGIT_REPO_URI="https://github.com/lutris/lutris.git"
+ inherit git-r3
+else
+ SRC_URI="https://lutris.net/releases/${P/-/_}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${PN}"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ test? (
+ $(python_gen_cond_dep '
+ dev-python/nose[${PYTHON_USEDEP}]
+ ')
+ )
+"
+RDEPEND="
+ app-arch/cabextract
+ app-arch/p7zip
+ app-arch/unrar
+ app-arch/unzip
+ $(python_gen_cond_dep '
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/python-evdev[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ ')
+ gnome-base/gnome-desktop:3[introspection]
+ media-sound/fluid-soundfont
+ net-libs/libsoup
+ net-libs/webkit-gtk:4[introspection]
+ x11-apps/mesa-progs
+ x11-apps/xgamma
+ x11-apps/xrandr
+ x11-libs/gtk+:3[introspection]
+ x11-libs/libnotify
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.5.7-copy_paste_fix.patch"
+)
+
+python_install_all() {
+ local DOCS=( AUTHORS README.rst docs/installers.rst )
+ distutils-r1_python_install_all
+ python_fix_shebang "${ED}"/usr/share/lutris/bin/lutris-wrapper #740048
+}
+
+python_test() {
+ virtx nosetests -v
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ # Quote README.rst
+ elog "Lutris installations are fully automated through scripts, which can"
+ elog "be written in either JSON or YAML. The scripting syntax is described"
+ elog "in ${EROOT}/usr/share/doc/${PF}/installers.rst.bz2, and is also"
+ elog "available online at lutris.net."
+}