summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2020-08-19 17:19:32 +0200
committerConrad Kostecki <conikost@gentoo.org>2020-08-19 17:19:32 +0200
commit59a374c3bd469e97ad7dc000b0bc2ceae53002e7 (patch)
tree8a22966cfff1b6a3ab093c30060d4bf78332d69d /games-util
parentgames-util/nml: bump to version 0.5.2 (diff)
downloadgentoo-59a374c3bd469e97ad7dc000b0bc2ceae53002e7.tar.gz
gentoo-59a374c3bd469e97ad7dc000b0bc2ceae53002e7.tar.bz2
gentoo-59a374c3bd469e97ad7dc000b0bc2ceae53002e7.zip
games-util/nml: revbump due runtime change
Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'games-util')
-rw-r--r--games-util/nml/nml-0.4.5-r3.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/games-util/nml/nml-0.4.5-r3.ebuild b/games-util/nml/nml-0.4.5-r3.ebuild
new file mode 100644
index 000000000000..3588cfc60e87
--- /dev/null
+++ b/games-util/nml/nml-0.4.5-r3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Compiler of NML files into GRF/NFO files"
+HOMEPAGE="https://dev.openttdcoop.org/projects/nml"
+SRC_URI="https://bundles.openttdcoop.org/nml/releases/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+
+RDEPEND="
+ dev-python/pillow[zlib,${PYTHON_USEDEP}]
+ dev-python/ply[${PYTHON_USEDEP}]
+"
+
+DEPEND="
+ ${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+DOCS=( docs/{changelog,readme}.txt )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.4.4-pillow3.patch
+ "${FILESDIR}"/${PN}-0.4.5-pillow6.patch
+ "${FILESDIR}"/${PN}-0.4.5-pillow7.patch
+ "${FILESDIR}"/${PN}-0.4.5-python38.patch
+)
+
+src_install() {
+ distutils-r1_src_install
+
+ doman docs/nmlc.1
+}