summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-04 09:25:15 +0000
committerSam James <sam@gentoo.org>2021-04-04 09:51:52 +0000
commit5c8db59126374340ed571149ec8680ccad1378e6 (patch)
tree1e2623d63a87aa891e21874dc59da8ca648ef20f /games-util
parentgames-util/xpadneo: toolchain-funcs-- (diff)
downloadgentoo-5c8db59126374340ed571149ec8680ccad1378e6.tar.gz
gentoo-5c8db59126374340ed571149ec8680ccad1378e6.tar.bz2
gentoo-5c8db59126374340ed571149ec8680ccad1378e6.zip
games-util/glbsp: port to EAPI 7, eutils--
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-util')
-rw-r--r--games-util/glbsp/files/glbsp-2.24-ldflags.patch8
-rw-r--r--games-util/glbsp/glbsp-2.24.ebuild19
2 files changed, 16 insertions, 11 deletions
diff --git a/games-util/glbsp/files/glbsp-2.24-ldflags.patch b/games-util/glbsp/files/glbsp-2.24-ldflags.patch
index e6adb0ff035c..56c9a4abcd8a 100644
--- a/games-util/glbsp/files/glbsp-2.24-ldflags.patch
+++ b/games-util/glbsp/files/glbsp-2.24-ldflags.patch
@@ -1,5 +1,5 @@
---- Makefile.unx.old 2010-11-25 11:24:48.000000000 +0100
-+++ Makefile.unx 2010-11-25 11:25:10.000000000 +0100
+--- a/Makefile.unx
++++ b/Makefile.unx
@@ -79,8 +79,7 @@
$(CC) $(CMD_FLAGS) -c $^ -o $@
@@ -10,8 +10,8 @@
install: $(CMD_NAME)
cp $(CMD_NAME) $(INSTALL_PREFIX)/bin/
---- Makefile.unx.old 2010-11-25 11:31:27.000000000 +0100
-+++ Makefile.unx 2010-11-25 11:31:31.000000000 +0100
+--- a/Makefile.unx
++++ b/Makefile.unx
@@ -125,7 +125,6 @@
$(GUI_NAME): $(LIB_NAME) $(GUI_OBJS)
diff --git a/games-util/glbsp/glbsp-2.24.ebuild b/games-util/glbsp/glbsp-2.24.ebuild
index e6c982167ae0..79ed87ae1288 100644
--- a/games-util/glbsp/glbsp-2.24.ebuild
+++ b/games-util/glbsp/glbsp-2.24.ebuild
@@ -1,13 +1,15 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit eutils toolchain-funcs versionator
+EAPI=7
-MY_PV=$(delete_version_separator 1)
+inherit desktop toolchain-funcs
+
+MY_PV=$(ver_rs 1 '')
DESCRIPTION="A node builder specially designed for OpenGL ports of the DOOM game engine"
HOMEPAGE="http://glbsp.sourceforge.net/"
SRC_URI="mirror://sourceforge/glbsp/${PN}_src_${MY_PV}.tar.gz"
+S="${WORKDIR}"/${P}-source
LICENSE="GPL-2"
SLOT="0"
@@ -15,12 +17,15 @@ KEYWORDS="~amd64 ~x86"
IUSE="fltk"
DEPEND="fltk? ( x11-libs/fltk:1 )"
-RDEPEND=${DEPEND}
+RDEPEND="${DEPEND}"
-S=${WORKDIR}/${P}-source
+PATCHES=(
+ "${FILESDIR}"/${P}-ldflags.patch
+)
src_prepare() {
- epatch "${FILESDIR}"/${P}-ldflags.patch
+ default
+
sed -i \
-e "/^CC=/s:=.*:=$(tc-getCC):" \
-e "/^CXX=/s:=.*:=$(tc-getCXX):" \