summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2020-04-10 12:44:41 +0300
committerJoonas Niilola <juippis@gentoo.org>2020-04-10 13:30:02 +0300
commit8833fd81190992809feb90317e98f3fa22a44800 (patch)
tree2a845e8bbca6a2f238d4e0d80ab271ca588e618a /games-util
parentgames-util/pyfa: remove old versions (diff)
downloadgentoo-8833fd81190992809feb90317e98f3fa22a44800.tar.gz
gentoo-8833fd81190992809feb90317e98f3fa22a44800.tar.bz2
gentoo-8833fd81190992809feb90317e98f3fa22a44800.zip
games-util/pyfa: tidy 2.19.0.ebuild
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'games-util')
-rw-r--r--games-util/pyfa/pyfa-2.19.0.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/games-util/pyfa/pyfa-2.19.0.ebuild b/games-util/pyfa/pyfa-2.19.0.ebuild
index 145ca005c0d1..c1952e88595f 100644
--- a/games-util/pyfa/pyfa-2.19.0.ebuild
+++ b/games-util/pyfa/pyfa-2.19.0.ebuild
@@ -2,6 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
+
PYTHON_COMPAT=( python3_6 )
PYTHON_REQ_USE="sqlite,threads"
@@ -18,9 +19,9 @@ if [[ ${PV} = 9999 ]]; then
else
SRC_URI="https://github.com/pyfa-org/Pyfa/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
- S=${WORKDIR}/Pyfa-${PV}
+ S="${WORKDIR}/Pyfa-${PV}"
fi
-IUSE=""
+
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RESTRICT="mirror bindist"
@@ -49,7 +50,7 @@ BDEPEND="app-arch/zip"
PATCHES=(
# fix import path in the main script for systemwide installation
"${FILESDIR}/${PN}-2.9.3-import-pyfa.patch"
- )
+)
src_prepare() {
# get rid of CRLF line endings introduced in 1.1.10 so patches work