summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-01-10 06:06:32 +0000
committerSam James <sam@gentoo.org>2023-01-10 06:06:32 +0000
commitc0d90d4543062c23fc2b5b4276f8bd57512dad3c (patch)
tree8d54d583a45fd0f5e41dd8341df689086db6cc94 /games-util
parentnet-misc/rsync: enable py3.11 (diff)
downloadgentoo-c0d90d4543062c23fc2b5b4276f8bd57512dad3c.tar.gz
gentoo-c0d90d4543062c23fc2b5b4276f8bd57512dad3c.tar.bz2
gentoo-c0d90d4543062c23fc2b5b4276f8bd57512dad3c.zip
games-util/nml: enable py3.11
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-util')
-rw-r--r--games-util/nml/nml-0.6.1.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/games-util/nml/nml-0.6.1.ebuild b/games-util/nml/nml-0.6.1.ebuild
index a378873b7b05..9b47a1fe387a 100644
--- a/games-util/nml/nml-0.6.1.ebuild
+++ b/games-util/nml/nml-0.6.1.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_SINGLE_IMPL=1
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( python3_{8..11} )
inherit distutils-r1
DESCRIPTION="Compiler of NML files into GRF/NFO files"
@@ -19,7 +19,9 @@ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
RDEPEND="
$(python_gen_cond_dep '
dev-python/pillow[${PYTHON_USEDEP},zlib]
- dev-python/ply[${PYTHON_USEDEP}]')"
+ dev-python/ply[${PYTHON_USEDEP}]
+ ')
+"
src_install() {
local DOCS=( README.md docs/changelog.txt )