summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2021-02-16 07:59:27 +0100
committerLars Wendler <polynomial-c@gentoo.org>2021-02-16 07:59:27 +0100
commitcd7651c0c10634b19cb3e6986339528ee0652923 (patch)
treea80fe3cd3e8024ad14bbec4f41ce7d7f65692f19 /games-util
parentnet-misc/whois: Bump to version 5.5.8 (diff)
downloadgentoo-cd7651c0c10634b19cb3e6986339528ee0652923.tar.gz
gentoo-cd7651c0c10634b19cb3e6986339528ee0652923.tar.bz2
gentoo-cd7651c0c10634b19cb3e6986339528ee0652923.zip
games-util/lutris: Bump to version 0.5.8.3
Closes: https://bugs.gentoo.org/770865 Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'games-util')
-rw-r--r--games-util/lutris/Manifest1
-rw-r--r--games-util/lutris/lutris-0.5.8.3.ebuild78
2 files changed, 79 insertions, 0 deletions
diff --git a/games-util/lutris/Manifest b/games-util/lutris/Manifest
index 281ec26d2b77..b848dd3d8eea 100644
--- a/games-util/lutris/Manifest
+++ b/games-util/lutris/Manifest
@@ -1,3 +1,4 @@
DIST lutris_0.5.7.1.tar.xz 2145584 BLAKE2B eb766d5e36aca63af7af8f2e85f51b4e3e37b8372b13a59702c545a0c697fa5feb1403cd9589d22c2bdff6593f69ed39e1bcb7ecb28ecc24b7a77b09ed1b2f89 SHA512 9efff4d92ae4d9051a7253324047dfa57f463188ebdbcede5feba2c0268494e8fa7929d2ef30bfe85e52824bbb9c05b1f1688b6658376597cc4cc35c26a19da3
DIST lutris_0.5.8.1.tar.xz 893328 BLAKE2B 67c66b59c3fa78af46f953b6e27fb3dd77d0e4cb0746f490716c7c074e81afa4f9c4e8c10dc6d4dab3e2b37d03254bae5eda0b777da72bc17f18dda5fd1f990a SHA512 da3b5ebf3e5dcc5011351197c5a80e8547e54df4555ea9124a8404877c5b75225cfae970819a171c55454fef73afdd927dafbf427301b71618c33660a1c8c022
+DIST lutris_0.5.8.3.tar.xz 942716 BLAKE2B f831c6ad6f67c3948f07e89f9caacd0d8aa3878b912fe987afea85eea549f41347044967255fa80e4e0c4544d148d9782dfe3c5bf08a123436e8a5ef7034901f SHA512 8f653d38a9a551298fa344cde67d53bf50cfd2a0a0667e344d04f6e17dda4ef358037755975d1a7f74ecd39824d58f9586e8a82b70dccc26619f22fee94d1144
DIST lutris_0.5.8.tar.xz 892740 BLAKE2B eaa8c71ade35392e701b3fd1d8ef2c0077e7fb7b96c3f037b5e4353d89b50b82e8a75fb2fb537e6ceeb9b6faaa5962e0ffe425f52820168b60eed742024610a4 SHA512 dcd963ff8b3c6d66fe79acc1e1c237196f7351d87bf1b4e5920201ecd7f1b2a80ac59f7151287e70e68c402c2b1b00e961d7314e6d5cbbbae0f4ca5fda562a0f
diff --git a/games-util/lutris/lutris-0.5.8.3.ebuild b/games-util/lutris/lutris-0.5.8.3.ebuild
new file mode 100644
index 000000000000..eb14c714095f
--- /dev/null
+++ b/games-util/lutris/lutris-0.5.8.3.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_REQ_USE="sqlite,threads(+)"
+DISTUTILS_SINGLE_IMPL="1"
+
+inherit distutils-r1 virtualx xdg
+
+DESCRIPTION="An open source gaming platform for GNU/Linux"
+HOMEPAGE="https://lutris.net/"
+
+if [[ ${PV} == *9999* ]] ; then
+ EGIT_REPO_URI="https://github.com/lutris/lutris.git"
+ inherit git-r3
+else
+ SRC_URI="https://lutris.net/releases/${P/-/_}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${PN}"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ test? (
+ $(python_gen_cond_dep '
+ dev-python/nose[${PYTHON_USEDEP}]
+ ')
+ )
+"
+RDEPEND="
+ app-arch/cabextract
+ app-arch/p7zip
+ app-arch/unzip
+ $(python_gen_cond_dep '
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/python-evdev[${PYTHON_USEDEP}]
+ dev-python/python-magic[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ ')
+ gnome-base/gnome-desktop:3[introspection]
+ media-sound/fluid-soundfont
+ net-libs/libsoup
+ net-libs/webkit-gtk:4[introspection]
+ x11-apps/mesa-progs
+ x11-apps/xgamma
+ x11-apps/xrandr
+ x11-libs/gtk+:3[introspection]
+ x11-libs/libnotify[introspection]
+"
+
+python_install_all() {
+ local DOCS=( AUTHORS README.rst docs/installers.rst )
+ distutils-r1_python_install_all
+ python_fix_shebang "${ED}"/usr/share/lutris/bin/lutris-wrapper #740048
+}
+
+python_test() {
+ virtx nosetests -v
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ # Quote README.rst
+ elog "Lutris installations are fully automated through scripts, which can"
+ elog "be written in either JSON or YAML. The scripting syntax is described"
+ elog "in ${EROOT}/usr/share/doc/${PF}/installers.rst.bz2, and is also"
+ elog "available online at lutris.net."
+}