summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-03-13 11:25:05 -0500
committerMatt Turner <mattst88@gentoo.org>2021-03-13 11:26:21 -0500
commitc6d963f9950929afd96970a07a4170b7d4e0f9f0 (patch)
treee61d676ddaca2a7b92e1f38b76b27086efa5f9f7 /gnome-base/dconf-editor
parentgnome-base/dconf: Version bump to 0.40.0 (diff)
downloadgentoo-c6d963f9950929afd96970a07a4170b7d4e0f9f0.tar.gz
gentoo-c6d963f9950929afd96970a07a4170b7d4e0f9f0.tar.bz2
gentoo-c6d963f9950929afd96970a07a4170b7d4e0f9f0.zip
gnome-base/dconf-editor: Version bump to 3.38.2
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'gnome-base/dconf-editor')
-rw-r--r--gnome-base/dconf-editor/Manifest1
-rw-r--r--gnome-base/dconf-editor/dconf-editor-3.38.2.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/gnome-base/dconf-editor/Manifest b/gnome-base/dconf-editor/Manifest
index 67400e4be980..a632da56e70d 100644
--- a/gnome-base/dconf-editor/Manifest
+++ b/gnome-base/dconf-editor/Manifest
@@ -1 +1,2 @@
DIST dconf-editor-3.36.4.tar.xz 583084 BLAKE2B 7d7f5164a4917d13372a2bcf7f9fe7b82d630693601bba33da1c4f3afffa58e4589ff90c3e5ca3039351a681eac6584b335171f4dce9d0bfedaed52cc25d505c SHA512 a24fa44830fb0e83834cf912267de6597c1d6bf02e063af4255409d3c9a135fae409116d91751d00ee8d2319e7130606f007af76d3ec9f1380cda98ab2329eff
+DIST dconf-editor-3.38.2.tar.xz 593428 BLAKE2B 6adb53cf2326d25b31d483645df9c2883658d525a32d1eb0ea13d410724911fbeb2ba17a948e4cca5e6a19e187d3cabf0a5722f7aae4dc70bc6699c13be9adc0 SHA512 64bcf7c5cea2c70f2c4ee08832490495c8c2dfee805d6fc27583e1369444f81ef9818f83de7c71228c88322f32c258c4550cc908263f1bb3032ab67e514efb2b
diff --git a/gnome-base/dconf-editor/dconf-editor-3.38.2.ebuild b/gnome-base/dconf-editor/dconf-editor-3.38.2.ebuild
new file mode 100644
index 000000000000..21fa99568f71
--- /dev/null
+++ b/gnome-base/dconf-editor/dconf-editor-3.38.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+VALA_MIN_API_VERSION="0.40"
+
+inherit gnome.org gnome2-utils meson vala xdg
+
+DESCRIPTION="Graphical tool for editing the dconf configuration database"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/dconf-editor"
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-linux"
+
+RDEPEND="
+ >=gnome-base/dconf-0.26.1
+ >=dev-libs/glib-2.55.1:2
+ >=x11-libs/gtk+-3.22.27:3
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ $(vala_depend)
+ dev-libs/libxml2:2
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ vala_src_prepare
+ xdg_src_prepare
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}