summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /gnome-base/dconf
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'gnome-base/dconf')
-rw-r--r--gnome-base/dconf/Manifest3
-rw-r--r--gnome-base/dconf/dconf-0.20.0.ebuild75
-rw-r--r--gnome-base/dconf/dconf-0.22.0.ebuild75
-rw-r--r--gnome-base/dconf/dconf-0.24.0.ebuild70
-rw-r--r--gnome-base/dconf/metadata.xml5
5 files changed, 228 insertions, 0 deletions
diff --git a/gnome-base/dconf/Manifest b/gnome-base/dconf/Manifest
new file mode 100644
index 000000000000..ab75472b9378
--- /dev/null
+++ b/gnome-base/dconf/Manifest
@@ -0,0 +1,3 @@
+DIST dconf-0.20.0.tar.xz 389388 SHA256 22c046a247d05ea65ad181e3aef4009c898a5531f76c0181f8ec0dfef83447d9 SHA512 d3069638ac8bfc077bbcef7878ad7e39c5c008d6b673128b685817e94a5ba147f4a3218e9547d9ce1a70260771f6f8e5c4c609fa5cf5530160373d7191aa3b00 WHIRLPOOL a82657d2ff5d0defd81fa9380a28798353e2e907869e85c089eb3c81c542662918cd15b850c9fb2929beee610f205aab01ddfe42312d571ae7712208e1a946fb
+DIST dconf-0.22.0.tar.xz 393260 SHA256 0a277cb0c3f09e77d9413c5a9b3577fc2b5d6e941b59b44940392e024a224b8e SHA512 fee502b599da3634934eadc3d9fc138f2036118e88edadf0e3dc157f8e689ee1fee057342a296197b126e5f657fcb2bb1f399b6a3ffa9ff5fdcc3119d9433d9b WHIRLPOOL 71214ae41394e5c86091674950bb0560f451247d5ae497411a37eebee89fa9ee6605206996303c3826247f31e6a05d2e693830cccd99e2991f0f76e130a4d3b0
+DIST dconf-0.24.0.tar.xz 218512 SHA256 4373e0ced1f4d7d68d518038796c073696280e22957babb29feb0267c630fec2 SHA512 8c2092f1a3002df386686473e6841d600665b3d2ae0e24625c9943b1a636706ecafc31e05f0db48958bbfd666680bb107f47978a9d867b151d1c61fc3c3b591a WHIRLPOOL 16f2fbf706247ad980c7c7cb3d937f060d4ed7c94209427eecd96d8ca55566e7da60d65d9dbf65b7476824215a0fa3bf0614ecfc6f4749ad017c515991bf9891
diff --git a/gnome-base/dconf/dconf-0.20.0.ebuild b/gnome-base/dconf/dconf-0.20.0.ebuild
new file mode 100644
index 000000000000..bdf7093f4e64
--- /dev/null
+++ b/gnome-base/dconf/dconf-0.20.0.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+
+inherit gnome2 bash-completion-r1 virtualx
+
+DESCRIPTION="Simple low-level configuration system"
+HOMEPAGE="https://wiki.gnome.org/dconf"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+
+# TODO: coverage ?
+IUSE="test X"
+
+KEYWORDS="alpha amd64 arm ia64 ~mips ppc ppc64 ~sh sparc x86 ~x86-fbsd ~arm-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-libs/glib-2.39.1:2
+ sys-apps/dbus
+ X? (
+ >=dev-libs/libxml2-2.7.7:2
+ >=x11-libs/gtk+-3.4:3 )
+"
+DEPEND="${RDEPEND}
+ dev-libs/libxslt
+ dev-util/gdbus-codegen
+ >=dev-util/gtk-doc-am-1.15
+ >=dev-util/intltool-0.50
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-gcov \
+ --enable-man \
+ $(use_enable X editor) \
+ VALAC=$(type -P true)
+}
+
+src_test() {
+ Xemake check
+}
+
+src_install() {
+ gnome2_src_install
+
+ # GSettings backend may be one of: memory, gconf, dconf
+ # Only dconf is really considered functional by upstream
+ # must have it enabled over gconf if both are installed
+ echo 'CONFIG_PROTECT_MASK="/etc/dconf"' >> 51dconf
+ echo 'GSETTINGS_BACKEND="dconf"' >> 51dconf
+ doenvd 51dconf
+
+ # Install bash-completion file properly to the system
+ rm -rv "${ED}usr/share/bash-completion" || die
+ dobashcomp "${S}/bin/completion/dconf"
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ # Kill existing dconf-service processes as recommended by upstream due to
+ # possible changes in the dconf private dbus API.
+ # dconf-service will be dbus-activated on next use.
+ pids=$(pgrep -x dconf-service)
+ if [[ $? == 0 ]]; then
+ ebegin "Stopping dconf-service; it will automatically restart on demand"
+ kill ${pids}
+ eend $?
+ fi
+}
diff --git a/gnome-base/dconf/dconf-0.22.0.ebuild b/gnome-base/dconf/dconf-0.22.0.ebuild
new file mode 100644
index 000000000000..2b4a49002e54
--- /dev/null
+++ b/gnome-base/dconf/dconf-0.22.0.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+
+inherit gnome2 bash-completion-r1 virtualx
+
+DESCRIPTION="Simple low-level configuration system"
+HOMEPAGE="https://wiki.gnome.org/dconf"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+
+# TODO: coverage ?
+IUSE="test X"
+
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~sh sparc x86 ~x86-fbsd ~arm-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-libs/glib-2.39.1:2
+ sys-apps/dbus
+ X? (
+ >=dev-libs/libxml2-2.7.7:2
+ >=x11-libs/gtk+-3.4:3 )
+"
+DEPEND="${RDEPEND}
+ dev-libs/libxslt
+ dev-util/gdbus-codegen
+ >=dev-util/gtk-doc-am-1.15
+ >=dev-util/intltool-0.50
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-gcov \
+ --enable-man \
+ $(use_enable X editor) \
+ VALAC=$(type -P true)
+}
+
+src_test() {
+ Xemake check
+}
+
+src_install() {
+ gnome2_src_install
+
+ # GSettings backend may be one of: memory, gconf, dconf
+ # Only dconf is really considered functional by upstream
+ # must have it enabled over gconf if both are installed
+ echo 'CONFIG_PROTECT_MASK="/etc/dconf"' >> 51dconf
+ echo 'GSETTINGS_BACKEND="dconf"' >> 51dconf
+ doenvd 51dconf
+
+ # Install bash-completion file properly to the system
+ rm -rv "${ED}usr/share/bash-completion" || die
+ dobashcomp "${S}/bin/completion/dconf"
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ # Kill existing dconf-service processes as recommended by upstream due to
+ # possible changes in the dconf private dbus API.
+ # dconf-service will be dbus-activated on next use.
+ pids=$(pgrep -x dconf-service)
+ if [[ $? == 0 ]]; then
+ ebegin "Stopping dconf-service; it will automatically restart on demand"
+ kill ${pids}
+ eend $?
+ fi
+}
diff --git a/gnome-base/dconf/dconf-0.24.0.ebuild b/gnome-base/dconf/dconf-0.24.0.ebuild
new file mode 100644
index 000000000000..ace839397a04
--- /dev/null
+++ b/gnome-base/dconf/dconf-0.24.0.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+
+inherit gnome2 bash-completion-r1 virtualx
+
+DESCRIPTION="Simple low-level configuration system"
+HOMEPAGE="https://wiki.gnome.org/dconf"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+
+# TODO: coverage ?
+IUSE="test"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~arm-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-libs/glib-2.39.1:2
+ sys-apps/dbus
+"
+DEPEND="${RDEPEND}
+ dev-libs/libxslt
+ dev-util/gdbus-codegen
+ >=dev-util/gtk-doc-am-1.15
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-gcov \
+ --enable-man \
+ VALAC=$(type -P true)
+}
+
+src_test() {
+ Xemake check
+}
+
+src_install() {
+ gnome2_src_install
+
+ # GSettings backend may be one of: memory, gconf, dconf
+ # Only dconf is really considered functional by upstream
+ # must have it enabled over gconf if both are installed
+ echo 'CONFIG_PROTECT_MASK="/etc/dconf"' >> 51dconf
+ echo 'GSETTINGS_BACKEND="dconf"' >> 51dconf
+ doenvd 51dconf
+
+ # Install bash-completion file properly to the system
+ rm -rv "${ED}usr/share/bash-completion" || die
+ dobashcomp "${S}/bin/completion/dconf"
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ # Kill existing dconf-service processes as recommended by upstream due to
+ # possible changes in the dconf private dbus API.
+ # dconf-service will be dbus-activated on next use.
+ pids=$(pgrep -x dconf-service)
+ if [[ $? == 0 ]]; then
+ ebegin "Stopping dconf-service; it will automatically restart on demand"
+ kill ${pids}
+ eend $?
+ fi
+}
diff --git a/gnome-base/dconf/metadata.xml b/gnome-base/dconf/metadata.xml
new file mode 100644
index 000000000000..da6fd63d0085
--- /dev/null
+++ b/gnome-base/dconf/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gnome</herd>
+</pkgmetadata>