summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuta Satoh <nigoro.dev@gmail.com>2018-01-10 22:45:32 +0900
committerMichał Górny <mgorny@gentoo.org>2018-01-27 09:22:20 +0100
commitd88029418808330780fe0064e0abb2a7c75b7079 (patch)
tree7c5c0ede466f2acdd4d7619ea088da7a9acc0b6f /gnome-base/gnome-session/gnome-session-3.24.2-r1.ebuild
parentnet-vpn/libreswan: add 3.23 (diff)
downloadgentoo-d88029418808330780fe0064e0abb2a7c75b7079.tar.gz
gentoo-d88029418808330780fe0064e0abb2a7c75b7079.tar.bz2
gentoo-d88029418808330780fe0064e0abb2a7c75b7079.zip
gnome-base/gnome-session: Fix dependency issue for Gentoo/FreeBSD.
Bug: https://bugs.gentoo.org/489984 Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'gnome-base/gnome-session/gnome-session-3.24.2-r1.ebuild')
-rw-r--r--gnome-base/gnome-session/gnome-session-3.24.2-r1.ebuild138
1 files changed, 138 insertions, 0 deletions
diff --git a/gnome-base/gnome-session/gnome-session-3.24.2-r1.ebuild b/gnome-base/gnome-session/gnome-session-3.24.2-r1.ebuild
new file mode 100644
index 000000000000..905dab2736df
--- /dev/null
+++ b/gnome-base/gnome-session/gnome-session-3.24.2-r1.ebuild
@@ -0,0 +1,138 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GNOME2_EAUTORECONF="yes"
+inherit gnome2
+
+DESCRIPTION="Gnome session manager"
+HOMEPAGE="https://git.gnome.org/browse/gnome-session"
+SRC_URI="${SRC_URI}
+ https://dev.gentoo.org/~leio/distfiles/${P}-xorg-default-translations.patch.xz"
+
+LICENSE="GPL-2 LGPL-2 FDL-1.1"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="doc elibc_FreeBSD ipv6 systemd"
+
+# x11-misc/xdg-user-dirs{,-gtk} are needed to create the various XDG_*_DIRs, and
+# create .config/user-dirs.dirs which is read by glib to get G_USER_DIRECTORY_*
+# xdg-user-dirs-update is run during login (see 10-user-dirs-update-gnome below).
+# gdk-pixbuf used in the inhibit dialog
+COMMON_DEPEND="
+ >=dev-libs/glib-2.46.0:2[dbus]
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-3.18.0:3
+ >=dev-libs/json-glib-0.10
+ >=gnome-base/gnome-desktop-3.18:3=
+ elibc_FreeBSD? ( || ( dev-libs/libexecinfo >=sys-freebsd/freebsd-lib-10.0 ) )
+
+ media-libs/mesa[egl,gles2]
+
+ media-libs/libepoxy
+ x11-libs/libSM
+ x11-libs/libICE
+ x11-libs/libXau
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ x11-libs/libXext
+ x11-libs/libXrender
+ x11-libs/libXtst
+ x11-misc/xdg-user-dirs
+ x11-misc/xdg-user-dirs-gtk
+ x11-apps/xdpyinfo
+
+ systemd? ( >=sys-apps/systemd-183:0= )
+"
+# Pure-runtime deps from the session files should *NOT* be added here
+# Otherwise, things like gdm pull in gnome-shell
+# gnome-themes-standard is needed for the failwhale dialog themeing
+# sys-apps/dbus[X] is needed for session management
+RDEPEND="${COMMON_DEPEND}
+ >=gnome-base/gnome-settings-daemon-3.23.2
+ >=gnome-base/gsettings-desktop-schemas-0.1.7
+ x11-themes/adwaita-icon-theme
+ sys-apps/dbus[X]
+ !systemd? (
+ sys-auth/consolekit
+ >=dev-libs/dbus-glib-0.76
+ )
+"
+DEPEND="${COMMON_DEPEND}
+ dev-libs/libxslt
+ >=dev-util/intltool-0.40.6
+ >=sys-devel/gettext-0.10.40
+ virtual/pkgconfig
+ !<gnome-base/gdm-2.20.4
+ doc? (
+ app-text/xmlto
+ dev-libs/libxslt )
+ gnome-base/gnome-common
+"
+# gnome-common needed for eautoreconf
+# gnome-base/gdm does not provide gnome.desktop anymore
+
+PATCHES=(
+ # Restore Xorg as the default GNOME session instead of Wayland for the 3.24 release, bug 641988
+ "${FILESDIR}/3.22.3-xorg-default.patch" # remove ewarn about this below when removing for 3.26; also eautoreconf if possible
+ "${WORKDIR}/${P}-xorg-default-translations.patch"
+)
+
+src_configure() {
+ # 1. Avoid automagic on old upower releases
+ # 2. xsltproc is always checked due to man configure
+ # switch, even if USE=-doc
+ # 3. Disable old gconf support as other distributions did long time
+ # ago
+ gnome2_src_configure \
+ --disable-deprecation-flags \
+ --disable-gconf \
+ --enable-session-selector \
+ $(use_enable doc docbook-docs) \
+ $(use_enable ipv6) \
+ $(use_enable systemd) \
+ $(use_enable !systemd consolekit) \
+ UPOWER_CFLAGS="" \
+ UPOWER_LIBS=""
+ # gnome-session-selector pre-generated man page is missing
+ #$(usex !doc XSLTPROC=$(type -P true))
+}
+
+src_install() {
+ gnome2_src_install
+
+ dodir /etc/X11/Sessions
+ exeinto /etc/X11/Sessions
+ doexe "${FILESDIR}/Gnome"
+
+ insinto /usr/share/applications
+ newins "${FILESDIR}/defaults.list-r3" gnome-mimeapps.list
+
+ dodir /etc/X11/xinit/xinitrc.d/
+ exeinto /etc/X11/xinit/xinitrc.d/
+ newexe "${FILESDIR}/15-xdg-data-gnome-r1" 15-xdg-data-gnome
+
+ # This should be done here as discussed in bug #270852
+ newexe "${FILESDIR}/10-user-dirs-update-gnome-r1" 10-user-dirs-update-gnome
+
+ # Set XCURSOR_THEME from current dconf setting instead of installing
+ # default cursor symlink globally and affecting other DEs (bug #543488)
+ # https://bugzilla.gnome.org/show_bug.cgi?id=711703
+ newexe "${FILESDIR}/90-xcursor-theme-gnome" 90-xcursor-theme-gnome
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+
+ ewarn "The Gentoo GNOME team has decided to retain Xorg session default instead of"
+ ewarn "Wayland for GNOME 3.24 stable version, even if USE=wayland is set on applicable"
+ ewarn "packages. You can still choose the 'GNOME on Wayland' session explicitly, if"
+ ewarn "desired. GNOME 3.26 will default to Wayland again as upstream GNOME does, if"
+ ewarn "USE=wayland is used globally, but 'GNOME on Xorg' session will remain a choice."
+ ewarn "Default enabling USE=wayland via gnome profiles is planned with 3.26 as well."
+
+ if ! has_version gnome-base/gdm && ! has_version x11-misc/sddm; then
+ ewarn "If you use a custom .xinitrc for your X session,"
+ ewarn "make sure that the commands in the xinitrc.d scripts are run."
+ fi
+}