summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-10-24 15:07:38 +0200
committerLars Wendler <polynomial-c@gentoo.org>2018-10-24 15:08:25 +0200
commitac43ef9f87e64583606d6654b1ede19a16d3abdd (patch)
treeb3b5ae6714ec8cb504e61a83ca11e686bb85f6b3 /gnome-base/gnome-vfs
parentdev-python/wsproto: Version bump to 0.12.0 (diff)
downloadgentoo-ac43ef9f87e64583606d6654b1ede19a16d3abdd.tar.gz
gentoo-ac43ef9f87e64583606d6654b1ede19a16d3abdd.tar.bz2
gentoo-ac43ef9f87e64583606d6654b1ede19a16d3abdd.zip
gnome-base/gnome-vfs: Fixed build with openssl-1.1
Closes: https://bugs.gentoo.org/592540 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'gnome-base/gnome-vfs')
-rw-r--r--gnome-base/gnome-vfs/files/gnome-vfs-2.24.4-openssl-1.1.patch26
-rw-r--r--gnome-base/gnome-vfs/gnome-vfs-2.24.4-r5.ebuild35
2 files changed, 47 insertions, 14 deletions
diff --git a/gnome-base/gnome-vfs/files/gnome-vfs-2.24.4-openssl-1.1.patch b/gnome-base/gnome-vfs/files/gnome-vfs-2.24.4-openssl-1.1.patch
new file mode 100644
index 000000000000..14207f28d19b
--- /dev/null
+++ b/gnome-base/gnome-vfs/files/gnome-vfs-2.24.4-openssl-1.1.patch
@@ -0,0 +1,26 @@
+$NetBSD: patch-libgnomevfs_gnome-vfs-ssl.c,v 1.1 2018/02/16 13:18:26 wiz Exp $
+
+struct SSL is opaque in openssl-1.1; and the SSL_free() man page
+says that one should not free members of it manually (in both
+the openssl-1.0 and openssl-1.1 man pages).
+
+--- libgnomevfs/gnome-vfs-ssl.c.orig 2010-02-09 12:16:14.000000000 +0000
++++ libgnomevfs/gnome-vfs-ssl.c
+@@ -400,9 +400,6 @@ gnome_vfs_ssl_create_from_fd (GnomeVFSSS
+ }
+ }
+
+- if (ssl->private->ssl->ctx)
+- SSL_CTX_free (ssl->private->ssl->ctx);
+-
+ SSL_free (ssl->private->ssl);
+ g_free (ssl->private);
+ g_free (ssl);
+@@ -705,7 +702,6 @@ gnome_vfs_ssl_destroy (GnomeVFSSSL *ssl,
+ }
+ }
+
+- SSL_CTX_free (ssl->private->ssl->ctx);
+ SSL_free (ssl->private->ssl);
+ close (ssl->private->sockfd);
+ if (ssl->private->timeout)
diff --git a/gnome-base/gnome-vfs/gnome-vfs-2.24.4-r5.ebuild b/gnome-base/gnome-vfs/gnome-vfs-2.24.4-r5.ebuild
index 7b788c1a09d7..ad3dca34e334 100644
--- a/gnome-base/gnome-vfs/gnome-vfs-2.24.4-r5.ebuild
+++ b/gnome-base/gnome-vfs/gnome-vfs-2.24.4-r5.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -47,43 +47,50 @@ DEPEND="${RDEPEND}
>=dev-util/gtk-doc-am-1.13
"
-src_prepare() {
+PATCHES=(
# Allow the Trash on afs filesystems (#106118)
- epatch "${FILESDIR}"/${PN}-2.12.0-afs.patch
+ "${FILESDIR}"/${PN}-2.12.0-afs.patch
# Fix compiling with headers missing
- epatch "${FILESDIR}"/${PN}-2.15.2-headers-define.patch
+ "${FILESDIR}"/${PN}-2.15.2-headers-define.patch
# Fix for crashes running programs via sudo
- epatch "${FILESDIR}"/${PN}-2.16.0-no-dbus-crash.patch
+ "${FILESDIR}"/${PN}-2.16.0-no-dbus-crash.patch
# Fix automagic dependencies, upstream bug #493475
- epatch "${FILESDIR}"/${PN}-2.20.0-automagic-deps.patch
- epatch "${FILESDIR}"/${PN}-2.20.1-automagic-deps.patch
+ "${FILESDIR}"/${PN}-2.20.0-automagic-deps.patch
+ "${FILESDIR}"/${PN}-2.20.1-automagic-deps.patch
# Fix to identify ${HOME} (#200897)
# thanks to debian folks
- epatch "${FILESDIR}"/${PN}-2.24.4-home_dir_fakeroot.patch
+ "${FILESDIR}"/${PN}-2.24.4-home_dir_fakeroot.patch
# Configure with gnutls-2.7, bug #253729
# Fix building with gnutls-2.12, bug #388895
- epatch "${FILESDIR}"/${PN}-2.24.4-gnutls27.patch
+ "${FILESDIR}"/${PN}-2.24.4-gnutls27.patch
# Prevent duplicated volumes, bug #193083
- epatch "${FILESDIR}"/${PN}-2.24.0-uuid-mount.patch
+ "${FILESDIR}"/${PN}-2.24.0-uuid-mount.patch
# Do not build tests with FEATURES="-test", bug #226221
- epatch "${FILESDIR}"/${PN}-2.24.4-build-tests-asneeded.patch
+ "${FILESDIR}"/${PN}-2.24.4-build-tests-asneeded.patch
# Disable broken test, bug #285706
- epatch "${FILESDIR}"/${PN}-2.24.4-disable-test-async-cancel.patch
+ "${FILESDIR}"/${PN}-2.24.4-disable-test-async-cancel.patch
# Fix for automake-1.13 compatibility, #466944
- epatch "${FILESDIR}"/${P}-automake-1.13.patch
+ "${FILESDIR}"/${P}-automake-1.13.patch
# Fix gnutls-3.4+ compatibility, #560084
# always use system defaults (patch from Arch Linux)
- epatch "${FILESDIR}"/${P}-gnutls34.patch
+ "${FILESDIR}"/${P}-gnutls34.patch
+
+ # Fix build with openssl-1.1 #592540
+ "${FILESDIR}"/${PN}-2.24.4-openssl-1.1.patch
+)
+
+src_prepare() {
+ epatch "${PATCHES[@]}"
sed -e "s/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/" -i configure.in || die