summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-05-05 11:00:04 -0400
committerMatt Turner <mattst88@gentoo.org>2021-05-12 15:07:33 -0700
commitb93e3e581161111eba0a64d68376aea1fad7dfbd (patch)
tree7945bd9111da0529c5356f66ad9505492ba82c33 /gnome-base/gnome
parentgnome-base/gnome-light: Version bump to 40.0 (diff)
downloadgentoo-b93e3e581161111eba0a64d68376aea1fad7dfbd.tar.gz
gentoo-b93e3e581161111eba0a64d68376aea1fad7dfbd.tar.bz2
gentoo-b93e3e581161111eba0a64d68376aea1fad7dfbd.zip
gnome-base/gnome: Version bump to 40.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'gnome-base/gnome')
-rw-r--r--gnome-base/gnome/gnome-40.0.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/gnome-base/gnome/gnome-40.0.ebuild b/gnome-base/gnome/gnome-40.0.ebuild
new file mode 100644
index 000000000000..5aaa2695cee3
--- /dev/null
+++ b/gnome-base/gnome/gnome-40.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Meta package for GNOME 3, merge this package to install"
+HOMEPAGE="https://www.gnome.org/"
+
+LICENSE="metapackage"
+SLOT="2.0" # Cannot be installed at the same time as gnome-2
+
+# when unmasking for an arch
+# double check none of the deps are still masked !
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+IUSE="accessibility +bluetooth +classic cups +extras"
+
+S=${WORKDIR}
+
+# TODO: check accessibility completeness
+RDEPEND="
+ >=gnome-base/gnome-core-libs-${PV}[cups?]
+ >=gnome-base/gnome-core-apps-${PV}[cups?,bluetooth?]
+
+ >=gnome-base/gdm-40.0
+
+ >=x11-wm/mutter-${PV}
+ >=gnome-base/gnome-shell-${PV}[bluetooth?]
+ >=media-fonts/cantarell-0.301
+
+ >=x11-themes/gnome-backgrounds-40.0
+ x11-themes/sound-theme-freedesktop
+
+ accessibility? (
+ >=app-accessibility/at-spi2-atk-2.38.0
+ >=app-accessibility/at-spi2-core-2.40.0
+ >=app-accessibility/orca-40.0
+ >=gnome-extra/mousetweaks-3.32.0
+ )
+ classic? ( >=gnome-extra/gnome-shell-extensions-40.0 )
+ extras? ( >=gnome-base/gnome-extra-apps-${PV} )
+"
+PDEPEND=">=gnome-base/gvfs-1.48.0[udisks]"
+
+DEPEND=""
+BDEPEND=""
+
+pkg_postinst() {
+ # Remind people where to find our project information
+ elog "Please remember to look at https://wiki.gentoo.org/wiki/Project:GNOME"
+ elog "for information about the project and documentation."
+}