summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2021-04-17 11:11:56 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2021-04-17 21:10:05 +0100
commitf8bdce4c2ac784689c0084a02f77e5a1b50386bf (patch)
treef12dd17b0a55e7fa935e69f55d4ade7e360eecb7 /gnome-base/gsettings-desktop-schemas
parentsci-chemistry/GromacsWrapper: Support newer python versions (diff)
downloadgentoo-f8bdce4c2ac784689c0084a02f77e5a1b50386bf.tar.gz
gentoo-f8bdce4c2ac784689c0084a02f77e5a1b50386bf.tar.bz2
gentoo-f8bdce4c2ac784689c0084a02f77e5a1b50386bf.zip
gnome-base/gsettings-desktop-schemas: use ${EPYTHON}, not python3
Reported-by: Agostino Sarubbo Closes: https://bugs.gentoo.org/762424 Closes: https://github.com/gentoo/gentoo/pull/20419 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'gnome-base/gsettings-desktop-schemas')
-rw-r--r--gnome-base/gsettings-desktop-schemas/gsettings-desktop-schemas-40.0.ebuild11
1 files changed, 10 insertions, 1 deletions
diff --git a/gnome-base/gsettings-desktop-schemas/gsettings-desktop-schemas-40.0.ebuild b/gnome-base/gsettings-desktop-schemas/gsettings-desktop-schemas-40.0.ebuild
index 02aa7efa2db7..32ded1713c2d 100644
--- a/gnome-base/gsettings-desktop-schemas/gsettings-desktop-schemas-40.0.ebuild
+++ b/gnome-base/gsettings-desktop-schemas/gsettings-desktop-schemas-40.0.ebuild
@@ -2,7 +2,9 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit gnome.org gnome2-utils meson xdg
+
+PYTHON_COMPAT=(python3_{6..9})
+inherit gnome.org gnome2-utils meson python-any-r1 xdg
DESCRIPTION="Collection of GSettings schemas for GNOME desktop"
HOMEPAGE="https://git.gnome.org/browse/gsettings-desktop-schemas"
@@ -17,6 +19,7 @@ BDEPEND="
dev-util/glib-utils
>=sys-devel/gettext-0.19.8
virtual/pkgconfig
+ ${PYTHON_DEPS}
"
PATCHES=(
@@ -24,6 +27,12 @@ PATCHES=(
"${FILESDIR}"/3.32.0-default-fonts.patch
)
+src_prepare() {
+ default
+
+ python_fix_shebang build-aux/meson/post-install.py
+}
+
src_configure() {
meson_src_configure $(meson_use introspection)
}