summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-07-31 03:45:54 +0100
committerSam James <sam@gentoo.org>2021-07-31 23:13:35 +0100
commit694fe6b7de8a7d4a69d1fa0c3140b43827675990 (patch)
tree69f30a5c8a54a75253e8feee57f81c10d5cdca61 /gnome-base/gvfs
parentdev-python/python-debian: Stabilize 0.1.40 ALLARCHES, #805425 (diff)
downloadgentoo-694fe6b7de8a7d4a69d1fa0c3140b43827675990.tar.gz
gentoo-694fe6b7de8a7d4a69d1fa0c3140b43827675990.tar.bz2
gentoo-694fe6b7de8a7d4a69d1fa0c3140b43827675990.zip
gnome-base/gvfs: [QA] call tmpfiles_process in pkg_postinst (conditionally)
This is needed to actually apply the tmpfiles configuration we've installed in the ebuild. See tmpfiles.eclass documentation. Revbump for the conditional virtual/tmpfiles dependency. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'gnome-base/gvfs')
-rw-r--r--gnome-base/gvfs/gvfs-1.48.1-r1.ebuild (renamed from gnome-base/gvfs/gvfs-1.48.1.ebuild)12
1 files changed, 10 insertions, 2 deletions
diff --git a/gnome-base/gvfs/gvfs-1.48.1.ebuild b/gnome-base/gvfs/gvfs-1.48.1-r1.ebuild
index be6dd089674b..f4b50cffc64b 100644
--- a/gnome-base/gvfs/gvfs-1.48.1.ebuild
+++ b/gnome-base/gvfs/gvfs-1.48.1-r1.ebuild
@@ -3,7 +3,8 @@
EAPI=7
-inherit gnome.org gnome2-utils meson systemd xdg
+TMPFILES_OPTIONAL=1
+inherit gnome.org gnome2-utils meson systemd tmpfiles xdg
DESCRIPTION="Virtual filesystem implementation for GIO"
HOMEPAGE="https://wiki.gnome.org/Projects/gvfs"
@@ -40,7 +41,10 @@ RDEPEND="
)
zeroconf? ( >=net-dns/avahi-0.6[dbus] )
udev? ( >=dev-libs/libgudev-147:= )
- fuse? ( >=sys-fs/fuse-3.0.0:3 )
+ fuse? (
+ >=sys-fs/fuse-3.0.0:3
+ virtual/tmpfiles
+ )
udisks? ( >=sys-fs/udisks-1.97:2 )
systemd? ( >=sys-apps/systemd-206:0= )
elogind? ( >=sys-auth/elogind-229:0= )
@@ -128,6 +132,10 @@ src_configure() {
}
pkg_postinst() {
+ if use fuse; then
+ tmpfiles_process gvfsd-fuse-tmpfiles.conf
+ fi
+
xdg_pkg_postinst
gnome2_schemas_update
gnome2_giomodule_cache_update