summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-12-09 13:25:18 +0100
committerPacho Ramos <pacho@gentoo.org>2016-12-09 13:33:16 +0100
commit1087707b24e61a211500cf003cb83503ff4868bc (patch)
tree3ac6f0d07b0d05a18fb4d8751306afc2209b265a /gnome-base/libgnomeprintui/files
parentapp-text/gtranslator: Drop old (diff)
downloadgentoo-1087707b24e61a211500cf003cb83503ff4868bc.tar.gz
gentoo-1087707b24e61a211500cf003cb83503ff4868bc.tar.bz2
gentoo-1087707b24e61a211500cf003cb83503ff4868bc.zip
gnome-base/libgnomeprintui: Apply Magia patches for fixing multiple bugs, also use system-config-printer optionally if it's present instead of silently dying, use adwaita-icon-theme and other fixes.
Package-Manager: portage-2.3.2
Diffstat (limited to 'gnome-base/libgnomeprintui/files')
-rw-r--r--gnome-base/libgnomeprintui/files/libgnomeprintui-2.18.6-adwaita-icon-theme.patch12
-rw-r--r--gnome-base/libgnomeprintui/files/libgnomeprintui-2.18.6-intl.patch10
-rw-r--r--gnome-base/libgnomeprintui/files/libgnomeprintui-2.18.6-orientation-for-preview.patch44
-rw-r--r--gnome-base/libgnomeprintui/files/libgnomeprintui-2.18.6-system-config-printer.patch12
4 files changed, 78 insertions, 0 deletions
diff --git a/gnome-base/libgnomeprintui/files/libgnomeprintui-2.18.6-adwaita-icon-theme.patch b/gnome-base/libgnomeprintui/files/libgnomeprintui-2.18.6-adwaita-icon-theme.patch
new file mode 100644
index 000000000000..f1fc4541db65
--- /dev/null
+++ b/gnome-base/libgnomeprintui/files/libgnomeprintui-2.18.6-adwaita-icon-theme.patch
@@ -0,0 +1,12 @@
+diff -up ./configure.in.orig ./configure.in
+--- ./configure.in.orig 2014-05-04 11:07:55.308844477 +0300
++++ ./configure.in 2014-05-04 11:08:26.884571685 +0300
+@@ -64,7 +64,7 @@ PKG_CHECK_MODULES(LIBGNOMEPRINTUI, [
+ gtk+-2.0 >= 2.6.0
+ libgnomeprint-2.2 >= 2.12.1
+ libgnomecanvas-2.0 >= 1.117.0
+- gnome-icon-theme >= 1.1.92
++ adwaita-icon-theme >= 1.1.92
+ ])
+ AC_SUBST(LIBGNOMEPRINTUI_CFLAGS)
+ AC_SUBST(LIBGNOMEPRINTUI_LIBS)
diff --git a/gnome-base/libgnomeprintui/files/libgnomeprintui-2.18.6-intl.patch b/gnome-base/libgnomeprintui/files/libgnomeprintui-2.18.6-intl.patch
new file mode 100644
index 000000000000..db206e6b13e8
--- /dev/null
+++ b/gnome-base/libgnomeprintui/files/libgnomeprintui-2.18.6-intl.patch
@@ -0,0 +1,10 @@
+--- libgnomeprintui-2.18.6/libgnomeprintui/gpaui/Makefile.am~ 2010-02-09 12:33:13.000000000 +0000
++++ libgnomeprintui-2.18.6/libgnomeprintui/gpaui/Makefile.am 2015-11-03 23:16:49.625137517 +0000
+@@ -2,7 +2,6 @@
+
+ INCLUDES = \
+ -I$(top_srcdir) \
+- -I$(top_srcdir)/intl \
+ -I$(top_srcdir)/libgnomeprintui \
+ -DWE_ARE_LIBGNOMEPRINT_INTERNALS \
+ $(LIBGNOMEPRINTUI_CFLAGS) \
diff --git a/gnome-base/libgnomeprintui/files/libgnomeprintui-2.18.6-orientation-for-preview.patch b/gnome-base/libgnomeprintui/files/libgnomeprintui-2.18.6-orientation-for-preview.patch
new file mode 100644
index 000000000000..3a6aa63fe356
--- /dev/null
+++ b/gnome-base/libgnomeprintui/files/libgnomeprintui-2.18.6-orientation-for-preview.patch
@@ -0,0 +1,44 @@
+--- ./libgnomeprintui/gnome-print-job-preview.c.orig 2012-02-23 22:48:42.000000000 +0600
++++ ./libgnomeprintui/gnome-print-job-preview.c 2012-02-25 00:18:43.000000000 +0600
+@@ -152,6 +152,7 @@
+ GtkWidget *last;
+ GnomeCanvas *canvas;
+ GnomePrintConfig *config;
++ guchar *paper_orientation_save;
+
+ guint current_page, current_offset;
+
+@@ -2187,6 +2188,19 @@
+ if (jp->config)
+ g_object_unref (G_OBJECT (jp->config));
+ jp->config = config;
++ if( config ) {
++ guchar *txt = gnome_print_config_get( jp->config, (const guchar*)GNOME_PRINT_KEY_PAGE_ORIENTATION );
++ if( ( g_ascii_strcasecmp(( const gchar* )txt, "R90") == 0 ) ||
++ ( g_ascii_strcasecmp(( const gchar* )txt, "R270") == 0 ) ) {
++ jp->paper_orientation_save =
++ gnome_print_config_get( jp->config, (const guchar*)GNOME_PRINT_KEY_PAPER_ORIENTATION );
++ gnome_print_config_set( jp->config, (const guchar*)GNOME_PRINT_KEY_PAPER_ORIENTATION, txt );
++ g_free ( txt );
++ }
++ else {
++ jp->paper_orientation_save = NULL;
++ }
++ }
+ if (!jp->config)
+ return;
+ g_object_ref (G_OBJECT (jp->config));
+@@ -2389,6 +2403,13 @@
+ {
+ GnomePrintJobPreview *jp = GNOME_PRINT_JOB_PREVIEW (object);
+
++ if( jp->paper_orientation_save ) {
++ gnome_print_config_set( jp->config, (const guchar*)GNOME_PRINT_KEY_PAPER_ORIENTATION,
++ jp->paper_orientation_save );
++ g_free ( jp->paper_orientation_save );
++ jp->paper_orientation_save = NULL;
++ }
++
+ gnome_print_job_preview_set_config (jp, NULL);
+ gnome_print_job_preview_set_job (jp, NULL);
+
diff --git a/gnome-base/libgnomeprintui/files/libgnomeprintui-2.18.6-system-config-printer.patch b/gnome-base/libgnomeprintui/files/libgnomeprintui-2.18.6-system-config-printer.patch
new file mode 100644
index 000000000000..57e188c863b7
--- /dev/null
+++ b/gnome-base/libgnomeprintui/files/libgnomeprintui-2.18.6-system-config-printer.patch
@@ -0,0 +1,12 @@
+diff -p -up libgnomeprintui-2.18.3/libgnomeprintui/gnome-printer-selector.c.system-config-printer libgnomeprintui-2.18.3/libgnomeprintui/gnome-printer-selector.c
+--- libgnomeprintui-2.18.3/libgnomeprintui/gnome-printer-selector.c.system-config-printer 2008-09-23 10:49:59.000000000 +0200
++++ libgnomeprintui-2.18.3/libgnomeprintui/gnome-printer-selector.c 2008-09-23 10:50:47.000000000 +0200
+@@ -47,7 +47,7 @@
+ #include "gpaui/gpa-transport-selector.h"
+
+ #define GPS_PAD 4
+-#define ADD_PRINTER_APP "gnome-cups-add"
++#define ADD_PRINTER_APP "system-config-printer"
+
+ static void gnome_printer_selector_class_init (GnomePrinterSelectorClass *klass);
+ static void gnome_printer_selector_init (GObject *object);