summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-06-25 16:45:37 +0200
committerPacho Ramos <pacho@gentoo.org>2016-06-25 18:25:46 +0200
commit9b894f1a3e01126eb913000783a0c5b78f7dfb19 (patch)
treee8aedab7e54e5f29fed1caa32efe3110eae32c6e /gnome-base/libgtop/libgtop-2.34.0.ebuild
parentgnome-base/gvfs: Version bump (diff)
downloadgentoo-9b894f1a3e01126eb913000783a0c5b78f7dfb19.tar.gz
gentoo-9b894f1a3e01126eb913000783a0c5b78f7dfb19.tar.bz2
gentoo-9b894f1a3e01126eb913000783a0c5b78f7dfb19.zip
gnome-base/libgtop: Version bump
Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'gnome-base/libgtop/libgtop-2.34.0.ebuild')
-rw-r--r--gnome-base/libgtop/libgtop-2.34.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnome-base/libgtop/libgtop-2.34.0.ebuild b/gnome-base/libgtop/libgtop-2.34.0.ebuild
new file mode 100644
index 000000000000..25a2780997e9
--- /dev/null
+++ b/gnome-base/libgtop/libgtop-2.34.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit gnome2
+
+DESCRIPTION="A library that provides top functionality to applications"
+HOMEPAGE="https://git.gnome.org/browse/libgtop"
+
+LICENSE="GPL-2"
+SLOT="2/10" # libgtop soname version
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="+introspection"
+
+RDEPEND="
+ >=dev-libs/glib-2.26:2
+ introspection? ( >=dev-libs/gobject-introspection-0.6.7:= )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.4
+ >=dev-util/intltool-0.35
+ virtual/pkgconfig
+"
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ $(use_enable introspection)
+}