summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-12-18 22:52:02 -0500
committerMatt Turner <mattst88@gentoo.org>2021-12-18 23:53:05 -0500
commit238c0c7a757b9eb2d9d9cb7f735e0643e179f25c (patch)
tree5b7d7641498b463c810669ee11811f862d7b1f2c /gnome-base/nautilus
parentgnome-extra/gnome-calendar: Version bump to 41.2 (diff)
downloadgentoo-238c0c7a757b9eb2d9d9cb7f735e0643e179f25c.tar.gz
gentoo-238c0c7a757b9eb2d9d9cb7f735e0643e179f25c.tar.bz2
gentoo-238c0c7a757b9eb2d9d9cb7f735e0643e179f25c.zip
gnome-base/nautilus: Version bump to 41.1
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'gnome-base/nautilus')
-rw-r--r--gnome-base/nautilus/Manifest1
-rw-r--r--gnome-base/nautilus/files/41.1-optional-gstreamer.patch57
-rw-r--r--gnome-base/nautilus/nautilus-41.1.ebuild108
3 files changed, 166 insertions, 0 deletions
diff --git a/gnome-base/nautilus/Manifest b/gnome-base/nautilus/Manifest
index 622c8809d83b..b3a1b26e4bd8 100644
--- a/gnome-base/nautilus/Manifest
+++ b/gnome-base/nautilus/Manifest
@@ -1 +1,2 @@
DIST nautilus-40.2.tar.xz 3250384 BLAKE2B 8f8bb0c1a060d57695b28df126d421f386d634cbeea007ca30e076eb1b432a4098b98e9a1f39f688f8a920d99ef42ae2d53fe14fb270ba1e7de16aadd037a8d7 SHA512 ff7beab2963231c6e5ccd88098260659dd7fedd38ef6c0b95d66ffa110bfe5adc86477e2c1657eb2fcfe6110384038f75a7e669158712dfc1e2bd3f9e273b268
+DIST nautilus-41.1.tar.xz 3246356 BLAKE2B 558cac6bacd4d4238e8ceb792baa4d85a6aa981e78ae380b6c1256d079cac8e78b3d9b850a01180e4952630eb7898b987f79c12844adca82ab3702b0213d3150 SHA512 1eb2f2a0187f8b6581fe64285f347e8522b971eeb4d1f575387f3767e177f0195e758da9187090155216807b8f49ebed0fbcc29dd3cce6f3e408d7a955ae5286
diff --git a/gnome-base/nautilus/files/41.1-optional-gstreamer.patch b/gnome-base/nautilus/files/41.1-optional-gstreamer.patch
new file mode 100644
index 000000000000..cb4023cd0d2e
--- /dev/null
+++ b/gnome-base/nautilus/files/41.1-optional-gstreamer.patch
@@ -0,0 +1,57 @@
+From 1b908b6cf0422ecb496a5aaf7da25ede9ad12d60 Mon Sep 17 00:00:00 2001
+From: Mart Raudsepp <leio@gentoo.org>
+Date: Thu, 19 Sep 2019 22:26:08 +0300
+Subject: [PATCH] build: Optional gstreamer
+
+---
+ extensions/meson.build | 4 +++-
+ meson.build | 2 ++
+ meson_options.txt | 6 ++++++
+ 3 files changed, 11 insertions(+), 1 deletion(-)
+
+diff --git a/extensions/meson.build b/extensions/meson.build
+index 5c6f64cef..bd8c41d3e 100644
+--- a/extensions/meson.build
++++ b/extensions/meson.build
+@@ -1,3 +1,5 @@
+ subdir('image-properties')
+-subdir('audio-video-properties')
++if get_option('gstreamer')
++ subdir('audio-video-properties')
++endif
+ subdir('sendto')
+diff --git a/meson.build b/meson.build
+index 66e56bda6..d71d597a6 100644
+--- a/meson.build
++++ b/meson.build
+@@ -110,8 +110,10 @@ libm = cc.find_library('m')
+
+ if get_option('extensions')
+ gexiv = dependency('gexiv2', version: '>= 0.12.2')
++ if get_option('gstreamer')
+ gst_tag_dep = dependency('gstreamer-tag-1.0')
+ gst_pbutils_dep = dependency('gstreamer-pbutils-1.0')
++ endif
+ endif
+ gio = dependency('gio-2.0', version: glib_ver)
+ gio_unix = dependency('gio-unix-2.0', version: glib_ver)
+diff --git a/meson_options.txt b/meson_options.txt
+index 6e781c4ef..9ad8d8196 100644
+--- a/meson_options.txt
++++ b/meson_options.txt
+@@ -13,6 +13,12 @@ option(
+ value: true,
+ description: 'Build stock extensions',
+ )
++option(
++ 'gstreamer',
++ type: 'boolean',
++ value: true,
++ description: 'Build audio-video properties extension (requires "extensions")',
++)
+ option(
+ 'introspection',
+ type: 'boolean',
+--
+2.32.0
+
diff --git a/gnome-base/nautilus/nautilus-41.1.ebuild b/gnome-base/nautilus/nautilus-41.1.ebuild
new file mode 100644
index 000000000000..da337e10b426
--- /dev/null
+++ b/gnome-base/nautilus/nautilus-41.1.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit gnome.org gnome2-utils meson readme.gentoo-r1 virtualx xdg
+
+DESCRIPTION="Default file manager for the GNOME desktop"
+HOMEPAGE="https://wiki.gnome.org/Apps/Nautilus"
+
+LICENSE="GPL-3+ LGPL-2.1+"
+SLOT="0"
+IUSE="gnome +gstreamer gtk-doc +introspection +previewer selinux sendto"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="
+ >=dev-libs/glib-2.67.1:2
+ >=media-libs/gexiv2-0.10.0
+ gstreamer? ( media-libs/gstreamer:1.0
+ media-libs/gst-plugins-base:1.0 )
+ >=app-arch/gnome-autoar-0.3.0
+ >=gnome-base/gnome-desktop-3.0.0:3=
+ >=x11-libs/gtk+-3.22.27:3[X,introspection?]
+ >=gui-libs/libhandy-1.1.90:1
+ >=x11-libs/pango-1.28.3
+ selinux? ( >=sys-libs/libselinux-2.0 )
+ >=app-misc/tracker-3.0:3=
+ x11-libs/libX11
+ >=dev-libs/libxml2-2.7.8:2
+ introspection? ( >=dev-libs/gobject-introspection-1.54:= )
+"
+RDEPEND="${DEPEND}
+ gstreamer? ( !<media-video/totem-3.31.91[nautilus] )
+ >=app-misc/tracker-miners-3.0:3=
+" # uses org.freedesktop.Tracker.Miner.Files gsettings schema from tracker-miners
+BDEPEND="
+ >=dev-util/gdbus-codegen-2.51.2
+ >=dev-util/meson-0.57.2
+ dev-util/glib-utils
+ gtk-doc? (
+ >=dev-util/gtk-doc-1.10
+ app-text/docbook-xml-dtd:4.1.2 )
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ x11-base/xorg-proto
+"
+PDEPEND="
+ gnome? ( x11-themes/adwaita-icon-theme )
+ previewer? ( >=gnome-extra/sushi-0.1.9 )
+ sendto? ( >=gnome-extra/nautilus-sendto-3.0.1 )
+ >=gnome-base/gvfs-1.14[gtk(+)]
+" # Need gvfs[gtk] for recent:/// support; always built (without USE=gtk) since gvfs-1.34
+
+PATCHES=(
+ "${FILESDIR}"/3.30.5-docs-build.patch # Always install pregenerated manpage, keeping docs option for gtk-doc
+ "${FILESDIR}"/41.1-optional-gstreamer.patch # Allow controlling audio-video-properties build
+)
+
+src_prepare() {
+ if use previewer; then
+ DOC_CONTENTS="nautilus uses gnome-extra/sushi to preview media files.
+ To activate the previewer, select a file and press space; to
+ close the previewer, press space again."
+ fi
+ xdg_src_prepare
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use gtk-doc docs)
+ -Dextensions=true # image file properties, sendto support; also required for -Dgstreamer=true
+ $(meson_use gstreamer) # gstreamer audio-video-properties extension
+ $(meson_use introspection)
+ -Dlibportal=false # As of 40.2, all libportal usages are flatpak-specific
+ -Dpackagekit=false
+ $(meson_use selinux)
+ -Dprofiling=false
+ -Dtests=$(usex test all none)
+ )
+ meson_src_configure
+}
+
+src_install() {
+ use previewer && readme.gentoo_create_doc
+ meson_src_install
+}
+
+src_test() {
+ gnome2_environment_reset # Avoid dconf that looks at XDG_DATA_DIRS, which can sandbox fail if flatpak is installed
+ virtx meson_src_test
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+
+ if use previewer; then
+ readme.gentoo_print_elog
+ else
+ elog "To preview media files, emerge nautilus with USE=previewer"
+ fi
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}