summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2020-02-22 13:24:20 +0200
committerMart Raudsepp <leio@gentoo.org>2020-02-22 13:52:22 +0200
commit330647523d5f58f67243a7680b72f758b6cac3a5 (patch)
treeae1a00b9161032bacf1026fcc414b86a3998dfb6 /gnome-base
parentgames-engines/qtads: delete old (diff)
downloadgentoo-330647523d5f58f67243a7680b72f758b6cac3a5.tar.gz
gentoo-330647523d5f58f67243a7680b72f758b6cac3a5.tar.bz2
gentoo-330647523d5f58f67243a7680b72f758b6cac3a5.zip
gnome-base/libgtop: bump to 2.40.0
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'gnome-base')
-rw-r--r--gnome-base/libgtop/Manifest1
-rw-r--r--gnome-base/libgtop/libgtop-2.40.0.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/gnome-base/libgtop/Manifest b/gnome-base/libgtop/Manifest
index a807c609a1d0..27814573056f 100644
--- a/gnome-base/libgtop/Manifest
+++ b/gnome-base/libgtop/Manifest
@@ -1 +1,2 @@
DIST libgtop-2.38.0.tar.xz 729700 BLAKE2B 2296741d6c6bd1c9eb17be10e480dabd732e956826c859c176cbc6f8f03259a3b2f2f04d6c55d1c562b082f7e880bb4b7a3f07a66d7f24660085387dce078879 SHA512 96586b7f12a2b63c5ec7f69c51b6e28361a7458f24f20270fc589213bfae43ae99d1e39efb6101d189741bba084c887554f745131e99d8ed90b7db6d53c36e1d
+DIST libgtop-2.40.0.tar.xz 744316 BLAKE2B 3ffd11937e29aacc4b0d5569429ec92835a3743d7cb65336c5c36165b1bb0d817629e73db88c29eff4baf4965791497a8676a897d0de9b394f583fb2cab15b3a SHA512 a9b2135796d7e41c63a6621f672c385d1baeb74d4af3e55c9164aaaae18c66a8a76b09a6ae8b37f89f120092123c38830e0da840c6613a09035ea62339117861
diff --git a/gnome-base/libgtop/libgtop-2.40.0.ebuild b/gnome-base/libgtop/libgtop-2.40.0.ebuild
new file mode 100644
index 000000000000..5413e13da05b
--- /dev/null
+++ b/gnome-base/libgtop/libgtop-2.40.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit flag-o-matic gnome2
+
+DESCRIPTION="A library that provides top functionality to applications"
+HOMEPAGE="https://git.gnome.org/browse/libgtop"
+
+LICENSE="GPL-2+"
+SLOT="2/11" # libgtop soname version
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE="+introspection"
+
+RDEPEND="
+ >=dev-libs/glib-2.26:2
+ introspection? ( >=dev-libs/gobject-introspection-0.6.7:= )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.4
+ >=sys-devel/gettext-0.19.4
+ virtual/pkgconfig
+"
+
+src_configure() {
+ # Add explicit stdc, bug #628256
+ append-cflags "-std=c99"
+
+ gnome2_src_configure \
+ --disable-static \
+ $(use_enable introspection)
+}