summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-06-25 14:05:19 +0200
committerPacho Ramos <pacho@gentoo.org>2016-06-25 14:22:03 +0200
commit3cb7174b3767a7b4c9cb31fdb7d5bd36c99c70af (patch)
tree42fae69eb5da2e07f9cd298e6c84ad1330119db2 /gnome-base
parentgames-puzzle/swell-foop: Version bump (diff)
downloadgentoo-3cb7174b3767a7b4c9cb31fdb7d5bd36c99c70af.tar.gz
gentoo-3cb7174b3767a7b4c9cb31fdb7d5bd36c99c70af.tar.bz2
gentoo-3cb7174b3767a7b4c9cb31fdb7d5bd36c99c70af.zip
gnome-base/dconf: Version bump
Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'gnome-base')
-rw-r--r--gnome-base/dconf/Manifest1
-rw-r--r--gnome-base/dconf/dconf-0.26.0.ebuild69
2 files changed, 70 insertions, 0 deletions
diff --git a/gnome-base/dconf/Manifest b/gnome-base/dconf/Manifest
index 613a03e58957..ebfc03b50b85 100644
--- a/gnome-base/dconf/Manifest
+++ b/gnome-base/dconf/Manifest
@@ -1 +1,2 @@
DIST dconf-0.24.0.tar.xz 218512 SHA256 4373e0ced1f4d7d68d518038796c073696280e22957babb29feb0267c630fec2 SHA512 8c2092f1a3002df386686473e6841d600665b3d2ae0e24625c9943b1a636706ecafc31e05f0db48958bbfd666680bb107f47978a9d867b151d1c61fc3c3b591a WHIRLPOOL 16f2fbf706247ad980c7c7cb3d937f060d4ed7c94209427eecd96d8ca55566e7da60d65d9dbf65b7476824215a0fa3bf0614ecfc6f4749ad017c515991bf9891
+DIST dconf-0.26.0.tar.xz 219688 SHA256 8683292eb31a3fae31e561f0a4220d8569b0f6d882e9958b68373f9043d658c9 SHA512 ea225397a486815c90a113c064d943f113490dfc754e4acba049b033115aa3a6a3849a5cdc133663de09811cde41c963041bc244cfd9ed32d65399889e415d1e WHIRLPOOL 5e4e24aa6083ad5a7a50041772bb7d466eb9cee93725311516fd6070a1b31b8db137772a3c55fa7cfca1675f72f9ab35b70d6aec1b67666eeedfbdfdebd9ac7a
diff --git a/gnome-base/dconf/dconf-0.26.0.ebuild b/gnome-base/dconf/dconf-0.26.0.ebuild
new file mode 100644
index 000000000000..91e57788502c
--- /dev/null
+++ b/gnome-base/dconf/dconf-0.26.0.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit gnome2 bash-completion-r1 virtualx
+
+DESCRIPTION="Simple low-level configuration system"
+HOMEPAGE="https://wiki.gnome.org/action/show/Projects/dconf"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+
+# TODO: coverage ?
+IUSE="test"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~arm-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-libs/glib-2.44.0:2
+"
+DEPEND="${RDEPEND}
+ app-text/docbook-xml-dtd:4.2
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt
+ dev-util/gdbus-codegen
+ >=dev-util/gtk-doc-am-1.15
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-gcov \
+ --enable-man \
+ VALAC=$(type -P true)
+}
+
+src_test() {
+ virtx emake check
+}
+
+src_install() {
+ gnome2_src_install
+
+ # GSettings backend may be one of: memory, gconf, dconf
+ # Only dconf is really considered functional by upstream
+ # must have it enabled over gconf if both are installed
+ echo 'CONFIG_PROTECT_MASK="/etc/dconf"' >> 51dconf
+ echo 'GSETTINGS_BACKEND="dconf"' >> 51dconf
+ doenvd 51dconf
+
+ # Install bash-completion file properly to the system
+ rm -rv "${ED}usr/share/bash-completion" || die
+ dobashcomp "${S}/bin/completion/dconf"
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ # Kill existing dconf-service processes as recommended by upstream due to
+ # possible changes in the dconf private dbus API.
+ # dconf-service will be dbus-activated on next use.
+ pids=$(pgrep -x dconf-service)
+ if [[ $? == 0 ]]; then
+ ebegin "Stopping dconf-service; it will automatically restart on demand"
+ kill ${pids}
+ eend $?
+ fi
+}