summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2019-03-11 18:10:15 +0200
committerMart Raudsepp <leio@gentoo.org>2019-03-11 18:14:28 +0200
commitd4904a90e3816b7fa1153c72a617b255670a19c4 (patch)
treebcc418dab2f25eff988df8b0c2a7c9009cbd8789 /gnome-base
parentmedia-gfx/gnome-photos: remove wrong yelp-tools build depend (diff)
downloadgentoo-d4904a90e3816b7fa1153c72a617b255670a19c4.tar.gz
gentoo-d4904a90e3816b7fa1153c72a617b255670a19c4.tar.bz2
gentoo-d4904a90e3816b7fa1153c72a617b255670a19c4.zip
gnome-base/gnome-core-libs: bump to 3.30.2
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'gnome-base')
-rw-r--r--gnome-base/gnome-core-libs/gnome-core-libs-3.30.2.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/gnome-base/gnome-core-libs/gnome-core-libs-3.30.2.ebuild b/gnome-base/gnome-core-libs/gnome-core-libs-3.30.2.ebuild
new file mode 100644
index 00000000000..7cc7dc16405
--- /dev/null
+++ b/gnome-base/gnome-core-libs/gnome-core-libs-3.30.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Sub-meta package for the core libraries of GNOME 3"
+HOMEPAGE="https://www.gnome.org/"
+LICENSE="metapackage"
+SLOT="3.0"
+IUSE="cups python"
+
+# when unmasking for an arch
+# double check none of the deps are still masked !
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+# Note to developers:
+# This is a wrapper for the core libraries used by GNOME 3
+RDEPEND="
+ >=dev-libs/glib-2.58.1:2
+ >=x11-libs/gdk-pixbuf-2.38.0:2
+ >=x11-libs/pango-1.42.4
+ >=x11-libs/gtk+-3.24.1:3[cups?]
+ >=dev-libs/atk-2.30.0
+ >=gnome-base/librsvg-2.40.20
+ >=gnome-base/gnome-desktop-${PV}:3
+ >=x11-libs/startup-notification-0.12
+
+ >=gnome-base/gvfs-1.38.1
+ >=gnome-base/dconf-0.30.1
+
+ >=media-libs/gstreamer-1.14.4:1.0
+ >=media-libs/gst-plugins-base-1.14.4:1.0
+ >=media-libs/gst-plugins-good-1.14.4:1.0
+
+ python? ( >=dev-python/pygobject-3.30.1:3 )
+"
+DEPEND=""
+
+# >=x11-libs/libwnck-3.24.1:3 - not used by core packages anymore
+# librsvg kept back on non-rust version; should move on at some point for non-exotic arches.
+
+S="${WORKDIR}"